ipq806x: increase kernel partition size for the TP-Link Archer VR2600v
authorStefan Lippers-Hollmann <s.l-h@gmx.de>
Fri, 18 May 2018 01:34:44 +0000 (03:34 +0200)
committerJohn Crispin <john@phrozen.org>
Tue, 22 May 2018 18:34:14 +0000 (20:34 +0200)
The default image does not fit 2 MB anymore, expand kernel partition
to 3 MB.

Upgrading should work transparently via sysupgrade in both directions.
Another option would be to merge "kernel" and "rootfs" into a single
"firmware" partition using MTD_SPLIT_TPLINK_FW, but just changing the
sizes of the existing partitioning has been deemed safer in the absence
of an actual runtime test on an affected device; the maximum for rootfs
changes from 10.4 MB to 9.4 MB.

This change follows the example for the TP-Link Archer C2600, but has
not been runtime tested on a TP-Link Archer VR2600v.

Signed-off-by: Stefan Lippers-Hollmann <s.l-h@gmx.de>
Cc: Sebastian Quilitz <zeraphim@x-pantion.de>
target/linux/ipq806x/files-4.14/arch/arm/boot/dts/qcom-ipq8064-vr2600v.dts
target/linux/ipq806x/files-4.9/arch/arm/boot/dts/qcom-ipq8064-vr2600v.dts
target/linux/ipq806x/image/Makefile

index 561c49aaa67b0cc8ec157180dce675aef90708df..e941fa420a197b4a7d51ebb5c0ec1026ff449649 100644 (file)
 
                                        kernel@320000 {
                                                label = "kernel";
-                                               reg = <0x320000 0x200000>;
+                                               reg = <0x320000 0x300000>;
                                        };
 
-                                       rootfs@520000 {
+                                       rootfs@620000 {
                                                label = "rootfs";
-                                               reg = <0x520000 0xa60000>;
+                                               reg = <0x620000 0x960000>;
                                        };
 
                                        defaultmac: default-mac@0xfaf100 {
index 561c49aaa67b0cc8ec157180dce675aef90708df..e941fa420a197b4a7d51ebb5c0ec1026ff449649 100644 (file)
 
                                        kernel@320000 {
                                                label = "kernel";
-                                               reg = <0x320000 0x200000>;
+                                               reg = <0x320000 0x300000>;
                                        };
 
-                                       rootfs@520000 {
+                                       rootfs@620000 {
                                                label = "rootfs";
-                                               reg = <0x520000 0xa60000>;
+                                               reg = <0x620000 0x960000>;
                                        };
 
                                        defaultmac: default-mac@0xfaf100 {
index e5df7275a16ceaa52b279ec49959e003b6700b6a..8b302b658d5dc120c9b4a2ff3ce27ef4420b23a1 100644 (file)
@@ -215,7 +215,7 @@ define Device/tplink_vr2600v
        KERNEL_SUFFIX := -uImage
        KERNEL = kernel-bin | append-dtb | uImage none
        KERNEL_NAME := zImage
-       KERNEL_SIZE := 2097152
+       KERNEL_SIZE := 3145728
        DEVICE_DTS := qcom-ipq8064-vr2600v
        BLOCKSIZE := 128k
        PAGESIZE := 2048