fix rb532 patch error
authorFelix Fietkau <nbd@openwrt.org>
Wed, 6 Jun 2007 23:34:34 +0000 (23:34 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 6 Jun 2007 23:34:34 +0000 (23:34 +0000)
SVN-Revision: 7511

target/linux/rb532-2.6/patches/140-cmdline_hack.patch
target/linux/rb532-2.6/patches/500-Nand.patch

index 50c299a65753e2ca018f72c876591f269a34b0db..4425af7de4fae33bc3702dc37abfd889086a4648 100644 (file)
@@ -1,28 +1,14 @@
-diff -ur linux.old/arch/mips/kernel/head.S linux.dev/arch/mips/kernel/head.S
---- linux.old/arch/mips/kernel/head.S  2006-12-06 17:30:27.000000000 +0100
-+++ linux.dev/arch/mips/kernel/head.S  2006-12-06 18:34:43.000000000 +0100
-@@ -129,15 +129,20 @@
- #endif
-       .endm
--
+Index: linux-2.6.21.1/arch/mips/kernel/head.S
+===================================================================
+--- linux-2.6.21.1.orig/arch/mips/kernel/head.S        2007-06-07 01:26:11.862575128 +0200
++++ linux-2.6.21.1/arch/mips/kernel/head.S     2007-06-07 01:31:06.499783464 +0200
+@@ -133,6 +133,9 @@
        j kernel_entry
        nop
--
-+      nop
-+      
++EXPORT(_image_cmdline)
++      .ascii "CMDLINE:"
++
        /*
         * Reserved space for exception handlers.
         * Necessary for machines which link their kernels at KSEG0.
-+       * Use as temporary storage for the kernel command line, so that it
-+       * can be updated easily without having to relink the kernel.
-        */
--      .fill   0x400
-+       
-+EXPORT(_image_cmdline)
-+      .ascii "CMDLINE:"
-+      .fill   0x3ec
- EXPORT(stext)                                 # used for profiling
- EXPORT(_stext)
-
index 6189ecb8e509b5d46dc077dd5d3cfb10572c07de..7e4cb65c77080a6548a2f7c5d08777b50b6931fd 100644 (file)
@@ -1,6 +1,7 @@
-diff -urN linux.old/drivers/mtd/nand/Kconfig linux.dev/drivers/mtd/nand/Kconfig
---- linux.old/drivers/mtd/nand/Kconfig 2006-11-29 22:57:37.000000000 +0100
-+++ linux.dev/drivers/mtd/nand/Kconfig 2006-12-14 04:38:51.000000000 +0100
+Index: linux-2.6.21.1/drivers/mtd/nand/Kconfig
+===================================================================
+--- linux-2.6.21.1.orig/drivers/mtd/nand/Kconfig       2007-04-27 23:49:26.000000000 +0200
++++ linux-2.6.21.1/drivers/mtd/nand/Kconfig    2007-06-07 01:31:30.927069952 +0200
 @@ -75,6 +75,12 @@
        help
          Support for NAND flash on Technologic Systems TS-7250 platform.
@@ -14,10 +15,11 @@ diff -urN linux.old/drivers/mtd/nand/Kconfig linux.dev/drivers/mtd/nand/Kconfig
  config MTD_NAND_IDS
        tristate
  
-diff -urN linux.old/drivers/mtd/nand/Makefile linux.dev/drivers/mtd/nand/Makefile
---- linux.old/drivers/mtd/nand/Makefile        2006-11-29 22:57:37.000000000 +0100
-+++ linux.dev/drivers/mtd/nand/Makefile        2006-12-14 04:38:51.000000000 +0100
-@@ -9,6 +9,7 @@
+Index: linux-2.6.21.1/drivers/mtd/nand/Makefile
+===================================================================
+--- linux-2.6.21.1.orig/drivers/mtd/nand/Makefile      2007-04-27 23:49:26.000000000 +0200
++++ linux-2.6.21.1/drivers/mtd/nand/Makefile   2007-06-07 01:31:30.927069952 +0200
+@@ -10,6 +10,7 @@
  obj-$(CONFIG_MTD_NAND_SPIA)           += spia.o
  obj-$(CONFIG_MTD_NAND_AMS_DELTA)      += ams-delta.o
  obj-$(CONFIG_MTD_NAND_TOTO)           += toto.o
@@ -25,4 +27,3 @@ diff -urN linux.old/drivers/mtd/nand/Makefile linux.dev/drivers/mtd/nand/Makefil
  obj-$(CONFIG_MTD_NAND_AUTCPU12)               += autcpu12.o
  obj-$(CONFIG_MTD_NAND_EDB7312)                += edb7312.o
  obj-$(CONFIG_MTD_NAND_AU1550)         += au1550nd.o
-