ramips: remove old code for Edimax BR-6524N
authorJohn Crispin <john@openwrt.org>
Mon, 17 Aug 2015 06:01:23 +0000 (06:01 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 17 Aug 2015 06:01:23 +0000 (06:01 +0000)
It seems that support for Edimax BR-6524N was dropped long time ago (dts file for this device is missing).
This patch removes remaining code.

Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
SVN-Revision: 46630

target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/rt288x/profiles/edimax.mk [deleted file]

index 1456be1abfa11264b19b57526f5fb1dc33758e02..e872b39ffe3ddceec56a681c481b9dbd3bf29c26 100755 (executable)
@@ -70,9 +70,6 @@ case $board in
                set_usb_led "red:diskmounted"
                set_wifi_led "red:wps_active"
                ;;
-       br6524n)
-               set_wifi_led "edimax:blue:wlan"
-               ;;
        cf-wr800n)
                ucidef_set_led_netdev "lan" "lan" "comfast:white:ethernet" eth0.1
                set_wifi_led "comfast:white:wifi"
index 334003d1ee55c31d6b72ce14dcca3a73a8df0f61..8c19b40de6f3c3f443fe9148dcf2244b04bc31e5 100755 (executable)
@@ -182,7 +182,6 @@ ramips_setup_interfaces()
                ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
                ;;
 
-       br6524n | \
        v11st-fe)
                ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
                ucidef_add_switch "switch0" "1" "1"
index f63cf31cb329c9b572c7b6e8a6ab5b1d74db79ec..1e0a15efce7d2219e4fcc0f5b2e6b3d95958c2f4 100644 (file)
@@ -33,9 +33,6 @@ get_status_led() {
        asl26555)
                status_led="asl26555:green:power"
                ;;
-       br6524n)
-               status_led="edimax:blue:power"
-               ;;
        br-6425 | br-6475nd)
                status_led="edimax:green:power"
                ;;
diff --git a/target/linux/ramips/rt288x/profiles/edimax.mk b/target/linux/ramips/rt288x/profiles/edimax.mk
deleted file mode 100644 (file)
index 43ac818..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/BR6524N
-       NAME:=Edimax BR6524N
-       PACKAGES:=kmod-switch-ip17xx kmod-swconfig swconfig
-endef
-
-define Profile/BR6524N/Description
-       Package set for Edimax BR6524N
-endef
-
-$(eval $(call Profile,BR6524N))
-