kernel: bump 4.14 to 4.14.151
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 30 Oct 2019 11:57:20 +0000 (12:57 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 31 Oct 2019 08:17:14 +0000 (09:17 +0100)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm47xx/patches-4.14/159-cpu_fixes.patch
target/linux/generic/pending-4.14/220-optimize_inlining.patch
target/linux/layerscape/patches-4.14/202-core-linux-support-layerscape.patch

index eea1cbfc16fab6430f3a9de7ab6d756aec9786c2..c37db101e64d3a72e6c11b890893d9fcba383d01 100644 (file)
@@ -7,11 +7,11 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-4.9 = .198
-LINUX_VERSION-4.14 = .150
+LINUX_VERSION-4.14 = .151
 LINUX_VERSION-4.19 = .80
 
 LINUX_KERNEL_HASH-4.9.198 = 9572ebfa6ba0efcf9f1ec7b62c7b89baa36a621ab9fd4c5ad025196c549605ac
-LINUX_KERNEL_HASH-4.14.150 = 65c5a4b86b858ba58642f46ae8c983990376d1946e59cc7e054e85b1b7eb57b0
+LINUX_KERNEL_HASH-4.14.151 = ff519c428ee9bbb513a84db5ec32a7e3705cd8c23a57104b25b944cb79583fae
 LINUX_KERNEL_HASH-4.19.80 = 80a9ba764e088aa7fddfef5a97c0236905e291468a37832243b6f3828d36e7ec
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 8dc8664c924d7b2bb585b0a636e2010504c5fdeb..e015610269b63590743f19a300485dc56b8510ec 100644 (file)
        /*
 --- a/arch/mips/mm/tlbex.c
 +++ b/arch/mips/mm/tlbex.c
-@@ -976,6 +976,9 @@ void build_get_pgde32(u32 **p, unsigned
+@@ -983,6 +983,9 @@ void build_get_pgde32(u32 **p, unsigned
                uasm_i_srl(p, ptr, ptr, SMP_CPUID_PTRSHIFT);
                uasm_i_addu(p, ptr, tmp, ptr);
  #else
                UASM_i_LA_mostly(p, ptr, pgdc);
  #endif
                uasm_i_mfc0(p, tmp, C0_BADVADDR); /* get faulting address */
-@@ -1337,6 +1340,9 @@ static void build_r4000_tlb_refill_handl
+@@ -1344,6 +1347,9 @@ static void build_r4000_tlb_refill_handl
  #ifdef CONFIG_64BIT
                build_get_pmde64(&p, &l, &r, K0, K1); /* get pmd in K1 */
  #else
                build_get_pgde32(&p, K0, K1); /* get pgd in K1 */
  #endif
  
-@@ -1348,6 +1354,9 @@ static void build_r4000_tlb_refill_handl
+@@ -1355,6 +1361,9 @@ static void build_r4000_tlb_refill_handl
                build_update_entries(&p, K0, K1);
                build_tlb_write_entry(&p, &l, &r, tlb_random);
                uasm_l_leave(&l, p);
                uasm_i_eret(&p); /* return from trap */
        }
  #ifdef CONFIG_MIPS_HUGE_TLB_SUPPORT
-@@ -2057,6 +2066,9 @@ build_r4000_tlbchange_handler_head(u32 *
+@@ -2064,6 +2073,9 @@ build_r4000_tlbchange_handler_head(u32 *
  #ifdef CONFIG_64BIT
        build_get_pmde64(p, l, r, wr.r1, wr.r2); /* get pmd in ptr */
  #else
        build_get_pgde32(p, wr.r1, wr.r2); /* get pgd in ptr */
  #endif
  
-@@ -2103,6 +2115,9 @@ build_r4000_tlbchange_handler_tail(u32 *
+@@ -2110,6 +2122,9 @@ build_r4000_tlbchange_handler_tail(u32 *
        build_tlb_write_entry(p, l, r, tlb_indexed);
        uasm_l_leave(l, *p);
        build_restore_work_registers(p);
index ff2bed17f31cdfd964a90e7e434225e3900ff0aa..76aabf86db2692b931c1e7f7c4c35d78980e117f 100644 (file)
@@ -11,7 +11,7 @@
        early_print("no ATAGS support: can't continue\n");
 --- a/arch/arm64/include/asm/cpufeature.h
 +++ b/arch/arm64/include/asm/cpufeature.h
-@@ -126,7 +126,7 @@ static inline bool cpu_have_feature(unsi
+@@ -347,7 +347,7 @@ static inline bool cpu_have_feature(unsi
  }
  
  /* System capability check for constant caps */
@@ -20,7 +20,7 @@
  {
        if (num >= ARM64_NCAPS)
                return false;
-@@ -140,7 +140,7 @@ static inline bool cpus_have_cap(unsigne
+@@ -361,7 +361,7 @@ static inline bool cpus_have_cap(unsigne
        return test_bit(num, cpu_hwcaps);
  }
  
index 46650d17fac42e8c3c6ed176bc7cff92cbecfec6..512d323ac6e9c488bca27845d137d9f78679e68e 100644 (file)
@@ -62,7 +62,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
 
 --- a/drivers/base/core.c
 +++ b/drivers/base/core.c
-@@ -161,10 +161,10 @@ static int device_reorder_to_tail(struct
+@@ -162,10 +162,10 @@ static int device_reorder_to_tail(struct
   * of the link.  If DL_FLAG_PM_RUNTIME is not set, DL_FLAG_RPM_ACTIVE will be
   * ignored.
   *
@@ -77,7 +77,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
   *
   * A side effect of the link creation is re-ordering of dpm_list and the
   * devices_kset list by moving the consumer device and all devices depending
-@@ -181,7 +181,8 @@ struct device_link *device_link_add(stru
+@@ -182,7 +182,8 @@ struct device_link *device_link_add(stru
        struct device_link *link;
  
        if (!consumer || !supplier ||
@@ -87,7 +87,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                return NULL;
  
        device_links_write_lock();
-@@ -199,8 +200,10 @@ struct device_link *device_link_add(stru
+@@ -200,8 +201,10 @@ struct device_link *device_link_add(stru
        }
  
        list_for_each_entry(link, &supplier->links.consumers, s_node)
@@ -99,7 +99,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
        link = kzalloc(sizeof(*link), GFP_KERNEL);
        if (!link)
-@@ -232,6 +235,7 @@ struct device_link *device_link_add(stru
+@@ -233,6 +236,7 @@ struct device_link *device_link_add(stru
        link->consumer = consumer;
        INIT_LIST_HEAD(&link->c_node);
        link->flags = flags;
@@ -107,7 +107,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
        /* Determine the initial link state. */
        if (flags & DL_FLAG_STATELESS) {
-@@ -302,8 +306,10 @@ static void __device_link_free_srcu(stru
+@@ -303,8 +307,10 @@ static void __device_link_free_srcu(stru
        device_link_free(container_of(rhead, struct device_link, rcu_head));
  }
  
@@ -119,7 +119,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        dev_info(link->consumer, "Dropping the link to %s\n",
                 dev_name(link->supplier));
  
-@@ -315,8 +321,10 @@ static void __device_link_del(struct dev
+@@ -316,8 +322,10 @@ static void __device_link_del(struct dev
        call_srcu(&device_links_srcu, &link->rcu_head, __device_link_free_srcu);
  }
  #else /* !CONFIG_SRCU */
@@ -131,7 +131,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        dev_info(link->consumer, "Dropping the link to %s\n",
                 dev_name(link->supplier));
  
-@@ -334,18 +342,50 @@ static void __device_link_del(struct dev
+@@ -335,18 +343,50 @@ static void __device_link_del(struct dev
   * @link: Device link to delete.
   *
   * The caller must ensure proper synchronization of this function with runtime
@@ -184,7 +184,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  static void device_links_missing_supplier(struct device *dev)
  {
        struct device_link *link;
-@@ -453,8 +493,8 @@ static void __device_links_no_driver(str
+@@ -454,8 +494,8 @@ static void __device_links_no_driver(str
                if (link->flags & DL_FLAG_STATELESS)
                        continue;
  
@@ -195,7 +195,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                else if (link->status != DL_STATE_SUPPLIER_UNBIND)
                        WRITE_ONCE(link->status, DL_STATE_AVAILABLE);
        }
-@@ -489,8 +529,18 @@ void device_links_driver_cleanup(struct
+@@ -490,8 +530,18 @@ void device_links_driver_cleanup(struct
                if (link->flags & DL_FLAG_STATELESS)
                        continue;
  
@@ -215,7 +215,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                WRITE_ONCE(link->status, DL_STATE_DORMANT);
        }
  
-@@ -607,13 +657,13 @@ static void device_links_purge(struct de
+@@ -608,13 +658,13 @@ static void device_links_purge(struct de
  
        list_for_each_entry_safe_reverse(link, ln, &dev->links.suppliers, c_node) {
                WARN_ON(link->status == DL_STATE_ACTIVE);
@@ -231,7 +231,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        }
  
        device_links_write_unlock();
-@@ -1035,6 +1085,34 @@ static ssize_t online_store(struct devic
+@@ -1036,6 +1086,34 @@ static ssize_t online_store(struct devic
  }
  static DEVICE_ATTR_RW(online);
  
@@ -266,7 +266,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  int device_add_groups(struct device *dev, const struct attribute_group **groups)
  {
        return sysfs_create_groups(&dev->kobj, groups);
-@@ -1206,8 +1284,20 @@ static int device_add_attrs(struct devic
+@@ -1207,8 +1285,20 @@ static int device_add_attrs(struct devic
                        goto err_remove_dev_groups;
        }
  
@@ -287,7 +287,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
   err_remove_dev_groups:
        device_remove_groups(dev, dev->groups);
   err_remove_type_groups:
-@@ -1225,6 +1315,8 @@ static void device_remove_attrs(struct d
+@@ -1226,6 +1316,8 @@ static void device_remove_attrs(struct d
        struct class *class = dev->class;
        const struct device_type *type = dev->type;