ramips: move seama build recipe to Makefile
authorMathias Kresin <dev@kresin.me>
Sat, 3 Sep 2016 07:43:31 +0000 (09:43 +0200)
committerMathias Kresin <dev@kresin.me>
Sat, 3 Sep 2016 07:43:31 +0000 (09:43 +0200)
The identical build step is defined twice. Move it to the parent
Makefile to use only one version.

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ramips/image/Makefile
target/linux/ramips/image/mt7620.mk
target/linux/ramips/image/mt7621.mk

index 2af6d68547f21e8b839734ec6c798813484ac698..39da5e09c0a791f1a3e11af2b0c6faf3627db4e0 100644 (file)
@@ -83,6 +83,15 @@ define Build/senao-header
        mv $@.new $@
 endef
 
+define Build/seama
+       $(STAGING_DIR_HOST)/bin/seama -i $@ $(1)
+       mv $@.seama $@
+endef
+
+define Build/seama-seal
+       $(call Build/seama,-s $@.seama $(1))
+endef
+
 #
 # The real magic happens inside these templates
 #
index 9ccd3d9833a8913a80084ef0cd862fe34b9642eb..003fc7021072e4e6211a4bdee843358d01849152 100644 (file)
@@ -37,15 +37,6 @@ define Build/elecom-header
        $(STAGING_DIR_HOST)/bin/tar -cf $@ -C $(KDIR) v_0.0.0.bin v_0.0.0.md5
 endef
 
-define Build/seama
-       $(STAGING_DIR_HOST)/bin/seama -i $@ $(1)
-       mv $@.seama $@
-endef
-
-define Build/seama-seal
-       $(call Build/seama,-s $@.seama $(1))
-endef
-
 define Device/ArcherC20i
   DTS := ArcherC20i
   KERNEL := $(KERNEL_DTB)
index 47778c4636db2be2a9d1ed28c7212c4a3d47cc4b..769b86b81bcb90bdd698d66f169a2a620c3920f0 100644 (file)
@@ -2,15 +2,6 @@
 # MT7621 Profiles
 #
 
-define Build/seama
-       $(STAGING_DIR_HOST)/bin/seama -i $@ $(1)
-       mv $@.seama $@
-endef
-
-define Build/seama-seal
-       $(call Build/seama,-s $@.seama $(1))
-endef
-
 define Build/ubnt-erx-factory-image
        if [ -e $(KDIR)/tmp/$(KERNEL_INITRAMFS_IMAGE) -a "$$(stat -c%s $@)" -lt "$(KERNEL_SIZE)" ]; then \
                echo '21001:6' > $(1).compat; \