build: add back the package/cleanup step to remove the root staging dir for mklibs
authorFelix Fietkau <nbd@openwrt.org>
Mon, 15 Oct 2012 13:19:45 +0000 (13:19 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 15 Oct 2012 13:19:45 +0000 (13:19 +0000)
SVN-Revision: 33777

Makefile
package/Makefile

index 57575eac54948affe31727d12736e5cf0d15389c..348e64500592d502b100ec2e5cb9fe96d6534f2d 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -40,7 +40,7 @@ else
 
 $(toolchain/stamp-install): $(tools/stamp-install)
 $(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install) $(BUILD_DIR)/.prepared
-$(package/stamp-compile): $(target/stamp-compile)
+$(package/stamp-compile): $(target/stamp-compile) $(package/stamp-cleanup)
 $(package/stamp-install): $(package/stamp-compile)
 $(target/stamp-install): $(package/stamp-compile) $(package/stamp-install)
 
index 63fdb92bae5ae5895f4611fd629bbd529713570c..46bcb9d3c7f3f66276bfe244380b489005c84174 100644 (file)
@@ -73,9 +73,12 @@ OPKG:= \
 PACKAGE_INSTALL:=$(sort $(foreach pkg,$(package-y),$(lastword $(subst /,$(space),$(pkg)))))
 PACKAGE_INSTALL_FILES:=$(patsubst %,$(PKG_INFO_DIR)/%.install,$(PACKAGE_INSTALL))
 
+$(curdir)/cleanup: $(TMP_DIR)/.build
+       rm -rf $(STAGING_DIR_ROOT)
+
 $(curdir)/install: $(TMP_DIR)/.build
        - find $(STAGING_DIR_ROOT) -type d | $(XARGS) chmod 0755
-       rm -rf $(TARGET_DIR) $(STAGING_DIR_ROOT)
+       rm -rf $(TARGET_DIR)
        [ -d $(TARGET_DIR)/tmp ] || mkdir -p $(TARGET_DIR)/tmp
        $(OPKG) install `cat $(PACKAGE_INSTALL_FILES) | sed -e 's,^\(.*\)$$,$(PACKAGE_DIR)/\1_*.ipk,'`
        @for pkg in $(PACKAGE_INSTALL); do \
@@ -121,6 +124,7 @@ $(curdir)/preconfig:
 $(curdir)/flags-install:= -j1
 
 $(eval $(call stampfile,$(curdir),package,prereq,.config))
+$(eval $(call stampfile,$(curdir),package,cleanup,$(TMP_DIR)/.build))
 $(eval $(call stampfile,$(curdir),package,compile,$(TMP_DIR)/.build))
 $(eval $(call stampfile,$(curdir),package,install,$(TMP_DIR)/.build))