ignore filenames that can cause problems for the recursive dependency handling
authorFelix Fietkau <nbd@openwrt.org>
Thu, 26 Jul 2007 11:32:13 +0000 (11:32 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 26 Jul 2007 11:32:13 +0000 (11:32 +0000)
SVN-Revision: 8171

include/depends.mk

index 1e01d35f81bdceb395c1d66e7f45fb9977cc75bd..be58ed1cf08105931b589bb45d6c53c36731d488 100644 (file)
@@ -11,9 +11,9 @@
 #      3: tempfile for file listings
 #      4: find options
 
-DEP_FINDPARAMS := -type f -not -name ".*" -and -not -path "*.svn*" 
+DEP_FINDPARAMS := -type f -not -name ".*" -and -not -path "*.svn*" -type f -not -name ".*" -and -not -path "*.svn*" -and -not -path "*:*" -and -not -path "*!*" -and -not -path "* *" -and -not -path "*\\\#*"
 define rdep
-  $(foreach file,$(shell find $(1) $(DEP_FINDPARAMS) -and -not -path "*:*" $(4)),
+  $(foreach file,$(shell find $(1) $(DEP_FINDPARAMS) $(4)),
     $(2): $(file)
     $(file): ;
   )