Prevent unnecessary host package rebuilds.
authorLars-Peter Clausen <lars@metafoo.de>
Sun, 3 Jan 2010 18:00:28 +0000 (18:00 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Sun, 3 Jan 2010 18:00:28 +0000 (18:00 +0000)
Sometimes `make install` touches a file inside the build directory, so it is
betterr to create the build stamp after calling `make install` otherwise the
package is going to be rebuild even though nothing really changed.

SVN-Revision: 19021

include/host-build.mk

index 8eb49c8f44f6dce754ee321e2869acb8a0b926f5..6324276a70453fa065e82c43f179e25d3686b689 100644 (file)
@@ -130,17 +130,8 @@ ifndef DUMP
        touch $$@
 
   $(call Host/Exports,$(HOST_STAMP_BUILT))
-  $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
-       $(call Host/Compile)
-       touch $$@
-
-  $(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT)
-       $(call Host/Install)
-       mkdir -p $$(shell dirname $$@)
-       touch $$@
-
   ifdef Host/Install
-    host-install: $(HOST_STAMP_INSTALLED)
+    host-install: $(if $(STAMP_BUILT),$(HOST_STAMP_BUILT),$(HOST_STAMP_INSTALLED))
   endif
 
   ifndef STAMP_BUILT
@@ -149,8 +140,20 @@ ifndef DUMP
     install: host-install
     clean: host-clean
     update: host-update
+
+    $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
+               $(call Host/Compile)
+               touch $$@
+
+    $(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT)
+               $(call Host/Install)
+               mkdir -p $$(shell dirname $$@)
+               touch $$@
   else
-    host-compile: $(HOST_STAMP_INSTALLED)
+    $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
+               $(call Host/Compile)
+               $(call Host/Install)
+               touch $$@
   endif
   host-prepare: $(HOST_STAMP_PREPARED)
   host-configure: $(HOST_STAMP_CONFIGURED)