fix tg3 libphy dependency, thanks Acinonyx
authorFlorian Fainelli <florian@openwrt.org>
Tue, 3 Feb 2009 14:26:02 +0000 (14:26 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 3 Feb 2009 14:26:02 +0000 (14:26 +0000)
SVN-Revision: 14390

package/kernel/modules/netdevices.mk

index 454a9f26fa39f66b903f7127325e2e516d93911d..1a819ecb45788906eaf1733d872adda71e06c2ac 100644 (file)
@@ -265,7 +265,7 @@ define KernelPackage/tg3
   TITLE:=Broadcom Tigon3 Gigabit Ethernet
   FILES:=$(LINUX_DIR)/drivers/net/tg3.$(LINUX_KMOD_SUFFIX)
   KCONFIG:=CONFIG_TIGON3
-  DEPENDS:=@LINUX_2_6 +LINUX_2_6_27:kmod-libphy +LINUX_2_6_28:kmod-libphy
+  DEPENDS:=@LINUX_2_6 +LINUX_2_6_27||LINUX_2_6_28:kmod-libphy
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   AUTOLOAD:=$(call AutoLoad,50,tg3)
 endef