lantiq: add a subtarget for the xrx200 SoC family
authorJohn Crispin <john@openwrt.org>
Tue, 17 Sep 2013 21:46:00 +0000 (21:46 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 17 Sep 2013 21:46:00 +0000 (21:46 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 38029

14 files changed:
target/linux/lantiq/Makefile
target/linux/lantiq/image/Makefile
target/linux/lantiq/image/ubinize.cfg [new file with mode: 0644]
target/linux/lantiq/xrx200/config-default [new file with mode: 0644]
target/linux/lantiq/xrx200/profiles/arv.mk [new file with mode: 0644]
target/linux/lantiq/xrx200/profiles/avm.mk [new file with mode: 0644]
target/linux/lantiq/xrx200/profiles/lantiq.mk [new file with mode: 0644]
target/linux/lantiq/xrx200/profiles/tplink.mk [new file with mode: 0644]
target/linux/lantiq/xrx200/target.mk [new file with mode: 0644]
target/linux/lantiq/xway/config-default
target/linux/lantiq/xway/profiles/arv.mk
target/linux/lantiq/xway/profiles/avm.mk
target/linux/lantiq/xway/profiles/lantiq.mk
target/linux/lantiq/xway/profiles/tplink.mk [deleted file]

index 94b506d4eec539e5bde5949fd50d9c5826df9fb1..4b820547fed98309be2682ffe61aa5b66f76c2e6 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 BOARD:=lantiq
 BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs
-SUBTARGETS=xway ase falcon
+SUBTARGETS=xway xrx200 ase falcon
 
 LINUX_VERSION:=3.8.13
 
index e4e3e9e06b83585752a570b1116bc6560bb0d9ce..fea32bef221abc53343dff3f2b04d2d21d7be23a 100644 (file)
@@ -255,6 +255,10 @@ Image/Build/Profile/FRITZ7320=$(call Image/BuildEVA/$(1),$(1),FRITZ7320)
 Image/BuildKernel/Profile/GR7000=$(call Image/BuildKernel/Template,GR7000)
 Image/Build/Profile/GR7000=$(call Image/Build/$(1),$(1),GR7000)
 
+endif
+
+
+ifeq ($(CONFIG_TARGET_lantiq_xrx200),y)
 
 # VR9
 Image/BuildKernel/Profile/EASY80920NAND=$(call Image/BuildKernel/Template,EASY80920NAND)
diff --git a/target/linux/lantiq/image/ubinize.cfg b/target/linux/lantiq/image/ubinize.cfg
new file mode 100644 (file)
index 0000000..49d55b9
--- /dev/null
@@ -0,0 +1,14 @@
+[rootfs]
+# Volume mode (other option is static)
+mode=ubi
+# Source image
+image=root.ubifs
+# Volume ID in UBI image
+vol_id=0
+# Allow for dynamic resize
+vol_type=dynamic
+# Volume name
+vol_name=rootfs
+# Autoresize volume at first mount
+vol_flags=autoresize
+
diff --git a/target/linux/lantiq/xrx200/config-default b/target/linux/lantiq/xrx200/config-default
new file mode 100644 (file)
index 0000000..d888b1e
--- /dev/null
@@ -0,0 +1,43 @@
+CONFIG_ADM6996_PHY=y
+CONFIG_AR8216_PHY=y
+CONFIG_CLONE_BACKWARDS=y
+CONFIG_FIRMWARE_IN_KERNEL=y
+CONFIG_GPIO_DEVRES=y
+# CONFIG_HAVE_64BIT_ALIGNED_ACCESS is not set
+# CONFIG_HAVE_BOOTMEM_INFO_NODE is not set
+CONFIG_HAVE_KVM=y
+CONFIG_HZ_PERIODIC=y
+CONFIG_INPUT=y
+CONFIG_INPUT_EVDEV=y
+CONFIG_INPUT_POLLDEV=y
+CONFIG_IRQCHIP=y
+CONFIG_IRQ_WORK=y
+# CONFIG_ISDN is not set
+CONFIG_LEDS_TRIGGER_HEARTBEAT=y
+CONFIG_M25PXX_USE_FAST_READ=y
+CONFIG_MTD_M25P80=y
+CONFIG_MTD_NAND=y
+CONFIG_MTD_NAND_ECC=y
+CONFIG_MTD_NAND_PLATFORM=y
+CONFIG_MTD_NAND_XWAY=y
+# CONFIG_MTD_PHYSMAP_OF is not set
+# CONFIG_MTD_SM_COMMON is not set
+CONFIG_NLS=y
+CONFIG_PCIE_LANTIQ=y
+# CONFIG_PCI_LANTIQ is not set
+# CONFIG_PROC_DEVICETREE is not set
+# CONFIG_RCU_STALL_COMMON is not set
+CONFIG_RTL8306_PHY=y
+CONFIG_RTL8366S_PHY=y
+CONFIG_RTL8367B_PHY=y
+CONFIG_RTL8367_PHY=y
+CONFIG_SPI=y
+CONFIG_SPI_BITBANG=y
+CONFIG_SPI_GPIO=y
+CONFIG_SPI_MASTER=y
+CONFIG_SPI_XWAY=y
+CONFIG_USB=y
+CONFIG_USB_COMMON=y
+# CONFIG_USB_EHCI_HCD is not set
+CONFIG_USB_SUPPORT=y
+# CONFIG_USB_UHCI_HCD is not set
diff --git a/target/linux/lantiq/xrx200/profiles/arv.mk b/target/linux/lantiq/xrx200/profiles/arv.mk
new file mode 100644 (file)
index 0000000..ebb3fa8
--- /dev/null
@@ -0,0 +1,7 @@
+define Profile/VG3503J
+  NAME:=BT Openreach - ECI VDSL Modem
+  PACKAGES:=kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
+       kmod-ltq-ptm-vr9 ltq-vdsl-app
+endef
+
+$(eval $(call Profile,VG3503J))
diff --git a/target/linux/lantiq/xrx200/profiles/avm.mk b/target/linux/lantiq/xrx200/profiles/avm.mk
new file mode 100644 (file)
index 0000000..77c1a0a
--- /dev/null
@@ -0,0 +1,10 @@
+define Profile/FRITZ3370
+  NAME:=Fritz!Box WLan - FRITZ3370
+  PACKAGES:=kmod-ath9k wpad-mini \
+       kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
+       kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
+       kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
+       ltq-vdsl-app ppp-mod-pppoa
+endef
+
+$(eval $(call Profile,FRITZ3370))
diff --git a/target/linux/lantiq/xrx200/profiles/lantiq.mk b/target/linux/lantiq/xrx200/profiles/lantiq.mk
new file mode 100644 (file)
index 0000000..6380387
--- /dev/null
@@ -0,0 +1,21 @@
+define Profile/EASY80920NOR
+  NAME:=Lantiq VR9 - EASY80920NOR
+  PACKAGES:=kmod-ath9k wpad-mini \
+       kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
+       kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
+       kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
+       ltq-vdsl-app ppp-mod-pppoa
+endef
+
+$(eval $(call Profile,EASY80920NOR))
+
+define Profile/EASY80920NAND
+  NAME:=Lantiq VR9 - EASY80920NAND
+  PACKAGES:=kmod-ath9k wpad-mini \
+       kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
+       kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
+       kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
+       ltq-vdsl-app ppp-mod-pppoa
+endef
+
+$(eval $(call Profile,EASY80920NAND))
diff --git a/target/linux/lantiq/xrx200/profiles/tplink.mk b/target/linux/lantiq/xrx200/profiles/tplink.mk
new file mode 100644 (file)
index 0000000..fd4d760
--- /dev/null
@@ -0,0 +1,11 @@
+define Profile/TDW8970
+  NAME:=TP-LINK TD-W8970
+  PACKAGES:=kmod-ath9k wpad-mini \
+       kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
+       kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
+       kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
+       ltq-vdsl-app ppp-mod-pppoa \
+       kmod-ledtrig-usbdev 
+endef
+
+$(eval $(call Profile,TDW8970))
diff --git a/target/linux/lantiq/xrx200/target.mk b/target/linux/lantiq/xrx200/target.mk
new file mode 100644 (file)
index 0000000..0eb5937
--- /dev/null
@@ -0,0 +1,11 @@
+ARCH:=mips
+SUBTARGET:=xrx200
+BOARDNAME:=XRX200
+FEATURES:=squashfs atm mips16
+CFLAGS+= -mtune=34kc -mdsp
+
+DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug
+
+define Target/Description
+       Lantiq XRX200
+endef
index 6ee3a3bc54ae5ebe801c03d28296a1739a1812d4..9feaa8e1c2294dceeafc7b06fd517045fe8604f3 100644 (file)
@@ -1,9 +1,17 @@
 CONFIG_ADM6996_PHY=y
 CONFIG_AR8216_PHY=y
+CONFIG_CLONE_BACKWARDS=y
 CONFIG_FIRMWARE_IN_KERNEL=y
+CONFIG_GPIO_DEVRES=y
+# CONFIG_HAVE_64BIT_ALIGNED_ACCESS is not set
+# CONFIG_HAVE_BOOTMEM_INFO_NODE is not set
+CONFIG_HAVE_KVM=y
+CONFIG_HZ_PERIODIC=y
 CONFIG_INPUT=y
 CONFIG_INPUT_EVDEV=y
 CONFIG_INPUT_POLLDEV=y
+CONFIG_IRQCHIP=y
+CONFIG_IRQ_WORK=y
 # CONFIG_ISDN is not set
 CONFIG_LEDS_TRIGGER_HEARTBEAT=y
 CONFIG_M25PXX_USE_FAST_READ=y
@@ -13,9 +21,9 @@ CONFIG_MTD_NAND_ECC=y
 CONFIG_MTD_NAND_PLATFORM=y
 CONFIG_MTD_NAND_XWAY=y
 # CONFIG_MTD_PHYSMAP_OF is not set
-# CONFIG_MTD_SM_COMMON is not set
 CONFIG_NLS=y
 # CONFIG_PROC_DEVICETREE is not set
+# CONFIG_RCU_STALL_COMMON is not set
 CONFIG_RTL8306_PHY=y
 CONFIG_RTL8366S_PHY=y
 CONFIG_RTL8367B_PHY=y
@@ -30,3 +38,4 @@ CONFIG_USB_COMMON=y
 # CONFIG_USB_EHCI_HCD is not set
 CONFIG_USB_SUPPORT=y
 # CONFIG_USB_UHCI_HCD is not set
+# CONFIG_XRX200_PHY_FW is not set
index 4528741ea0ac7827bbf544223972829158a2d1e9..32bab8f643823097d4ca3454dcb3e9cfea134709 100644 (file)
@@ -125,11 +125,3 @@ define Profile/ARV752DPW22
 endef
 
 $(eval $(call Profile,ARV752DPW22))
-
-define Profile/VG3503J
-  NAME:=BT Openreach - ECI VDSL Modem
-  PACKAGES:=kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
-       kmod-ltq-ptm-vr9 ltq-vdsl-app
-endef
-
-$(eval $(call Profile,VG3503J))
index 8dba09dc8598689c65546d97a7735be10ff936f4..1ca963b7cbc7664dd655c5fcebaf4905c1e27c3f 100644 (file)
@@ -8,14 +8,3 @@ define Profile/FRITZ7320
 endef
 
 $(eval $(call Profile,FRITZ7320))
-
-define Profile/FRITZ3370
-  NAME:=Fritz!Box WLan - FRITZ3370
-  PACKAGES:=kmod-ath9k wpad-mini \
-       kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
-       kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
-       kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
-       ltq-vdsl-app ppp-mod-pppoa
-endef
-
-$(eval $(call Profile,FRITZ3370))
index b4990b660472b0f51e721e26bd5c084c940196da..800a9f67684e6c668109dc1cb2a42c1c48a2a515 100644 (file)
@@ -3,25 +3,3 @@ define Profile/EASY50712
 endef
 
 $(eval $(call Profile,EASY50712))
-
-define Profile/EASY80920NOR
-  NAME:=Lantiq VR9 - EASY80920NOR
-  PACKAGES:=kmod-ath9k wpad-mini \
-       kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
-       kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
-       kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
-       ltq-vdsl-app ppp-mod-pppoa
-endef
-
-$(eval $(call Profile,EASY80920NOR))
-
-define Profile/EASY80920NAND
-  NAME:=Lantiq VR9 - EASY80920NAND
-  PACKAGES:=kmod-ath9k wpad-mini \
-       kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
-       kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
-       kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
-       ltq-vdsl-app ppp-mod-pppoa
-endef
-
-$(eval $(call Profile,EASY80920NAND))
diff --git a/target/linux/lantiq/xway/profiles/tplink.mk b/target/linux/lantiq/xway/profiles/tplink.mk
deleted file mode 100644 (file)
index fd4d760..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-define Profile/TDW8970
-  NAME:=TP-LINK TD-W8970
-  PACKAGES:=kmod-ath9k wpad-mini \
-       kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
-       kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
-       kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
-       ltq-vdsl-app ppp-mod-pppoa \
-       kmod-ledtrig-usbdev 
-endef
-
-$(eval $(call Profile,TDW8970))