ramips: fix Airlink AR725W factory image build
authorMathias Kresin <dev@kresin.me>
Sat, 4 Feb 2017 10:02:36 +0000 (11:02 +0100)
committerMathias Kresin <dev@kresin.me>
Sat, 4 Feb 2017 12:46:48 +0000 (13:46 +0100)
The factory image can't be bigger than 3328 KByte. If the image is
bigger than that, the gemtek-header tool throws an error and breaks
the build.

Make sure the output file to which the gemtek header should be added
exists and wasn't removed during the check-size step because of it
size. This will prevent hard errors in case the factory image is to big
similar to what is done for sysupgrade images.

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ramips/image/rt288x.mk

index fbe50a282440a11939c6957653aaa812c186f7bf..33830a6e78697004fe5dcc6e0ee3c01daba5d5b8 100644 (file)
@@ -3,7 +3,10 @@
 #
 
 define Build/gemtek-header
-       mkheader_gemtek $@ $@.new $(1) && mv $@.new $@
+       if [ -f $@ ]; then \
+               mkheader_gemtek $@ $@.new $(1) && \
+               mv $@.new $@; \
+       fi
 endef
 
 define Device/ar670w
@@ -22,7 +25,7 @@ define Device/ar725w
   DTS := AR725W
   DEVICE_TITLE := Gemtek AR725W
   IMAGES += factory.bin
-  IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
+  IMAGE/factory.bin := $$(sysupgrade_bin) | check-size 3328k | \
        gemtek-header ar725w
 endef
 TARGET_DEVICES += ar725w