ipq40xx: Add support for Teltonika RUTX10
authorFelix Matouschek <felix@matouschek.org>
Thu, 15 Jul 2021 19:48:11 +0000 (21:48 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 28 Nov 2021 17:39:01 +0000 (18:39 +0100)
This patch adds support for the Teltonika RUTX10.
This device is an industrial DIN-rail router with 4 ethernet ports,
2.4G/5G dualband WiFi, Bluetooth, a USB 2.0 port and two GPIOs.

The RUTX series devices are very similiar so common parts of the DTS
are kept in a DTSI file. They are based on the QCA AP-DK01.1-C1 dev
board.

See https://teltonika-networks.com/product/rutx10 for more info.

Hardware:
  SoC:                 Qualcomm IPQ4018
  RAM:                 256MB DDR3
  SPI Flash 1:         XTX XT25F128B (16MB, NOR)
  SPI Flash 2:         XTX XT26G02AWS (256MB, NAND)
  Ethernet:            Built-in IPQ4018 (SoC, QCA8075), 4x 10/100/1000 ports
  WiFi 1:              Qualcomm QCA4019 IEEE 802.11b/g/n
  Wifi 2:              Qualcomm QCA4019 IEEE 802.11a/n/ac
  USB Hub:             Genesys Logic GL852GT
  Bluetooth:           Qualcomm CSR8510 (A10U)
  LED/GPIO controller: STM32F030 with custom firmware
  Buttons:             Reset button
  Leds:                Power (green, cannot be controlled)
                       WiFi 2.4G activity (green)
                       WiFi 5G activity (green)

MACs Details verified with the stock firmware:
   eth0:             Partition 0:CONFIG Offset: 0x0
   eth1:             = eth0 + 1
   radio0 (2.4 GHz): = eth0 + 2
   radio1 (5.0 GHz): = eth0 + 3
Label MAC address is from eth0.

The LED/GPIO controller needs a separate kernel driver to function.
The driver was extracted from the Teltonika GPL sources and can be
found at following feed: https://github.com/0xFelix/teltonika-rutx-openwrt

USB detection of the bluetooth interface is sometimes a bit flaky. When
not detected power cycle the device. When the bluetooth interface was
detected properly it can be used with bluez / bluetoothctl.

Flash instructions via stock web interface (sysupgrade based):
  1. Set PC to fixed ip address 192.168.1.100
  2. Push reset button and power on the device
  3. Open u-boot HTTP recovery at http://192.168.1.1
  4. Upload latest stock firmware and wait until the device is rebooted
  5. Open stock web interface at http://192.168.1.1
  6. Set some password so the web interface is happy
  7. Go to firmware upgrade settings
  8. Choose
     openwrt-ipq40xx-generic-teltonika_rutx10-squashfs-nand-factory.ubi
  9. Set 'Keep settings' to off
  10. Click update, when warned that it is not a signed image proceed

Return to stock firmware:
  1. Set PC to fixed ip address 192.168.1.100
  2. Push reset button and power on the device
  3. Open u-boot HTTP recovery at http://192.168.1.1
  4. Upload latest stock firmware and wait until the device is rebooted

Note: The DTS expects OpenWrt to be running from the second rootfs
partition. u-boot on these devices hot-patches the DTS so running from the
first rootfs partition should also be possible. If you want to be save follow
the instructions above. u-boot HTTP recovery restores the device so that when
flashing OpenWrt from stock firmware it is flashed to the second rootfs
partition and the DTS matches.

Signed-off-by: Felix Matouschek <felix@matouschek.org>
package/firmware/ipq-wifi/Makefile
package/firmware/ipq-wifi/board-teltonika_rutx.qca4019 [new file with mode: 0644]
target/linux/ipq40xx/base-files/etc/board.d/02_network
target/linux/ipq40xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ipq40xx/base-files/lib/upgrade/platform.sh
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-rutx.dtsi [new file with mode: 0644]
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-rutx10.dts [new file with mode: 0644]
target/linux/ipq40xx/image/generic.mk
target/linux/ipq40xx/patches-5.10/901-arm-boot-add-dts-files.patch
target/linux/ipq40xx/patches-5.4/901-arm-boot-add-dts-files.patch

index 6835363cb6df59c4e1510d0961eb54ae1dc797a3..ebaac48c24e7761a4dc8ec1e2708b9309e2eaba1 100644 (file)
@@ -51,7 +51,8 @@ ALLWIFIBOARDS:= \
        p2w_r619ac \
        plasmacloud_pa1200 \
        plasmacloud_pa2200 \
-       qxwlan_e2600ac
+       qxwlan_e2600ac \
+       teltonika_rutx
 
 ALLWIFIPACKAGES:=$(foreach BOARD,$(ALLWIFIBOARDS),ipq-wifi-$(BOARD))
 
@@ -139,5 +140,6 @@ $(eval $(call generate-ipq-wifi-package,p2w_r619ac,P&W R619AC))
 $(eval $(call generate-ipq-wifi-package,plasmacloud_pa1200,Plasma Cloud PA1200))
 $(eval $(call generate-ipq-wifi-package,plasmacloud_pa2200,Plasma Cloud PA2200))
 $(eval $(call generate-ipq-wifi-package,qxwlan_e2600ac,Qxwlan E2600AC))
+$(eval $(call generate-ipq-wifi-package,teltonika_rutx,Teltonika RUTX))
 
 $(foreach PACKAGE,$(ALLWIFIPACKAGES),$(eval $(call BuildPackage,$(PACKAGE))))
diff --git a/package/firmware/ipq-wifi/board-teltonika_rutx.qca4019 b/package/firmware/ipq-wifi/board-teltonika_rutx.qca4019
new file mode 100644 (file)
index 0000000..440c63a
Binary files /dev/null and b/package/firmware/ipq-wifi/board-teltonika_rutx.qca4019 differ
index 7ccdf97a60ff28b64efe2ddf6cd4814dfaec4528..12e67387fad464a307d3d1d9a0aaf773274be9f3 100644 (file)
@@ -35,7 +35,8 @@ ipq40xx_setup_interfaces()
        zyxel,wre6606)
                ucidef_set_interface_lan "eth0"
                ;;
-       aruba,ap-303h)
+       aruba,ap-303h|\
+       teltonika,rutx10)
                ucidef_set_interfaces_lan_wan "eth0" "eth1"
                ucidef_add_switch "switch0" \
                        "0u@eth0" "2:lan:1" "3:lan:2" "4:lan:3" "0u@eth1" "5:wan"
index 1e1b44592428082fe08ff49812007fdd2c2e8216..f43a3a88b727144e5e1470d17bc6f40abe71cd4a 100644 (file)
@@ -166,6 +166,10 @@ case "$FIRMWARE" in
                caldata_extract "0:ART" 0x1000 0x2f20
                ath10k_patch_mac $(mtd_get_mac_binary "0:MANUDATA" 0x6)
                ;;
+       teltonika,rutx10)
+               caldata_extract "0:ART" 0x1000 0x2f20
+               ath10k_patch_mac $(macaddr_add $(mtd_get_mac_binary "0:CONFIG" 0x0) 2)
+               ;;
        zyxel,nbg6617 |\
        zyxel,wre6606)
                caldata_extract "ART" 0x1000 0x2f20
@@ -285,6 +289,10 @@ case "$FIRMWARE" in
                caldata_extract "0:ART" 0x5000 0x2f20
                ath10k_patch_mac $(macaddr_add $(mtd_get_mac_binary "0:MANUDATA" 0x6) 16)
                ;;
+       teltonika,rutx10)
+               caldata_extract "0:ART" 0x5000 0x2f20
+               ath10k_patch_mac $(macaddr_add $(mtd_get_mac_binary "0:CONFIG" 0x0) 3)
+               ;;
        zyxel,nbg6617 |\
        zyxel,wre6606)
                caldata_extract "ART" 0x5000 0x2f20
index 02833ebc3d54a2bbaf6f930985ef317a76a6e55a..bd55b1712bfbad5ea542fc938e61ddf92451e59d 100644 (file)
@@ -153,6 +153,10 @@ platform_do_upgrade() {
                PART_NAME="inactive"
                platform_do_upgrade_dualboot_datachk "$1"
                ;;
+       teltonika,rutx10)
+               CI_UBIPART="rootfs"
+               nand_do_upgrade "$1"
+               ;;
        zyxel,nbg6617)
                zyxel_do_upgrade "$1"
                ;;
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-rutx.dtsi b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-rutx.dtsi
new file mode 100644 (file)
index 0000000..3673a13
--- /dev/null
@@ -0,0 +1,251 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qcom-ipq4019-ap.dk01.1.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       aliases {
+               label-mac-device = &gmac0;
+       };
+
+       memory {
+               device_type = "memory";
+               reg = <0x80000000 0x10000000>;
+       };
+
+       soc {
+               pinctrl@1000000 {
+                       mdio_pins: mdio_pinmux {
+                               mux_1 {
+                                       pins = "gpio53";
+                                       function = "mdio";
+                                       bias-pull-up;
+                               };
+                               mux_2 {
+                                       pins = "gpio52";
+                                       function = "mdc";
+                                       bias-pull-up;
+                               };
+                       };
+
+                       i2c_0_pins: i2c_0_pinmux {
+                               mux {
+                                       pins = "gpio58", "gpio59";
+                                       function = "blsp_i2c0";
+                                       bias-disable;
+                               };
+                       };
+               };
+
+               keys {
+                       compatible = "gpio-keys";
+
+                       reset {
+                               label = "reset";
+                               gpios = <&tlmm 4 1>;
+                               linux,code = <KEY_RESTART>;
+                       };
+               };
+
+               gpio_export {
+                       compatible = "gpio-export";
+                       #size-cells = <0>;
+
+                       gpio_out {
+                               gpio-export,name = "gpio_out";
+                               gpio-export,output = <0>;
+                               gpio-export,direction_may_change = <0>;
+                               gpios = <&stm32_io 23 GPIO_ACTIVE_HIGH>;
+                       };
+
+                       gpio_in {
+                               gpio-export,name = "gpio_in";
+                               gpio-export,input = <0>;
+                               gpio-export,direction_may_change = <0>;
+                               gpios = <&stm32_io 24 GPIO_ACTIVE_LOW>;
+                       };
+               };
+       };
+};
+
+&blsp1_i2c3 {
+       status = "okay";
+       pinctrl-0 = <&i2c_0_pins>;
+       pinctrl-names = "default";
+       clock-frequency = <400000>;
+
+       stm32_io: stm32@74 {
+               compatible = "tlt,stm32v1";
+               #gpio-cells = <2>;
+               #interrupt-cells = <2>;
+               gpio-controller;
+               interrupt-controller;
+               interrupt-parent = <&tlmm>;
+               interrupts = <5 2>;
+               reg = <0x74>;
+       };
+};
+
+&blsp1_spi1 {
+       cs-gpios = <&tlmm 54 0>, <&tlmm 63 0>;
+       num-cs = <2>;
+
+       xt25f128b@0 {
+               /*
+                * Factory U-boot looks in 0:BOOTCONFIG partition for active
+                * partitions settings and mangles the partition config so
+                * 0:QSEE/0:QSEE_1, 0:CDT/0:CDT_1 and  0:APPSBL/0:APPSBL_1 pairs
+                * can be swaped. It isn't a problem but we never can be sure where
+                * OFW put factory images. "n25q128a11" is required for proper nor
+                * recognition in u-boot.
+                */
+               compatible = "jedec,spi-nor", "n25q128a11";
+               #address-cells = <1>;
+               #size-cells = <1>;
+               reg = <0>;
+               spi-max-frequency = <24000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "0:SBL1";
+                               reg = <0x0 0x40000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "0:MIBIB";
+                               reg = <0x40000 0x20000>;
+                               read-only;
+                       };
+
+                       partition@60000 {
+                               label = "0:BOOTCONFIG";
+                               reg = <0x60000 0x20000>;
+                               read-only;
+                       };
+
+                       partition@80000 {
+                               label = "0:BOOTCONFIG1";
+                               reg = <0x80000 0x20000>;
+                               read-only;
+                       };
+
+                       partition@a0000 {
+                               label = "0:QSEE";
+                               reg = <0xa0000 0x60000>;
+                               read-only;
+                       };
+
+                       partition@100000 {
+                               label = "0:QSEE_1";
+                               reg = <0x100000 0x60000>;
+                               read-only;
+                       };
+
+                       partition@160000 {
+                               label = "0:CDT";
+                               reg = <0x160000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@170000 {
+                               label = "0:CDT_1";
+                               reg = <0x170000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@180000 {
+                               label = "0:DDRPARAMS";
+                               reg = <0x180000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@190000 {
+                               label = "0:APPSBLENV";
+                               reg = <0x190000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@1a0000 {
+                               label = "0:APPSBL";
+                               reg = <0x1a0000 0xa0000>;
+                               read-only;
+                       };
+
+                       partition@240000 {
+                               label = "0:APPSBL_1";
+                               reg = <0x240000 0xa0000>;
+                               read-only;
+                       };
+
+                       partition@2e0000 {
+                               label = "0:ART";
+                               reg = <0x2e0000 0x10000>;
+                               read-only;
+                       };
+
+                       config: partition@2f0000 {
+                               label = "0:CONFIG";
+                               reg = <0x2f0000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@300000 {
+                               label = "0:CONFIG_RW";
+                               reg = <0x300000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@310000 {
+                               label = "0:EVENTSLOG";
+                               reg = <0x310000 0x90000>;
+                               read-only;
+                       };
+               };
+       };
+
+       xt26g02a@1 {
+               /*
+                * Factory U-boot looks in 0:BOOTCONFIG partition for active
+                * partitions settings and mangles the partition config so
+                * rootfs/rootfs_1 pairs can be swaped.
+                * It isn't a problem but we never can be sure where OFW put
+                * factory images. "spinand,mt29f" value is required for proper
+                * nand recognition in u-boot.
+                */
+               compatible = "spi-nand", "spinand,mt29f";
+               #address-cells = <1>;
+               #size-cells = <1>;
+               reg = <1>;
+               spi-max-frequency = <24000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "rootfs_1";
+                               reg = <0x00000000 0x08000000>;
+                       };
+
+                       partition@8000000 {
+                               label = "rootfs";
+                               reg = <0x08000000 0x08000000>;
+                       };
+               };
+       };
+};
+
+&mdio {
+       status = "okay";
+       pinctrl-0 = <&mdio_pins>;
+       pinctrl-names = "default";
+       phy-reset-gpio = <&tlmm 62 0>;
+};
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-rutx10.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-rutx10.dts
new file mode 100644 (file)
index 0000000..d1d6325
--- /dev/null
@@ -0,0 +1,26 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qcom-ipq4018-rutx.dtsi"
+
+/ {
+       model = "Teltonika RUTX10";
+       compatible = "teltonika,rutx10";
+
+       soc {
+               leds {
+                       compatible = "gpio-leds";
+
+                       wifi2g {
+                               label = "green:wifi2g";
+                               gpios = <&stm32_io 19 GPIO_ACTIVE_HIGH>;
+                               linux,default-trigger = "phy0tpt";
+                       };
+
+                       wifi5g {
+                               label = "green:wifi5g";
+                               gpios = <&stm32_io 18 GPIO_ACTIVE_HIGH>;
+                               linux,default-trigger = "phy1tpt";
+                       };
+               };
+       };
+};
index c24eb285234558cf1d6cd1023fae30371078ef77..0d7d7a30d223be108e2288b3e7424c84f3350b80 100644 (file)
@@ -46,6 +46,17 @@ define Build/append-rootfshdr
        dd if=$@.new bs=64 count=1 >> $(IMAGE_KERNEL)
 endef
 
+define Build/append-rutx-metadata
+       echo \
+               '{ \
+                       "device_code": [".*"], \
+                       "hwver": [".*"], \
+                       "batch": [".*"], \
+                       "serial": [".*"], \
+                       "supported_devices":["teltonika,rutx"] \
+               }' | fwtool -I - $@
+endef
+
 define Build/mkmylofw_32m
        $(eval device_id=$(word 1,$(1)))
        $(eval revision=$(word 2,$(1)))
@@ -873,6 +884,22 @@ define Device/qxwlan_e2600ac-c2
 endef
 TARGET_DEVICES += qxwlan_e2600ac-c2
 
+define Device/teltonika_rutx10
+       $(call Device/FitImage)
+       $(call Device/UbiFit)
+       DEVICE_VENDOR := Teltonika
+       DEVICE_MODEL := RUTX10
+       SOC := qcom-ipq4018
+       DEVICE_DTS_CONFIG := config@5
+       KERNEL_INSTALL := 1
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       FILESYSTEMS := squashfs
+       IMAGE/nand-factory.ubi := append-ubi | qsdk-ipq-factory-nand | append-rutx-metadata
+       DEVICE_PACKAGES := ipq-wifi-teltonika_rutx kmod-bluetooth
+endef
+TARGET_DEVICES += teltonika_rutx10
+
 define Device/unielec_u4019-32m
        $(call Device/FitImage)
        DEVICE_VENDOR := Unielec
index 69ba9e4a431f3851836ce078c3854d4211971a29..9817e9c102cf670a61f98ca8ddea8496af10de5b 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -902,11 +902,68 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+@@ -902,11 +902,69 @@ dtb-$(CONFIG_ARCH_QCOM) += \
        qcom-apq8074-dragonboard.dtb \
        qcom-apq8084-ifc6540.dtb \
        qcom-apq8084-mtp.dtb \
@@ -37,6 +37,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 +      qcom-ipq4019-oap100.dtb \
 +      qcom-ipq4018-pa1200.dtb \
 +      qcom-ipq4018-rt-ac58u.dtb \
++      qcom-ipq4018-rutx10.dtb \
 +      qcom-ipq4018-wac510.dtb \
 +      qcom-ipq4018-wre6606.dtb \
 +      qcom-ipq4018-wrtq-329acn.dtb \
index 0846c6668c91fc799ec8545489b72d40efea8ea3..bda2b014a46063a36f8b0ac7264e39ef1ecada79 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -837,11 +837,66 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+@@ -837,11 +837,67 @@ dtb-$(CONFIG_ARCH_QCOM) += \
        qcom-apq8074-dragonboard.dtb \
        qcom-apq8084-ifc6540.dtb \
        qcom-apq8084-mtp.dtb \
@@ -37,6 +37,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 +      qcom-ipq4019-oap100.dtb \
 +      qcom-ipq4018-pa1200.dtb \
 +      qcom-ipq4018-rt-ac58u.dtb \
++      qcom-ipq4018-rutx10.dtb \
 +      qcom-ipq4018-wac510.dtb \
 +      qcom-ipq4018-wre6606.dtb \
 +      qcom-ipq4018-wrtq-329acn.dtb \