iproute2: update version to 3.15.0, refresh patches, add maintainer
authorSteven Barth <cyrus@openwrt.org>
Tue, 17 Jun 2014 12:43:30 +0000 (12:43 +0000)
committerSteven Barth <cyrus@openwrt.org>
Tue, 17 Jun 2014 12:43:30 +0000 (12:43 +0000)
Signed-off-by: Russell Senior <russell@personaltelco.net>
SVN-Revision: 41227

package/network/utils/iproute2/Makefile
package/network/utils/iproute2/patches/006-no_sctp.patch
package/network/utils/iproute2/patches/110-extra-ccopts.patch
package/network/utils/iproute2/patches/200-add-tc_esfq.patch
package/network/utils/iproute2/patches/210-add-act_connmark.patch
package/network/utils/iproute2/patches/300-ip_tiny.patch

index 7cc2fb43c760fe9490bacb8900a3466a4070571d..558855ff4cdb8317fc961bd527b55792d8f4813d 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006-2013 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
-PKG_VERSION:=3.11.0
+PKG_VERSION:=3.15.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://kernel.org/pub/linux/utils/net/iproute2/
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://kernel.org/pub/linux/utils/net/iproute2/
-PKG_MD5SUM:=d7ffb27bc9f0d80577b1f3fb9d1a7689
+PKG_MD5SUM:=5b1711c9d16071959052e369a2682d77
 PKG_BUILD_PARALLEL:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_BUILD_PARALLEL:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
@@ -24,8 +24,9 @@ define Package/iproute2/Default
   TITLE:=Routing control utility ($(2))
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Routing control utility ($(2))
   SECTION:=net
   CATEGORY:=Network
-  URL:=http://linux-net.osdl.org/index.php/Iproute2
+  URL:=http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2
   SUBMENU:=Routing and Redirection
   SUBMENU:=Routing and Redirection
+  MAINTAINER:=Russell Senior <russell@personaltelco.net>
   DEPENDS:= +libnl-tiny
   VARIANT:=$(1)
 endef
   DEPENDS:= +libnl-tiny
   VARIANT:=$(1)
 endef
index a3ed890450f827241515576601f8cd6b24ff5661..d4a0de00a5f376e75d4ca79ee4312a3ba2ab95f7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/ip/ipxfrm.c
 +++ b/ip/ipxfrm.c
 --- a/ip/ipxfrm.c
 +++ b/ip/ipxfrm.c
-@@ -470,7 +470,6 @@ void xfrm_selector_print(struct xfrm_sel
+@@ -469,7 +469,6 @@ void xfrm_selector_print(struct xfrm_sel
        switch (sel->proto) {
        case IPPROTO_TCP:
        case IPPROTO_UDP:
        switch (sel->proto) {
        case IPPROTO_TCP:
        case IPPROTO_UDP:
@@ -8,7 +8,7 @@
        case IPPROTO_DCCP:
        default: /* XXX */
                if (sel->sport_mask)
        case IPPROTO_DCCP:
        default: /* XXX */
                if (sel->sport_mask)
-@@ -1283,7 +1282,6 @@ static int xfrm_selector_upspec_parse(st
+@@ -1282,7 +1281,6 @@ static int xfrm_selector_upspec_parse(st
                switch (sel->proto) {
                case IPPROTO_TCP:
                case IPPROTO_UDP:
                switch (sel->proto) {
                case IPPROTO_TCP:
                case IPPROTO_UDP:
index 4a08757bd913cdc32cc232d0c1aea8ef34f5a247..0e3623001226ad7bcf5d24b2c543c2719d847f5a 100644 (file)
@@ -7,5 +7,5 @@
 -CCOPTS = -O2
 +CCOPTS = -O2 $(EXTRA_CCOPTS)
  WFLAGS := -Wall -Wstrict-prototypes  -Wmissing-prototypes
 -CCOPTS = -O2
 +CCOPTS = -O2 $(EXTRA_CCOPTS)
  WFLAGS := -Wall -Wstrict-prototypes  -Wmissing-prototypes
- WFLAGS += -Wmissing-declarations -Wold-style-definition
+ WFLAGS += -Wmissing-declarations -Wold-style-definition -Wformat=2
  
  
index f09b45004fe2095ded62f8079253673814bb22c2..19d819974bb27fe5f4b2ab4e7a3225a2df6c76be 100644 (file)
@@ -10,7 +10,7 @@
  TCMODULES += q_tbf.o
 --- a/include/linux/pkt_sched.h
 +++ b/include/linux/pkt_sched.h
  TCMODULES += q_tbf.o
 --- a/include/linux/pkt_sched.h
 +++ b/include/linux/pkt_sched.h
-@@ -222,6 +222,33 @@ struct tc_sfq_xstats {
+@@ -226,6 +226,33 @@ struct tc_sfq_xstats {
        __s32           allot;
  };
  
        __s32           allot;
  };
  
index ac6ba3379280f050b0c34b93758796fd8f39600b..c0bf07aaddc124202b1dc11ea1888aa1c9977576 100644 (file)
@@ -1,13 +1,13 @@
 --- a/tc/Makefile
 +++ b/tc/Makefile
 --- a/tc/Makefile
 +++ b/tc/Makefile
-@@ -38,6 +38,7 @@ TCMODULES += m_mirred.o
+@@ -39,6 +39,7 @@ TCMODULES += m_mirred.o
  TCMODULES += m_nat.o
  TCMODULES += m_pedit.o
  TCMODULES += m_skbedit.o
 +TCMODULES += m_connmark.o
  TCMODULES += m_csum.o
  TCMODULES += m_nat.o
  TCMODULES += m_pedit.o
  TCMODULES += m_skbedit.o
 +TCMODULES += m_connmark.o
  TCMODULES += m_csum.o
+ TCMODULES += m_simple.o
  TCMODULES += p_ip.o
  TCMODULES += p_ip.o
- TCMODULES += p_icmp.o
 --- /dev/null
 +++ b/tc/m_connmark.c
 @@ -0,0 +1,74 @@
 --- /dev/null
 +++ b/tc/m_connmark.c
 @@ -0,0 +1,74 @@
index 43afb9c848fb92980c1e2d8ff81f969987edc0b8..5b0d56c114ef054db10eb62add1761fe93331fac 100644 (file)
@@ -14,7 +14,7 @@
  ALLOBJ=$(IPOBJ) $(RTMONOBJ)
  SCRIPTS=ifcfg rtpr routel routef
  TARGETS=ip rtmon
  ALLOBJ=$(IPOBJ) $(RTMONOBJ)
  SCRIPTS=ifcfg rtpr routel routef
  TARGETS=ip rtmon
-@@ -43,7 +50,7 @@ else
+@@ -42,7 +49,7 @@ else
  
  ip: static-syms.o
  static-syms.o: static-syms.h
  
  ip: static-syms.o
  static-syms.o: static-syms.h
@@ -28,7 +28,7 @@
 @@ -66,29 +66,41 @@ static const struct cmd {
        int (*func)(int argc, char **argv);
  } cmds[] = {
 @@ -66,29 +66,41 @@ static const struct cmd {
        int (*func)(int argc, char **argv);
  } cmds[] = {
-       { "address",    do_ipaddr },
+       { "address",    do_ipaddr },
 +#ifndef IPROUTE2_TINY
        { "addrlabel",  do_ipaddrlabel },
 +#endif
 +#ifndef IPROUTE2_TINY
        { "addrlabel",  do_ipaddrlabel },
 +#endif