Support LibreSSL as provider of openssl
authorFelix Fietkau <nbd@openwrt.org>
Sun, 17 Jan 2016 10:42:32 +0000 (10:42 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 17 Jan 2016 10:42:32 +0000 (10:42 +0000)
The build scripts check for openssl by grepping the string "OpenSSL" in
the output of openssl version command. LibreSSL fails this test as it
outputs something like "LibreSSL 2.2.4". This patch fix the
prereq-bulid.mk file so that it accepts LibreSSL as openssl provider as
well.

Signed-off-by: Marek Behun <kabel@blackhole.sk>
SVN-Revision: 48267

include/prereq-build.mk

index 77fa991b04f2c23534b0e58819b0f49fa71f8cbc..bcb2103047906cebccbc14b23fb856555c00ef53 100644 (file)
@@ -161,7 +161,7 @@ $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
        file --version 2>&1 | grep file))
 
 $(eval $(call SetupHostCommand,openssl,Please install the 'openssl' utility, \
-       openssl version | grep OpenSSL))
+       openssl version | grep '\(OpenSSL\|LibreSSL\)'))
 
 
 # Install ldconfig stub