mt76: update to the latest version, add mt76x0 firmware, enable mt76x0e
authorFelix Fietkau <nbd@nbd.name>
Tue, 16 Oct 2018 10:58:57 +0000 (12:58 +0200)
committerFelix Fietkau <nbd@nbd.name>
Tue, 16 Oct 2018 11:01:11 +0000 (13:01 +0200)
96fa353 mt76: do not store aggregation sequence number for null-data frames
c50dca8 mt76x0: print BBP version only for debug
ddc9e05 mt76x0: correct RF access via RF_CSR register.
02d2385 mt76: allow to identify bus
c438e67 mt76x0: correct RF reg pairs write for PCIe
c83abb8 mt76x0: use bus helper to identify rf access method
9c272ff mt76x0: phy: fix bank check in mt76x0_rf_csr_{wr,rr}
1945d57 mt76: use mt76x02_dev instead of mt76_dev in mt76x02_mcu.c
214eab7 mt76: use mt76x02_dev instead of mt76_dev in mt76x02_phy.c
29bc2ae mt76: use mt76x02_dev instead of mt76_dev in mt76x02_util.c
08ecb5f mt76: use mt76x02_dev instead of mt76_dev in mt76x02_usb_mcu.c
fd9b2b0 mt76: use mt76x02_dev instead of mt76_dev in mt76x02_mac.c
f37bd25 mt76: use mt76x02_dev instead of mt76_dev in mt76x02_txrx.c
48950cb mt76: use mt76x02_dev instead of mt76_dev in mt76x02_eeprom.c
06276cc mt76x0: pci: report firmware version using ethtool
72546ed mt76x0: pci: add missing mac80211 callbacks
4de98cd mt76: disable ldpc coding for mt76x0 devices
f0951c2 mt76x0: pci: add mt76x0_register_device in mt76x0e_register_device
4f3685e mt76: reserve enough room for USB tx skbs
5e6907f mt76x0: remove dma.h
acfc5a9 mt76x0: pci: fix set external PA I/O current
2b79bb7 mt76: mt76x0e: another fix for the external PA current setting
8a0acfd mt76x0: phy: fix restore phase in mt76x0_phy_recalibrate_after_assoc
e9e949b mt76x0: phy: remove channel parameter from mt76x0_phy_set_chan_bbp_params
1775717 mt76: move mt76x02_phy_set_bw in mt76x02-lib module
f82134f mt76: move mt76x02_phy_set_band in mt76x02-lib module
3eaa34f mt76x0: pci: rename mt76x0_phy_calibrate
7269fb4 mt76x0: pci: introduce mt76x0_phy_calirate routine
a514b75 mt76x0: phy: update set_channel for mt76x0e devices
62a1bc5 mt76x0: eeprom: introduce mt76x0_tssi_enabled routine
a48481d mt76x0: phy: add phy/vco temperature compensation
cc34ce9 mt76: move rssi_gain_thresh routines in mt76x02-lib module
eaf9751 mt76: move mt76x02_phy_adjust_vga_gain in mt76/mt76x02_phy.c
2715e7c mt76: introduce mt76x02_init_agc_gain routine
87fcb31 mt76x0: phy: align channel gain logic to mt76x2 one
98f8ef7 mt76x0: phy: do not run calibration during channel switch
cf859ad mt76x2: align mt76x2 and mt76x2u firmware
1f3f767 mt76x2u: align channel gain logic to mt76x2 one
d1c1454 treewide: Replace more open-coded allocation size multiplications
bcbecd2 mt76x0: phy: use proper name convention
b6694e6 mt76x0: phy: simplify rf configuration routines
da129c9 mt76x0: phy: improve code readability in initvals_phy.h
eab7ab1 mt76x0: pci: add get_survey support
9e493f7 mt76: move mt76x02_mac_work routine in mt76x02-lib module
ecec6ba mt76: move mt76x02_debugfs in mt76x02-lib module
4f3b608 mt76x0: use shared debugfs implementation
6aae25b mt76x0: use mt76x02_mac_work as stats handler
b228a45 mt76x2u: introduce mac workqueue support
4671af4 mt76x0: phy: unify calibration between mt76x0u and mt76x0e
5ed28f3 mt76x0: do not perform MCU calibration for MT7630
9b844da add mt7610e firmware

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/mt76/Makefile

index 5238b4c73c9c2acc71489d87edaed49f05845407..29f64f4c8ede38adfb5c735d71491bed961fb121 100644 (file)
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
 
 PKG_SOURCE_URL:=https://github.com/openwrt/mt76
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2018-10-05
-PKG_SOURCE_VERSION:=d533f1351834ba2899897b090aa56a5f5b922bd7
-PKG_MIRROR_HASH:=27e9c4cf876ad26a6f854d2b00d7e3b100980e820444f13986bf66f3f539eed3
+PKG_SOURCE_DATE:=2018-10-16
+PKG_SOURCE_VERSION:=9b844dababa4538363ce9ef0c0ff96e668b07628
+PKG_MIRROR_HASH:=cd928823042cfa8104b7f1950d6cd25097b604b8ac634e5abca19a9ea17035a3
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 PKG_BUILD_PARALLEL:=1
@@ -85,6 +85,15 @@ define KernelPackage/mt76x0-common
   FILES:=$(PKG_BUILD_DIR)/mt76x0/mt76x0-common.ko
 endef
 
+define KernelPackage/mt76x0e
+  $(KernelPackage/mt76-default)
+  TITLE:=MediaTek MT76x0E wireless driver
+  DEPENDS+=+kmod-mt76x0-common
+  FILES:=\
+       $(PKG_BUILD_DIR)/mt76x0/mt76x0e.ko
+  AUTOLOAD:=$(call AutoProbe,mt76x0e)
+endef
+
 define KernelPackage/mt76x0u
   $(KernelPackage/mt76-default)
   TITLE:=MediaTek MT76x0U wireless driver
@@ -154,6 +163,9 @@ endif
 ifdef CONFIG_PACKAGE_kmod-mt76x0-common
   PKG_MAKE_FLAGS += CONFIG_MT76x0_COMMON=m
 endif
+ifdef CONFIG_PACKAGE_kmod-mt76x0e
+  PKG_MAKE_FLAGS += CONFIG_MT76x0E=m
+endif
 ifdef CONFIG_PACKAGE_kmod-mt76x0u
   PKG_MAKE_FLAGS += CONFIG_MT76x0U=m
 endif
@@ -183,6 +195,13 @@ define Package/kmod-mt76/install
        true
 endef
 
+define KernelPackage/mt76x0-common/install
+       $(INSTALL_DIR) $(1)/lib/firmware/mediatek
+       cp \
+               $(PKG_BUILD_DIR)/firmware/mt7610e.bin \
+               $(1)/lib/firmware/mediatek
+endef
+
 define KernelPackage/mt76x2-common/install
        $(INSTALL_DIR) $(1)/lib/firmware
        cp \
@@ -191,6 +210,11 @@ define KernelPackage/mt76x2-common/install
                $(1)/lib/firmware
 endef
 
+define KernelPackage/mt76x0u/install
+       $(INSTALL_DIR) $(1)/lib/firmware/mediatek
+       ln -sf mt7610e.bin $(1)/lib/firmware/mediatek/mt7610u.bin
+endef
+
 define KernelPackage/mt76x2u/install
        $(INSTALL_DIR) $(1)/lib/firmware/mediatek
        ln -sf ../mt7662.bin $(1)/lib/firmware/mediatek/mt7662u.bin
@@ -214,6 +238,7 @@ $(eval $(call KernelPackage,mt76-usb))
 $(eval $(call KernelPackage,mt76x02-usb))
 $(eval $(call KernelPackage,mt76x02-common))
 $(eval $(call KernelPackage,mt76x0-common))
+$(eval $(call KernelPackage,mt76x0e))
 $(eval $(call KernelPackage,mt76x0u))
 $(eval $(call KernelPackage,mt76x2-common))
 $(eval $(call KernelPackage,mt76x2u))