brcm63xx: add DT support for F5D7633
authorJonas Gorski <jogo@openwrt.org>
Mon, 8 Dec 2014 16:11:03 +0000 (16:11 +0000)
committerJonas Gorski <jogo@openwrt.org>
Mon, 8 Dec 2014 16:11:03 +0000 (16:11 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
SVN-Revision: 43574

target/linux/brcm63xx/dts/f5d7633.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/369-MIPS-BCM63XX-populate-the-compatible-to-board_info-l.patch
target/linux/brcm63xx/patches-3.14/558-board_AR1004G.patch
target/linux/brcm63xx/patches-3.18/369-MIPS-BCM63XX-populate-the-compatible-to-board_info-l.patch
target/linux/brcm63xx/patches-3.18/558-board_AR1004G.patch
target/linux/brcm63xx/profiles/belkin.mk [new file with mode: 0644]

diff --git a/target/linux/brcm63xx/dts/f5d7633.dts b/target/linux/brcm63xx/dts/f5d7633.dts
new file mode 100644 (file)
index 0000000..9393413
--- /dev/null
@@ -0,0 +1,30 @@
+/dts-v1/;
+
+/include/ "bcm6348.dtsi"
+
+/ {
+       model = "Belkin F5D7633";
+       compatible = "belkin,f5d7633", "brcm,bcm6348";
+};
+
+&pflash {
+       status = "ok";
+
+       linux,part-probe = "bcm63xxpart";
+
+       cfe@0 {
+               label = "CFE";
+               reg = <0x000000 0x020000>;
+               read-only;
+       };
+
+       linux@20000 {
+               label = "linux";
+               reg = <0x020000 0x3c0000>;
+       };
+
+       nvram@3e0000 {
+               label = "nvram";
+               reg = <0x3e0000 0x020000>;
+       };
+};
index 09c291aa14a2cea1e4ab9dd3566c0c0b70c85844..0e95a012b54a5cd3211cc6bcb29fee2192c448ad 100755 (executable)
@@ -202,8 +202,6 @@ define Image/Build
 
        # USR 9108
        $(call Image/Build/CFE,$(1),96348GW-A,6348,USR9108)
-       # Belkin f5d7633
-       $(call Image/Build/CFE,$(1),96348GW-10,6348,F5D7633)
 
        # Inventel Livebox
        $(call Image/Build/RedBoot,livebox)
@@ -260,6 +258,8 @@ $(eval $(call ImageDTB,CFEDTB,A4001N1,a4001n1,963281T_TEF,6328,A4001N1,--pad 8))
 $(eval $(call ImageDTB,CFEDTB,RG100A,rg100a,96358VW2,6358,RG100A,--block-size 0x20000 --image-offset 0x20000))
 # Asmax AR 1004g
 $(eval $(call ImageDTB,CFEDTB,AR1004G,ar1004g,96348GW-10,6348,AR1004G))
+# Belkin F5D7633
+$(eval $(call ImageDTB,CFEDTB,F5D7633,f5d7633,96348GW-10,6348,F5D7633,--block-size 0x20000 --image-offset 0x20000))
 # Comtrend AR-5381u
 $(eval $(call ImageDTB,CFEDTB,AR5381u,ar-5381u,96328A-1241N,6328,AR-5381u,--pad 8))
 # Comtrend AR-5387un
index 9e6416d099941fba108d677818dc3014c4c7c46a..63dc96919c8a34bb90f5be57c05afaa66f78a2e6 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -736,6 +736,47 @@ static const struct board_info __initcon
+@@ -736,6 +736,48 @@ static const struct board_info __initcon
  };
  
  static struct of_device_id const bcm963xx_boards_dt[] = {
@@ -33,6 +33,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 +      { .compatible = "brcm,bcm96345gw2", .data = &board_96345gw2, },
 +#endif
 +#ifdef CONFIG_BCM63XX_CPU_6348
++      { .compatible = "belkin,f5d7633", .data = &board_96348gw_10, },
 +      { .compatible = "brcm,bcm96348r", .data = &board_96348r, },
 +      { .compatible = "brcm,bcm96348gw-10", .data = &board_96348gw_10, },
 +      { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
index 92bb0273402d63308c69fcbb815640948dab8a58..0b4009e3e3f73275706102dcb037aa5de3233bfa 100644 (file)
@@ -73,6 +73,6 @@ Signed-off-by: Adrian Feliks <mexit@o2.pl>
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6348
 +      { .compatible = "asmax,ar1004g", .data = &board_96348gw_10_AR1004G, },
+       { .compatible = "belkin,f5d7633", .data = &board_96348gw_10, },
        { .compatible = "brcm,bcm96348r", .data = &board_96348r, },
        { .compatible = "brcm,bcm96348gw-10", .data = &board_96348gw_10, },
-       { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
index 9e6416d099941fba108d677818dc3014c4c7c46a..63dc96919c8a34bb90f5be57c05afaa66f78a2e6 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -736,6 +736,47 @@ static const struct board_info __initcon
+@@ -736,6 +736,48 @@ static const struct board_info __initcon
  };
  
  static struct of_device_id const bcm963xx_boards_dt[] = {
@@ -33,6 +33,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 +      { .compatible = "brcm,bcm96345gw2", .data = &board_96345gw2, },
 +#endif
 +#ifdef CONFIG_BCM63XX_CPU_6348
++      { .compatible = "belkin,f5d7633", .data = &board_96348gw_10, },
 +      { .compatible = "brcm,bcm96348r", .data = &board_96348r, },
 +      { .compatible = "brcm,bcm96348gw-10", .data = &board_96348gw_10, },
 +      { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
index 92bb0273402d63308c69fcbb815640948dab8a58..0b4009e3e3f73275706102dcb037aa5de3233bfa 100644 (file)
@@ -73,6 +73,6 @@ Signed-off-by: Adrian Feliks <mexit@o2.pl>
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6348
 +      { .compatible = "asmax,ar1004g", .data = &board_96348gw_10_AR1004G, },
+       { .compatible = "belkin,f5d7633", .data = &board_96348gw_10, },
        { .compatible = "brcm,bcm96348r", .data = &board_96348r, },
        { .compatible = "brcm,bcm96348gw-10", .data = &board_96348gw_10, },
-       { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
diff --git a/target/linux/brcm63xx/profiles/belkin.mk b/target/linux/brcm63xx/profiles/belkin.mk
new file mode 100644 (file)
index 0000000..4bd50b0
--- /dev/null
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/F5D7633
+  NAME:=Belkin F5D7633
+  PACKAGES:=kmod-b43 wpad-mini
+endef
+define Profile/F5D7633/Description
+  Package set optimized for F5D7633.
+endef
+$(eval $(call Profile,F5D7633))