at91bootstrap: at91bootstrap default selection
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Thu, 4 Jan 2018 19:47:17 +0000 (12:47 -0700)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 9 Jan 2018 21:58:49 +0000 (22:58 +0100)
The fixes following problems
1. changing prefix at91bootstrap to AT91bootstrap will fix the default
   selection of at91bootstrap for the selected sama5 subtarget.
2. fixed missing default selection of sama5d4 nand flash for the
   selected sama5d4 subtarget.
3. corrected at91bootstrap Title name.

Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
package/boot/at91bootstrap/Makefile

index 4571fedc044ac6bfb592233b541e0845d34c5d2e..88b46bbf89d9d7e9661e563922a05da4ff27f507 100644 (file)
@@ -28,50 +28,50 @@ define AT91Bootstrap/Default
   AT91BOOTSTRAP_IMAGE:=at91bootstrap.bin
 endef
 
-define at91bootstrap/sama5d2_xplaineddf_uboot
-  TITLE:=AT91Bootstrap for the SAMA5D2 Xplained board (SPI Flash)
+define AT91Bootstrap/sama5d2_xplaineddf_uboot
+  TITLE:=AT91Bootstrap for SAMA5D2 Xplained board (SPI Flash)
   BUILD_SUBTARGET:=sama5
   BUILD_DEVICES:=at91-sama5d2_xplained
 endef
 
-define at91bootstrap/sama5d2_xplaineddf_qspi_uboot
-  TITLE:=AT91Bootstrap for the SAMA5D2 Xplained board (QSPI Flash)
+define AT91Bootstrap/sama5d2_xplaineddf_qspi_uboot
+  TITLE:=AT91Bootstrap for SAMA5D2 Xplained board (QSPI Flash)
   BUILD_SUBTARGET:=sama5
   BUILD_DEVICES:=at91-sama5d2_xplained
 endef
 
-define at91bootstrap/sama5d2_xplainedsd_uboot
-  TITLE:=AT91Bootstrap for the SAMA5D2 Xplained board (SDcard/EMMC)
+define AT91Bootstrap/sama5d2_xplainedsd_uboot
+  TITLE:=AT91Bootstrap for SAMA5D2 Xplained board (SDcard/EMMC)
   BUILD_SUBTARGET:=sama5
   BUILD_DEVICES:=at91-sama5d2_xplained
 endef
 
-define at91bootstrap/sama5d3_xplainednf_uboot
-  TITLE:=AT91Bootstrap for the SAMA5D3 Xplained board (Nand Flash)
+define AT91Bootstrap/sama5d3_xplainednf_uboot
+  TITLE:=AT91Bootstrap for SAMA5D3 Xplained board (Nand Flash)
   BUILD_SUBTARGET:=sama5
   BUILD_DEVICES:=at91-sama5d3_xplained
 endef
 
-define at91bootstrap/sama5d3_xplainedsd_uboot
-  TITLE:=AT91Bootstrap for the SAMA5D3 Xplained board (SDcard)
+define AT91Bootstrap/sama5d3_xplainedsd_uboot
+  TITLE:=AT91Bootstrap for SAMA5D3 Xplained board (SDcard)
   BUILD_SUBTARGET:=sama5
   BUILD_DEVICES:=at91-sama5d3_xplained
 endef
 
-define at91bootstrap/sama5d4_xplainednf_uboot
-  TITLE:=AT91Bootstrap for the SAMA5D4 Xplained board (Nand Flash)
+define AT91Bootstrap/sama5d4_xplainednf_uboot_secure
+  TITLE:=AT91Bootstrap for SAMA5D4 Xplained board (Nand Flash)
   BUILD_SUBTARGET:=sama5
   BUILD_DEVICES:=at91-sama5d4_xplained
 endef
 
-define at91bootstrap/sama5d4_xplaineddf_uboot_secure
-  TITLE:=AT91Bootstrap for the SAMA5D4 Xplained board (SPI Flash)
+define AT91Bootstrap/sama5d4_xplaineddf_uboot_secure
+  TITLE:=AT91Bootstrap for SAMA5D4 Xplained board (SPI Flash)
   BUILD_SUBTARGET:=sama5
   BUILD_DEVICES:=at91-sama5d4_xplained
 endef
 
-define at91bootstrap/sama5d4_xplainedsd_uboot_secure
-  TITLE:=AT91Bootstrap for the SAMA5D4 Xplained board (SDcard)
+define AT91Bootstrap/sama5d4_xplainedsd_uboot_secure
+  TITLE:=AT91Bootstrap for SAMA5D4 Xplained board (SDcard)
   BUILD_SUBTARGET:=sama5
   BUILD_DEVICES:=at91-sama5d4_xplained
 endef