gengetopt: fix parallel build issues (#18442)
authorFelix Fietkau <nbd@openwrt.org>
Sun, 30 Nov 2014 20:12:07 +0000 (20:12 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 30 Nov 2014 20:12:07 +0000 (20:12 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 43440

tools/Makefile
tools/gengetopt/Makefile
tools/gengetopt/patches/100-dependency_fix.patch [new file with mode: 0644]

index 27d0dc1c7967932c6615e2a0fecf9c87dcbb5e4f..b9fc47e2ef9f13eecc5a9f559351297a819333e5 100644 (file)
@@ -73,6 +73,7 @@ $(curdir)/padjffs2/compile := $(curdir)/findutils/install
 $(curdir)/cloog/compile := $(curdir)/ppl/install
 $(curdir)/bc/compile := $(curdir)/bison/install
 $(curdir)/findutils/compile := $(curdir)/bison/install
 $(curdir)/cloog/compile := $(curdir)/ppl/install
 $(curdir)/bc/compile := $(curdir)/bison/install
 $(curdir)/findutils/compile := $(curdir)/bison/install
+$(curdir)/gengetopt/compile := $(curdir)/automake/install
 
 ifneq ($(CONFIG_CCACHE),)
 $(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))
 
 ifneq ($(CONFIG_CCACHE),)
 $(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))
index a66fbe66052e08ed85b470d97ab6cfa24af3e19f..74e528e6fd5dc449f6b710966a93473eda4483cd 100644 (file)
@@ -13,6 +13,8 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
 PKG_MD5SUM:=29749a48dda69277ab969c510597a14e
 
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
 PKG_MD5SUM:=29749a48dda69277ab969c510597a14e
 
+HOST_FIXUP := autoreconf
+
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
diff --git a/tools/gengetopt/patches/100-dependency_fix.patch b/tools/gengetopt/patches/100-dependency_fix.patch
new file mode 100644 (file)
index 0000000..69cb598
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -51,7 +51,7 @@ libgengetopt_la_LIBADD = $(top_builddir)
+       @LTLIBOBJS@ \
+       skels/libgen.la
+-LDADD = $(top_builddir)/src/libgengetopt.la
++LDADD = libgengetopt.la
+ EXTRA_DIST = parser.h argsdef.h gengetopt.h ggos.h gm.h gnugetopt.h \
+ cmdline.c cmdline.h \