ramips: rt288x: add support for the Belkin F5D8235-4 v1 board
authorGabor Juhos <juhosg@openwrt.org>
Wed, 28 Dec 2011 08:43:43 +0000 (08:43 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 28 Dec 2011 08:43:43 +0000 (08:43 +0000)
Patch-by: Cezary Jackiewicz <cezary.jackiewicz@gmail.com>
SVN-Revision: 29617

target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/etc/uci-defaults/network
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt288x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt288x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt288x/mach-f5d8235-v1.c [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt288x/config-2.6.39
target/linux/ramips/rt288x/profiles/belkin.mk [new file with mode: 0644]

index 3cd5c0f9a7bf73046dae3a2da63a7b0048ee8dab..9e09e69074f4195aef9ca05b50dede94f8e4ad4e 100755 (executable)
@@ -36,6 +36,9 @@ get_status_led() {
        esr-9753)
                status_led="esr-9753:orange:power"
                ;;
+       f5d8235-v1)
+               set_usb_led "f5d8235-v1:green:usb"
+               ;;
        fonera20n)
                status_led="fonera20n:green:power"
                ;;
index 47f7f016af166f85c945127d049ce8066422305b..259c5d75fd201920f4f0c3f24b8237b1a191aa75 100644 (file)
@@ -41,6 +41,7 @@ case "$FIRMWARE" in
                rt2x00_eeprom_extract "devconf" 0 272
                ;;
 
+       f5d8235-v1 | \
        f5d8235-v2)
                rt2x00_eeprom_extract "u-boot" 262144 272
                ;;
index f98162c6b240c1bf069f2dcf9cb7b3401d8ea557..7e58ef043e7270c6f45c4fb01a5942e6abdebe54 100755 (executable)
@@ -35,6 +35,7 @@ ramips_setup_interfaces()
                ucidef_set_interface_lan "eth0"
                ;;
 
+       f5d8235-v1 | \
        rt-n15)
                ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
                ucidef_add_switch "rtl8366s" "1" "1"
@@ -67,6 +68,7 @@ ramips_setup_macs()
 
        argus-atp52b | \
        b2c | \
+       f5d8235-v1 | \
        nw718 | \
        rt-n15 | \
        wl-351)
index f05fc3d71c5c1d05ddd564520455ed222765cf89..0a336eaecee153cfd697ab3f02b2e2b2ddb3e5f4 100755 (executable)
@@ -65,6 +65,9 @@ ramips_board_name() {
        *"ESR-9753")
                name="esr-9753"
                ;;
+       *"F5D8235 v1")
+               name="f5d8235-v1"
+               ;;
        *"F5D8235 v2")
                name="f5d8235-v2"
                ;;
index df6adf4431a807bd1d054342847f8154e81b77ba..94eb4be4e5016c007bc176622d479a0658b0a603 100644 (file)
@@ -14,6 +14,7 @@
 enum ramips_mach_type {
        RAMIPS_MACH_GENERIC,
        /* RT2880 based machines */
+       RAMIPS_MACH_F5D8235_V1,         /* Belkin F5D8235 v1 */
        RAMIPS_MACH_RT_N15,             /* Asus RT-N15 */
        RAMIPS_MACH_WLI_TX4_AG300N,     /* Buffalo WLI-TX4-AG300N */
        RAMIPS_MACH_WZR_AGL300NH,       /* Buffalo WZR-AGL300NH */
index c30b3ad1d91685def4d26a79a7860f0406b4bfe2..4189d9eef0b93570b22d5bb8207c92c169c66b87 100644 (file)
@@ -2,6 +2,10 @@ if RALINK_RT288X
 
 menu "Ralink RT288x machine selection"
 
+config RT288X_MACH_F5D8235_V1
+       bool "Belkin F5D8235 V1 board support"
+       select RALINK_DEV_GPIO_LEDS
+
 config RT288X_MACH_RT_N15
        bool "Asus RT-N15 board support"
        select RALINK_DEV_GPIO_BUTTONS
index ab707018d25392f333b910bce1af52dd3be393ab..5205706f3c12540b6c6e075c07075b2d6cec090c 100644 (file)
@@ -13,6 +13,7 @@ obj-y := irq.o setup.o rt288x.o devices.o clock.o
 
 obj-$(CONFIG_EARLY_PRINTK)             += early_printk.o
 
+obj-$(CONFIG_RT288X_MACH_F5D8235_V1)   += mach-f5d8235-v1.o
 obj-$(CONFIG_RT288X_MACH_RT_N15)       += mach-rt-n15.o
 obj-$(CONFIG_RT288X_MACH_WLI_TX4_AG300N) += mach-wli-tx4-ag300n.o
 obj-$(CONFIG_RT288X_MACH_WZR_AGL300NH) += mach-wzr-agl300nh.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt288x/mach-f5d8235-v1.c b/target/linux/ramips/files/arch/mips/ralink/rt288x/mach-f5d8235-v1.c
new file mode 100644 (file)
index 0000000..7db7e6f
--- /dev/null
@@ -0,0 +1,142 @@
+/*
+ *  Belkin F5D825 V1 board support
+ *
+ *  Copyright (C) 2011 Cezary Jackiewicz <cezary.jackiewicz@gmail.com>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/mtd/physmap.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt288x.h>
+#include <asm/mach-ralink/rt288x_regs.h>
+
+#include "devices.h"
+
+#include <linux/rtl8366.h>
+#include <linux/ethtool.h>
+
+#include <asm/mach-ralink/ramips_eth_platform.h>
+
+#define F5D8235_GPIO_RTL8366_SCK       2
+#define F5D8235_GPIO_RTL8366_SDA       1
+
+#define F5D8235_GPIO_LED_USB_BLUE      7
+#define F5D8235_GPIO_LED_USB_ORANGE    8
+#define F5D8235_GPIO_BUTTON_WPS                0
+#define F5D8235_GPIO_BUTTON_RESET      9
+
+#define F5D8235_BUTTONS_POLL_INTERVAL  20
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition f5d8235_partitions[] = {
+       {
+               .name   = "uboot",
+               .offset = 0,
+               .size   = 0x050000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "kernel and rootfs",
+               .offset = 0x050000,
+               .size   = 0x790000,
+       }, {
+               .name   = "rootfs",
+               .offset = 0x1D0000,
+               .size   = 0x610000,
+       }, {
+               .name   = "nvram",
+               .offset = 0x7E0000,
+               .size   = 0x010000,
+       }, {
+               .name   = "factory",
+               .offset = 0x7F0000,
+               .size   = 0x010000,
+       }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct physmap_flash_data f5d8235_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+       .nr_parts       = ARRAY_SIZE(f5d8235_partitions),
+       .parts          = f5d8235_partitions,
+#endif
+};
+
+static struct rtl8366_platform_data f5d8235_rtl8366s_data = {
+       .gpio_sda       = F5D8235_GPIO_RTL8366_SDA,
+       .gpio_sck       = F5D8235_GPIO_RTL8366_SCK,
+};
+
+static struct platform_device f5d8235_rtl8366s_device = {
+       .name           = RTL8366S_DRIVER_NAME,
+       .id             = -1,
+       .dev = {
+               .platform_data  = &f5d8235_rtl8366s_data,
+       }
+};
+
+static struct gpio_led f5d8235_leds_gpio[] __initdata = {
+       {
+               .name           = "f5d8234-v1:blue:storage",
+               .gpio           = F5D8235_GPIO_LED_USB_BLUE,
+               .active_low     = 1,
+       },{
+               .name           = "f5d8234-v1:orange:storage",
+               .gpio           = F5D8235_GPIO_LED_USB_ORANGE,
+               .active_low     = 1,
+       }
+};
+
+static struct gpio_button f5d8235_gpio_buttons[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .threshold      = 3,
+               .gpio           = F5D8235_GPIO_BUTTON_RESET,
+               .active_low     = 1,
+       }, {
+               .desc           = "wps",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .threshold      = 3,
+               .gpio           = F5D8235_GPIO_BUTTON_WPS,
+               .active_low     = 1,
+       }
+};
+
+static void __init f5d8235_init(void)
+{
+       rt288x_gpio_init(RT2880_GPIO_MODE_UART0 | RT2880_GPIO_MODE_I2C);
+
+       rt288x_register_flash(0, &f5d8235_flash_data);
+       rt288x_register_wifi();
+       rt288x_register_wdt();
+
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(f5d8235_leds_gpio),
+                                 f5d8235_leds_gpio);
+
+       ramips_register_gpio_buttons(-1, F5D8235_BUTTONS_POLL_INTERVAL,
+                                    ARRAY_SIZE(f5d8235_gpio_buttons),
+                                    f5d8235_gpio_buttons);
+
+       platform_device_register(&f5d8235_rtl8366s_device);
+
+       rt288x_eth_data.speed = SPEED_1000;
+       rt288x_eth_data.duplex = DUPLEX_FULL;
+       rt288x_eth_data.tx_fc = 1;
+       rt288x_eth_data.rx_fc = 1;
+       rt288x_register_ethernet();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_F5D8235_V1, "F5D8235_V1",
+            "Belkin F5D8235 v1", f5d8235_init);
index b661cab558be14806585b68100a613880838aa0d..d177c04ba8565cd5630189ea0de33d7412380fa5 100644 (file)
@@ -257,6 +257,10 @@ define Image/Build/Profile/F5D8235V2
        $(call Image/Build/Template/F5D8235V2,$(1),f5d8235v2,F5D8235_V2)
 endef
 
+define Image/Build/Template/F5D8235V1
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_f5d8235,$(mtd_f5d8235_kernel_part_size),$(mtd_f5d8235_rootfs_part_size))
+endef
+
 
 mtdlayout_wr5123gn=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),2944k(rootfs),3776k@0x50000(firmware)
 mtdlayout_wr5123gn8m=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),7040k(rootfs),7872k@0x50000(firmware)
@@ -265,7 +269,6 @@ define Image/Build/Profile/WR5123GN
        $(call BuildFirmware/Generic,$(1),wr512-3gn-8M,board="WR512-3GN",mtdlayout_wr5123gn8m,851968,7208960)
 endef
 
-
 ifeq ($(CONFIG_RALINK_RT305X),y)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/ARGUS_ATP52B,$(1))
@@ -290,6 +293,9 @@ define Image/Build/Profile/Default
 endef
 endif
 
+define Image/Build/Profile/F5D8235V1
+       $(call Image/Build/Template/F5D8235V1,$(1),f5d8235v1,F5D8235_V1)
+endef
 
 define Image/Build/Profile/RTN15
        $(call Image/Build/Template/GENERIC_4M,$(1),rt-n15,RT-N15)
@@ -302,6 +308,7 @@ endef
 
 ifeq ($(CONFIG_RALINK_RT288X),y)
 define Image/Build/Profile/Default
+       $(call Image/Build/Profile/F5D8235V1,$(1))
        $(call Image/Build/Profile/RTN15,$(1))
        $(call Image/Build/Profile/WLITX4AG300N,$(1))
 endef
index a5fead582722041280a08d75b9655d73d413342c..5ad60af3af7c537150386eb313ec90e0fbc724a2 100644 (file)
@@ -92,6 +92,7 @@ CONFIG_RALINK_DEV_GPIO_LEDS=y
 CONFIG_RALINK_RT288X=y
 # CONFIG_RALINK_RT305X is not set
 CONFIG_RAMIPS_WDT=y
+CONFIG_RT288X_MACH_F5D8235_V1=y
 CONFIG_RT288X_MACH_RT_N15=y
 CONFIG_RT288X_MACH_WLI_TX4_AG300N=y
 CONFIG_RT288X_MACH_WZR_AGL300NH=y
diff --git a/target/linux/ramips/rt288x/profiles/belkin.mk b/target/linux/ramips/rt288x/profiles/belkin.mk
new file mode 100644 (file)
index 0000000..608cee9
--- /dev/null
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/F5D8235V1
+       NAME:=Belkin F5D8235 V1
+       PACKAGES:=kmod-switch-rtl8366s kmod-swconfig swconfig
+endef
+
+define Profile/F5D8235_V1/Description
+       Package set for Belkin F5D8235 V1
+endef
+
+$(eval $(call Profile,F5D8235V1))
+