kernel: bump 4.14 to 4.14.160
authorHauke Mehrtens <hauke@hauke-m.de>
Mon, 23 Dec 2019 20:46:17 +0000 (21:46 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 24 Dec 2019 16:45:54 +0000 (17:45 +0100)
Refreshed all patches.

Compile-tested on: ipq40xx, apm821xx
Runtime-tested on: ipq40xx

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
include/kernel-version.mk
target/linux/generic/backport-4.14/025-tcp-allow-drivers-to-tweak-TSQ-logic.patch
target/linux/generic/backport-4.14/274-flow_dissector-Parse-batman-adv-unicast-headers.patch
target/linux/generic/hack-4.14/721-phy_packets.patch
target/linux/generic/pending-4.14/643-net-bridge-support-hardware-flow-table-offload.patch
target/linux/generic/pending-4.14/680-NET-skip-GRO-for-foreign-MAC-addresses.patch
target/linux/layerscape/patches-4.14/202-core-linux-support-layerscape.patch
target/linux/layerscape/patches-4.14/807-usb-support-layerscape.patch
target/linux/layerscape/patches-4.14/816-pcie-support-layerscape.patch
target/linux/mvebu/patches-4.14/408-sfp-move-module-eeprom-ethtool-access-into-netdev-co.patch
target/linux/octeontx/patches-4.14/0001-net-thunderx-add-support-for-rgmii-internal-delay-mo.patch

index 6cae8d8555a9c7751481e439f8bd7a1ba8ff5a93..97dcd0296b906329247cd7947d36b60590e82f71 100644 (file)
@@ -7,11 +7,11 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-4.9 = .206
-LINUX_VERSION-4.14 = .159
+LINUX_VERSION-4.14 = .160
 LINUX_VERSION-4.19 = .91
 
 LINUX_KERNEL_HASH-4.9.206 = 1df27899a9bc4dd874f3830ab9e7b638f0026dffd67a2e230444e5d2805ccad6
-LINUX_KERNEL_HASH-4.14.159 = e8d42d3a1b85d180141e9bc11c4a0e87f8a413c0e989b0f24c1b7c40f8a826f2
+LINUX_KERNEL_HASH-4.14.160 = c60326bad1bcdede514ca8a0bb96843fa7578ef00829cced6218b888b2efa92c
 LINUX_KERNEL_HASH-4.19.91 = f403c3dee12ded0af1889c78871abf7a531a978ba423f1ca772de702a92c3447
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 484093d55acbd03d6f7e1c4c38b19d5a93f22ba4..b85179982404a97c11858655d8af4a102f2a2f9e 100644 (file)
@@ -65,7 +65,7 @@ Cc: Kir Kolyshkin <kir@openvz.org>
         * Before updating sk_refcnt, we must commit prior changes to memory
 --- a/net/ipv4/tcp_output.c
 +++ b/net/ipv4/tcp_output.c
-@@ -1696,7 +1696,7 @@ u32 tcp_tso_autosize(const struct sock *
+@@ -1697,7 +1697,7 @@ u32 tcp_tso_autosize(const struct sock *
  {
        u32 bytes, segs;
  
@@ -74,7 +74,7 @@ Cc: Kir Kolyshkin <kir@openvz.org>
                    sk->sk_gso_max_size - 1 - MAX_TCP_HEADER);
  
        /* Goal is to send at least one packet per ms,
-@@ -2214,7 +2214,7 @@ static bool tcp_small_queue_check(struct
+@@ -2215,7 +2215,7 @@ static bool tcp_small_queue_check(struct
  {
        unsigned int limit;
  
index b0b2823cc9ef3acb1e17299ae5f33d33250fe638..a9b2fc40a3d9f0cb859db8fb50447f6fb9871b29 100644 (file)
@@ -94,7 +94,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  static void
  __skb_flow_dissect_tcp(const struct sk_buff *skb,
                       struct flow_dissector *flow_dissector,
-@@ -717,6 +769,11 @@ proto_again:
+@@ -718,6 +770,11 @@ proto_again:
                                               nhoff, hlen);
                break;
  
index 9e1c57d92d0181950a802d76cf095f82aeac0a1b..2c59e837afd9cfeda6ffe09b87749e009af82dd8 100644 (file)
@@ -43,7 +43,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        const struct header_ops *header_ops;
  
        unsigned int            flags;
-@@ -1797,6 +1804,10 @@ struct net_device {
+@@ -1802,6 +1809,10 @@ struct net_device {
        struct mpls_dev __rcu   *mpls_ptr;
  #endif
  
index a070fe16362af4380a8d033a63db814a99c16f73..b54d3cb48fb3ce9ad0167fe6c1ce7c8fb54d4270 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
  #include <linux/uaccess.h>
  #include "br_private.h"
-@@ -340,6 +344,28 @@ static const struct ethtool_ops br_ethto
+@@ -346,6 +350,28 @@ static const struct ethtool_ops br_ethto
        .get_link       = ethtool_op_get_link,
  };
  
@@ -49,7 +49,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static const struct net_device_ops br_netdev_ops = {
        .ndo_open                = br_dev_open,
        .ndo_stop                = br_dev_stop,
-@@ -367,6 +393,9 @@ static const struct net_device_ops br_ne
+@@ -373,6 +399,9 @@ static const struct net_device_ops br_ne
        .ndo_bridge_setlink      = br_setlink,
        .ndo_bridge_dellink      = br_dellink,
        .ndo_features_check      = passthru_features_check,
index f76c39ac183cb92cfab95baf89fb66c24928d585..8919ea34ec75a8826a45beb260cf9e36ce457e17 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -1766,6 +1766,8 @@ struct net_device {
+@@ -1771,6 +1771,8 @@ struct net_device {
        struct netdev_hw_addr_list      mc;
        struct netdev_hw_addr_list      dev_addrs;
  
@@ -107,7 +107,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        call_netdevice_notifiers_info(NETDEV_CHANGEUPPER, dev,
                                      &changeupper_info.info);
  }
-@@ -6969,6 +7016,7 @@ int dev_set_mac_address(struct net_devic
+@@ -6970,6 +7017,7 @@ int dev_set_mac_address(struct net_devic
        if (err)
                return err;
        dev->addr_assign_type = NET_ADDR_SET;
index 7be95d49e40dfa873562bcc871b1626fd8b039c4..63d12e688e6f128f036c261b81b97444e72fed54 100644 (file)
@@ -539,7 +539,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -2344,7 +2344,8 @@ int register_netdevice_notifier(struct n
+@@ -2349,7 +2349,8 @@ int register_netdevice_notifier(struct n
  int unregister_netdevice_notifier(struct notifier_block *nb);
  
  struct netdev_notifier_info {
@@ -549,7 +549,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  };
  
  struct netdev_notifier_info_ext {
-@@ -2376,6 +2377,7 @@ static inline void netdev_notifier_info_
+@@ -2381,6 +2382,7 @@ static inline void netdev_notifier_info_
                                             struct net_device *dev)
  {
        info->dev = dev;
@@ -557,7 +557,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  }
  
  static inline struct net_device *
-@@ -2384,6 +2386,12 @@ netdev_notifier_info_to_dev(const struct
+@@ -2389,6 +2391,12 @@ netdev_notifier_info_to_dev(const struct
        return info->dev;
  }
  
index 3d8de1e516068597af35d7e171a7c0b3514a5d06..a569dff7d60ddb4422dbd70e69b219d560f22bd6 100644 (file)
@@ -1289,7 +1289,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
                xhci->quirks |= XHCI_BROKEN_PORT_PED;
 --- a/drivers/usb/host/xhci-ring.c
 +++ b/drivers/usb/host/xhci-ring.c
-@@ -1976,10 +1976,12 @@ static int finish_td(struct xhci_hcd *xh
+@@ -1972,10 +1972,12 @@ static int finish_td(struct xhci_hcd *xh
        union xhci_trb *ep_trb, struct xhci_transfer_event *event,
        struct xhci_virt_ep *ep, int *status)
  {
@@ -1302,7 +1302,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
        u32 trb_comp_code;
        int ep_index;
  
-@@ -2002,14 +2004,30 @@ static int finish_td(struct xhci_hcd *xh
+@@ -1998,14 +2000,30 @@ static int finish_td(struct xhci_hcd *xh
        if (trb_comp_code == COMP_STALL_ERROR ||
                xhci_requires_manual_halt_cleanup(xhci, ep_ctx,
                                                trb_comp_code)) {
index f3f09989a7a446e4c5d621aafc12a4609977085e..216bef0c3fd2dad622fbcb1609bc4e779c1b95a0 100644 (file)
@@ -5618,7 +5618,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  static void quirk_no_pm_reset(struct pci_dev *dev)
  {
        /*
-@@ -4878,3 +4885,11 @@ static void quirk_no_ats(struct pci_dev
+@@ -4884,3 +4891,11 @@ static void quirk_no_ats(struct pci_dev
  DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_ATI, 0x98e4, quirk_no_ats);
  DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_ATI, 0x6900, quirk_no_ats);
  #endif /* CONFIG_PCI_ATS */
index 2e4be1bc48cb639522d81de17d022b9018db5c81..19f8f1e6327ce5f03dcb4cd814d297ba3799b9fe 100644 (file)
@@ -129,7 +129,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
  /* 802.11 specific */
  struct wireless_dev;
  /* 802.15.4 specific */
-@@ -1935,6 +1936,7 @@ struct net_device {
+@@ -1940,6 +1941,7 @@ struct net_device {
        struct netprio_map __rcu *priomap;
  #endif
        struct phy_device       *phydev;
index efd13da5ec647b7beb7b0da59355693c0566aabc..cf0f96dce361d4c1203928b55f1432406306ece3 100644 (file)
@@ -51,7 +51,7 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
 +                                                        lmac->lmac_type)))
                        return -ENODEV;
  
-               phy_start_aneg(lmac->phydev);
+               phy_start(lmac->phydev);
 @@ -1287,6 +1289,8 @@ static int bgx_init_of_phy(struct bgx *b
                bgx->lmac[lmac].lmacid = lmac;