get rid of gcc 4.1.2 and 4.2.4 support
authorImre Kaloz <kaloz@openwrt.org>
Thu, 27 Jan 2011 13:24:38 +0000 (13:24 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Thu, 27 Jan 2011 13:24:38 +0000 (13:24 +0000)
SVN-Revision: 25144

package/uci/Makefile
toolchain/gcc/Config.in
toolchain/gcc/Config.version

index 78b3fa8..bd46864 100644 (file)
@@ -65,11 +65,6 @@ UCI_MAKEOPTS = \
                FPIC="$(FPIC)" \
                OS="Linux"
 
-# work around a nasty gcc bug
-ifneq ($(CONFIG_GCC_VERSION_4_2_4),)
-  UCI_MAKEOPTS += WOPTS=""
-endif
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) $(UCI_MAKEOPTS)
        $(MAKE) -C $(PKG_BUILD_DIR)/lua $(UCI_MAKEOPTS)
index 01b8f60..cd4f3e2 100644 (file)
@@ -12,12 +12,6 @@ choice
        help
          Select the version of gcc you wish to use.
 
-       config GCC_VERSION_4_1_2
-               bool "gcc 4.1.2"
-
-       config GCC_VERSION_4_2_4
-               bool "gcc 4.2.4"
-
        config GCC_VERSION_4_3_5
                bool "gcc 4.3.5"
 
@@ -84,7 +78,7 @@ config INSTALL_LIBSTDCPP
 
 config INSTALL_LIBGCJ
        bool
-       depends on !(GCC_VERSION_4_1||GCC_VERSION_4_2)
+       depends on !GCC_VERSION_4_2
        prompt "Build/install java compiler and GNU classpath ?" if TOOLCHAINOPTS
        default n
        help
index a5a1ea6..a39c0e8 100644 (file)
@@ -1,7 +1,5 @@
 config GCC_VERSION
        string
-       default "4.1.2"     if GCC_VERSION_4_1_2
-       default "4.2.4"     if GCC_VERSION_4_2_4
        default "4.3.3+cs"  if GCC_VERSION_4_3_3_CS
        default "4.3.5"     if GCC_VERSION_4_3_5
        default "4.4.1+cs"  if GCC_VERSION_4_4_1_CS
@@ -13,19 +11,13 @@ config GCC_VERSION
 
 config GCC_VERSION_4
        bool
-       default y       if GCC_VERSION_4_1
        default y       if GCC_VERSION_4_2
        default y       if GCC_VERSION_4_3
        default y       if GCC_VERSION_4_4
        default y       if GCC_VERSION_4_5
 
-config GCC_VERSION_4_1
-       bool
-       default y       if GCC_VERSION_4_1_2
-
 config GCC_VERSION_4_2
        bool
-       default y       if GCC_VERSION_4_2_4
        default y       if GCC_VERSION_LLVM
 
 config GCC_VERSION_4_3