metadata: fixup "board"
authorPaul Spooren <mail@aparcar.org>
Tue, 26 Feb 2019 19:50:49 +0000 (20:50 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 6 Mar 2019 00:11:54 +0000 (01:11 +0100)
currently the "board" parameter contains $(BOARD) which actually results
to `<target>` (like ramips, ar71xx) without subtarget. However, one
actually excepts (not?) to contain BOARD_NAME or DEVICE_NAME.

Signed-off-by: Paul Spooren <mail@aparcar.org>
include/image-commands.mk

index ade370cc0dacec90c0ee6e0d53b89fc051e9ad4b..c6b4b23ce3cf5e7e5ea91a6ae49940e4833889b5 100644 (file)
@@ -360,7 +360,7 @@ metadata_json = \
                        "dist": "$(call json_quote,$(VERSION_DIST))", \
                        "version": "$(call json_quote,$(VERSION_NUMBER))", \
                        "revision": "$(call json_quote,$(REVISION))", \
-                       "board": "$(call json_quote,$(BOARD))" \
+                       "board": "$(call json_quote,$(if $(BOARD_NAME),$(BOARD_NAME),$(DEVICE_NAME)))" \
                } \
        }'