include the default profile in target.mk as well - required for the image builder...
authorFelix Fietkau <nbd@openwrt.org>
Sun, 14 Jan 2007 21:44:13 +0000 (21:44 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 14 Jan 2007 21:44:13 +0000 (21:44 +0000)
SVN-Revision: 6098

scripts/metadata.pl

index 5da5ac48a0734fc36b02aec61bfd6b26b37ed555..9434af0f9d0cde4ad8d5179f75aba1a304896c2b 100755 (executable)
@@ -46,6 +46,15 @@ sub parse_target_metadata() {
                /^Target-Profile-Name:\s*(.+)\s*$/ and $profile->{name} = $1;
                /^Target-Profile-Packages:\s*(.*)\s*$/ and $profile->{packages} = [ split(/\s+/, $1) ];
        }
+       foreach my $target (@target) {
+               @{$target->{profiles}} > 0 or $target->{profiles} = [
+                       {
+                               id => 'Default',
+                               name => 'Default',
+                               packages => []
+                       }
+               ];
+       }
        return @target;
 }
 
@@ -274,13 +283,6 @@ EOF
        foreach my $target (@target) {
                my $profiles = $target->{profiles};
                
-               @$profiles > 0 or $profiles = [
-                       {
-                               id => 'Default',
-                               name => 'Default',
-                               packages => []
-                       }
-               ];
                foreach my $profile (@$profiles) {
                        print <<EOF;
 config LINUX_$target->{conf}_$profile->{id}