Make mv_cesa crypto module available on Orion as well.
authorLars-Peter Clausen <lars@metafoo.de>
Mon, 4 Oct 2010 21:33:07 +0000 (21:33 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Mon, 4 Oct 2010 21:33:07 +0000 (21:33 +0000)
SVN-Revision: 23229

package/kernel/modules/crypto.mk
target/linux/kirkwood/modules.mk [deleted file]

index 27cbf47132c938a82937e0675fd50a8b874c2013..49c5684b817179d811f584f4191b2131d3198291 100644 (file)
@@ -373,3 +373,14 @@ define KernelPackage/crypto-xts
 endef
 
 $(eval $(call KernelPackage,crypto-xts))
+
+define KernelPackage/crypto-mv_cesa
+   TITLE:=Marvell crypto engine
+   KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
+   FILES:=$(LINUX_DIR)/drivers/crypto/mv_cesa.ko
+   AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
+   SUBMENU:=Cryptographic API modules
+   DEPENDS:=kmod-crypto-core @TARGET_kirkwood||TARGET_orion
+endef
+
+$(eval $(call KernelPackage,crypto-mv_cesa))
diff --git a/target/linux/kirkwood/modules.mk b/target/linux/kirkwood/modules.mk
deleted file mode 100644 (file)
index 736c82c..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-
-define KernelPackage/crypto-mv_cesa
-   TITLE:=Marvell crypto engine
-   KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
-   FILES:=$(LINUX_DIR)/drivers/crypto/mv_cesa.ko
-   AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
-   SUBMENU:=Cryptographic API modules
-   DEPENDS:=kmod-crypto-core @TARGET_kirkwood
-endef
-
-$(eval $(call KernelPackage,crypto-mv_cesa))