ipq40xx: add support for EnGenius EAP1300
authorSteven Lin <steven.lin@senao.com>
Fri, 19 Oct 2018 08:55:08 +0000 (16:55 +0800)
committerMathias Kresin <dev@kresin.me>
Wed, 5 Dec 2018 08:40:32 +0000 (09:40 +0100)
SOC:    IPQ4018 / QCA Dakota
CPU:    Quad-Core ARMv7 Processor rev 5 (v7l) Cortex-A7
DRAM:   256 MiB
NOR:    32 MiB
ETH:    Qualcomm Atheros QCA8072
WLAN1:  Qualcomm Atheros QCA4018 2.4GHz 802.11bgn 2:2x2
WLAN2:  Qualcomm Atheros QCA4018 5GHz 802.11a/n/ac 2:2x2
INPUT:  RESET Button
LEDS:   Power, LAN, MESH, WLAN 2.4GHz, WLAN 5GHz

1. Load Ramdisk via U-Boot

To set up the flash memory environment, do the following:
a. As a preliminary step, ensure that the board console port is connected to the PC using these RS232 parameters:
   * 115200bps
   * 8N1
b. Confirm that the PC is connected to the board using one of the Ethernet ports. Set a static ip 192.168.99.8 for Ethernet that connects to board. The PC must have a TFTP server launched and listening on the interface to which the board is connected. At this stage power up the board and, after a few seconds, press 4 and then any key during the countdown.

U-BOOT> set serverip 192.168.99.8 && set ipaddr 192.168.99.9 && tftpboot 0x84000000 openwrt.itb && bootm

2. Load image via GUI

a. Upgrade EAP1300 to FW v3.5.3.2
In the GUI, System Manager > Firmware > Firmware Upgrade, to do upgrade.
b. Transfer to OpenWrt from EnGenius.
In Firmware Upgrade page, to upgrade yours openwrt-ipq40xx-engenius_eap1300-squashfs-sysupgrade.bin.

3. Revert to EnGenius EAP1300
To flash openwrt-ipq40xx-engenius_eap1300-squashfs-factory.bin by using sysupgrade command and "DO NOT" keep configuration.
$ sysupgrade –n openwrt-ipq40xx-engenius_eap1300-squashfs-factory.bin

Signed-off-by: Steven Lin <steven.lin@senao.com>
package/firmware/ipq-wifi/Makefile
package/firmware/ipq-wifi/board-engenius_eap1300.bin [new file with mode: 0644]
target/linux/ipq40xx/base-files/etc/board.d/01_leds
target/linux/ipq40xx/base-files/etc/board.d/02_network
target/linux/ipq40xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ipq40xx/files-4.14/arch/arm/boot/dts/qcom-ipq4018-eap1300.dts [new file with mode: 0644]
target/linux/ipq40xx/image/Makefile
target/linux/ipq40xx/patches-4.14/901-arm-boot-add-dts-files.patch

index 51da4bc465f3ae1cac5c18c2cf4897683a294d9d..4b39f970dd6aa40350bc37c56aa0d689b2bb7646 100644 (file)
@@ -17,7 +17,7 @@ endef
 # Please send a mail with your device-specific board files upstream.
 # You can find instructions and examples on the linux-wireless wiki:
 # <https://wireless.wiki.kernel.org/en/users/drivers/ath10k/boardfiles>
-ALLWIFIBOARDS:=
+ALLWIFIBOARDS:=engenius_eap1300
 ALLWIFIPACKAGES:=$(foreach BOARD,$(ALLWIFIBOARDS),ipq-wifi-$(BOARD))
 
 define Package/ipq-wifi-default
@@ -52,5 +52,6 @@ Don't install it for any other device!
 endef
 
 #$(eval $(call generate-ipq-wifi-package,<devicename>,<filename>,<displayname>))
+$(eval $(call generate-ipq-wifi-package,engenius_eap1300,board-engenius_eap1300.bin,EnGenius EAP1300))
 
 $(foreach PACKAGE,$(ALLWIFIPACKAGES),$(eval $(call BuildPackage,$(PACKAGE))))
diff --git a/package/firmware/ipq-wifi/board-engenius_eap1300.bin b/package/firmware/ipq-wifi/board-engenius_eap1300.bin
new file mode 100644 (file)
index 0000000..eb4328c
Binary files /dev/null and b/package/firmware/ipq-wifi/board-engenius_eap1300.bin differ
index ab2f77ee10a8e4371d8c52d6d6b6a35bae8aceb6..5e382c03a7d437eef8213a28ff5d088e863dcdce 100755 (executable)
@@ -23,6 +23,12 @@ avm,fritzbox-4040)
        ucidef_set_led_netdev "wan" "WAN" "fritz4040:green:wan" "eth1"
        ucidef_set_led_switch "lan" "LAN" "fritz4040:green:lan" "switch0" "0x1e"
        ;;
+engenius,eap1300)
+       ucidef_set_led_netdev "lan" "LAN" "${boardname}:blue:lan" "eth0"
+       ucidef_set_led_wlan "wlan2g" "WLAN2G" "${boardname}:blue:wlan2g" "phy0tpt"
+       ucidef_set_led_wlan "wlan5g" "WLAN5G" "${boardname}:yellow:wlan5g" "phy1tpt"
+       ucidef_set_led_default "mesh" "MESH" "${boardname}:blue:mesh" "0"
+       ;;
 glinet,gl-b1300)
        ucidef_set_led_wlan "wlan" "WLAN" "${boardname}:green:wlan" "phy0tpt"
        ;;
index 5c90ef136fd7cbbe023001030d8c9003347bd249..d73914c7c1526e23b84c88dc694f7b2a1a0e814b 100755 (executable)
@@ -33,6 +33,13 @@ avm,fritzbox-4040)
 compex,wpj428)
        ucidef_set_interface_lan "eth0 eth1"
        ;;
+engenius,eap1300 |\
+meraki,mr33 |\
+netgear,ex6100v2 |\
+netgear,ex6150v2 |\
+zyxel,wre6606)
+       ucidef_set_interface_lan "eth0"
+       ;;
 glinet,gl-b1300)
        ucidef_set_interfaces_lan_wan "eth0" "eth1"
        ucidef_add_switch "switch0" \
@@ -42,12 +49,6 @@ openmesh,a42 |\
 openmesh,a62)
        ucidef_set_interfaces_lan_wan "eth1" "eth0"
        ;;
-meraki,mr33 |\
-netgear,ex6100v2 |\
-netgear,ex6150v2 |\
-zyxel,wre6606)
-       ucidef_set_interface_lan "eth0"
-       ;;
 zyxel,nbg6617)
        ucidef_set_interfaces_lan_wan "eth0" "eth1"
        ucidef_add_switch "switch0" \
index 1d4fd9cd8f9a3983ac3323ce72153c1dcc17a69a..605a03be1dde8cb691b31dd7610be3985ce6da35 100644 (file)
@@ -142,6 +142,7 @@ case "$FIRMWARE" in
                ath10kcal_patch_mac_crc $(mtd_get_mac_binary dnidata 0)
                ;;
        compex,wpj428 |\
+       engenius,eap1300 |\
        openmesh,a42 |\
        openmesh,a62)
                ath10kcal_extract "0:ART" 4096 12064
@@ -178,6 +179,7 @@ case "$FIRMWARE" in
                ath10kcal_patch_mac_crc $(mtd_get_mac_binary dnidata 12)
                ;;
        compex,wpj428 |\
+       engenius,eap1300 |\
        openmesh,a42 |\
        openmesh,a62)
                ath10kcal_extract "0:ART" 20480 12064
diff --git a/target/linux/ipq40xx/files-4.14/arch/arm/boot/dts/qcom-ipq4018-eap1300.dts b/target/linux/ipq40xx/files-4.14/arch/arm/boot/dts/qcom-ipq4018-eap1300.dts
new file mode 100644 (file)
index 0000000..7ef0529
--- /dev/null
@@ -0,0 +1,230 @@
+// SPDX-License-Identifier: GPL-2.0-or-later
+
+#include "qcom-ipq4019.dtsi"
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/soc/qcom,tcsr.h>
+
+/ {
+       model = "EnGenius EAP1300";
+       compatible = "engenius,eap1300", "qcom,ipq4019";
+
+       soc {
+               mdio@90000 {
+                       status = "okay";
+               };
+
+               ess-psgmii@98000 {
+                       status = "okay";
+               };
+
+               tcsr@1949000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1949000 0x100>;
+                       qcom,wifi_glb_cfg = <TCSR_WIFI_GLB_CFG>;
+               };
+
+               ess_tcsr@1953000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1953000 0x1000>;
+                       qcom,ess-interface-select = <TCSR_ESS_PSGMII>;
+               };
+
+               tcsr@1957000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1957000 0x100>;
+                       qcom,wifi_noc_memtype_m0_m2 = <TCSR_WIFI_NOC_MEMTYPE_M0_M2>;
+               };
+
+               serial@78af000 {
+                       pinctrl-0 = <&serial_pins>;
+                       pinctrl-names = "default";
+                       status = "okay";
+               };
+
+               crypto@8e3a000 {
+                       status = "okay";
+               };
+
+               watchdog@b017000 {
+                       status = "okay";
+               };
+
+               ess-switch@c000000 {
+                       status = "okay";
+               };
+
+               edma@c080000 {
+                       status = "okay";
+               };
+       };
+
+       gpio-keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&tlmm 18 GPIO_ACTIVE_HIGH>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       aliases {
+               led-boot = &power;
+               led-failsafe = &power;
+               led-running = &power;
+               led-upgrade = &power;
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               power: orange {
+                       label = "eap1300:orange:power";
+                       gpios = <&tlmm 58 GPIO_ACTIVE_LOW>;
+               };
+
+               lan {
+                       label = "eap1300:blue:lan";
+                       gpios = <&tlmm 2 GPIO_ACTIVE_HIGH>;
+               };
+
+               mesh {
+                       label = "eap1300:blue:mesh";
+                       gpios = <&tlmm 1 GPIO_ACTIVE_HIGH>;
+               };
+
+               wlan2g {
+                       label = "eap1300:blue:wlan2g";
+                       gpios = <&tlmm 3 GPIO_ACTIVE_HIGH>;
+               };
+
+               wlan5g {
+                       label = "eap1300:yellow:wlan5g";
+                       gpios = <&tlmm 0 GPIO_ACTIVE_HIGH>;
+               };
+       };
+};
+
+&tlmm {
+       serial_pins: serial_pinmux {
+               mux {
+                       pins = "gpio60", "gpio61";
+                       function = "blsp_uart0";
+                       bias-disable;
+               };
+       };
+
+       spi_0_pins: spi_0_pinmux {
+               pin {
+                       function = "blsp_spi0";
+                       pins = "gpio54", "gpio55", "gpio56", "gpio57";
+                       drive-strength = <12>;
+                       bias-disable;
+               };
+               pin_cs {
+                       function = "gpio";
+                       pins = "gpio54";
+                       drive-strength = <2>;
+                       bias-disable;
+                       output-high;
+               };
+       };
+};
+
+&blsp_dma {
+       status = "okay";
+};
+
+&blsp1_spi1 {
+       pinctrl-0 = <&spi_0_pins>;
+       pinctrl-names = "default";
+       status = "okay";
+       cs-gpios = <&tlmm 54 GPIO_ACTIVE_HIGH>;
+
+       m25p80@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <24000000>;
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "0:SBL1";
+                               reg = <0x00000000 0x00040000>;
+                               read-only;
+                       };
+                       partition1@40000 {
+                               label = "0:MIBIB";
+                               reg = <0x00040000 0x00020000>;
+                               read-only;
+                       };
+                       partition2@60000 {
+                               label = "0:QSEE";
+                               reg = <0x00060000 0x00060000>;
+                               read-only;
+                       };
+                       partition3@c0000 {
+                               label = "0:CDT";
+                               reg = <0x000c0000 0x00010000>;
+                               read-only;
+                       };
+                       partition4@d0000 {
+                               label = "0:DDRPARAMS";
+                               reg = <0x000d0000 0x00010000>;
+                               read-only;
+                       };
+                       partition5@e0000 {
+                               label = "0:APPSBLENV";
+                               reg = <0x000e0000 0x00010000>;
+                               read-only;
+                       };
+                       partition6@f0000 {
+                               label = "0:APPSBL";
+                               reg = <0x000f0000 0x00090000>;
+                               read-only;
+                       };
+                       partition7@180000 {
+                               label = "0:ART";
+                               reg = <0x00180000 0x00010000>;
+                               read-only;
+                       };
+                       partition8@190000 {
+                               label = "firmware";
+                               reg = <0x190000 0x1dc0000>;
+                       };
+                       partition9@1f50000 {
+                               label = "u-boot-env";
+                               reg = <0x01f50000 0x00010000>;
+                       };
+                       partition10@1f60000 {
+                               label = "userconfig";
+                               reg = <0x01f60000 0x000a0000>;
+                       };
+               };
+       };
+};
+
+&cryptobam {
+       status = "okay";
+};
+
+&gmac0 {
+       vlan_tag = <2 0x20>;
+};
+
+&gmac1 {
+       vlan_tag = <1 0x10>;
+};
+
+&wifi0 {
+       status = "okay";
+       qcom,ath10k-calibration-variant = "EnGenius-EAP1300";
+};
+
+&wifi1 {
+       status = "okay";
+       qcom,ath10k-calibration-variant = "EnGenius-EAP1300";
+};
index 8a42d3e780cc8fa2ffe3ab7a5073bc9abd8e92ea..eaf9f68395948fd76647628e9bf4b157e5cafbc0 100644 (file)
@@ -105,6 +105,20 @@ define Device/compex_wpj428
 endef
 TARGET_DEVICES += compex_wpj428
 
+define Device/engenius_eap1300
+       $(call Device/FitImage)
+       DEVICE_TITLE := EnGenius EAP1300
+       DEVICE_DTS_CONFIG := config@4
+       BOARD_NAME := eap1300
+       DEVICE_DTS := qcom-ipq4018-eap1300
+       KERNEL_SIZE := 5120k
+       IMAGE_SIZE := 25344k
+       IMAGES := sysupgrade.bin
+       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+       DEVICE_PACKAGES := ipq-wifi-engenius_eap1300
+endef
+TARGET_DEVICES += engenius_eap1300
+
 define Device/glinet_gl-b1300
        $(call Device/FitImage)
        DEVICE_TITLE := GL.iNet GL-B1300
index 8066f986a4e030c9c8fe0ec4438e92d30daa77f0..46c34038d638c2460ce65bf5e866b72666b85474 100644 (file)
@@ -10,11 +10,12 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -697,7 +697,20 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+@@ -697,7 +697,21 @@ dtb-$(CONFIG_ARCH_QCOM) += \
        qcom-apq8074-dragonboard.dtb \
        qcom-apq8084-ifc6540.dtb \
        qcom-apq8084-mtp.dtb \
 +      qcom-ipq4018-a42.dtb \
++      qcom-ipq4018-eap1300.dtb \
 +      qcom-ipq4018-ex6100v2.dtb \
 +      qcom-ipq4018-ex6150v2.dtb \
 +      qcom-ipq4018-fritz4040.dtb \