kernel: kirkwood/orion I2C module support
authorLars-Peter Clausen <lars@metafoo.de>
Mon, 4 Oct 2010 09:16:13 +0000 (09:16 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Mon, 4 Oct 2010 09:16:13 +0000 (09:16 +0000)
This patch adds support for configuring kirkwood/orion i2c module.

Signed-off-by: Wojciech Dubowik <Wojciech.Dubowik@neratec.com>
SVN-Revision: 23215

package/kernel/modules/i2c.mk

index 14fbcf8e9ec7a656151a233675992244a3d6ac17..9612f965f988875c69d55308fc08ce41fa694d4c 100644 (file)
@@ -167,3 +167,19 @@ define KernelPackage/i2c-ibm-iic/description
 endef
 
 $(eval $(call KernelPackage,i2c-ibm-iic))
+
+I2C_MV64XXX_MODULES:=\
+  CONFIG_I2C_MV64XXX:drivers/i2c/busses/i2c-mv64xxx
+
+define KernelPackage/i2c-mv64xxx
+  $(call i2c_defaults,$(I2C_MV64XXX_MODULES),59)
+  TITLE:=Orion Platform I2C interface support
+  DEPENDS:=@TARGET_kirkwood||TARGET_orion +kmod-i2c-core
+endef
+
+define KernelPackage/i2c-mv64xxx/description
+ Kernel module for I2C interface on the Kirkwood and Orion
+ family processors.
+endef
+
+$(eval $(call KernelPackage,i2c-mv64xxx))