rpcd: update to lastest HEAD
authorRafał Miłecki <rafal@milecki.pl>
Mon, 14 May 2018 08:29:20 +0000 (10:29 +0200)
committerRafał Miłecki <rafal@milecki.pl>
Mon, 14 May 2018 08:29:20 +0000 (10:29 +0200)
All these changes are important enough to have them in the 17.01.

8206219 uci: fix memory leak in rpc_uci_replace_savedir()
10f7878 exec: close stdout and stderr streams on child signal
92d0d75 uci: use correct sort index when reordering sections
66a9bad uci: fix memory leak in rpc_uci_apply_timeout()
2423162 uci: switch to proper save directory on apply/rollback
edd37f8 uci: add rpc_uci_replace_savedir() helper
eb09f3a session: ignore non-string username attribute upon restore
3d400c7 session: support reclaiming pending apply session
f0f6f81 session: remove redundant key attribute to rpc_session_set()
6994c87 uci: fix session delta isolation

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
package/system/rpcd/Makefile

index dc4bbb982931ea5a0ef220a8ed45c6dc552caf82..754ea9ba05188daf2dccd559ae92407a081f1d98 100644 (file)
@@ -12,10 +12,10 @@ PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(LEDE_GIT)/project/rpcd.git
-PKG_SOURCE_DATE:=2017-12-07
-PKG_SOURCE_VERSION:=cfe1e75c91bc1bac82e6caab3e652b0ebee59524
+PKG_SOURCE_DATE:=2018-05-13
+PKG_SOURCE_VERSION:=820621952d537c49deba470c6f61c40df93f4ba8
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
-PKG_MIRROR_HASH:=4857497c88115defbf6add68a37975ed79e8f992e65d7d0df56cd29288dea379
+PKG_MIRROR_HASH:=24322b547cb062e9676da51d09de19d1cb9fb07df9e82b2b63fc0f714ec1c14b
 
 PKG_LICENSE:=ISC
 PKG_LICENSE_FILES:=