realview: fix zImage-initramfs installation
authorFlorian Fainelli <florian@openwrt.org>
Thu, 27 Feb 2014 00:12:53 +0000 (00:12 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 27 Feb 2014 00:12:53 +0000 (00:12 +0000)
We were copying the actual vmlinux-initramfs.elf kernel which cannot be
launched by QEMU or a real bootloader, use zImage-initramfs instead.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 39756

target/linux/realview/image/Makefile

index dd0d9ee76d24450caab5834d5e90a43975db957c..c6ff8ce46a86d8fd3949322bd619a82ae74dfdf4 100644 (file)
@@ -8,7 +8,11 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 define Image/BuildKernel
-       cp $(LINUX_DIR)/arch/$(ARCH)/boot/$(subst ",,$(KERNELNAME)) $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+       cp $(KDIR)/$(subst ",,$(KERNELNAME)) $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+endef
+
+define Image/BuildKernel/Initramfs
+       cp $(KDIR)/$(subst ",,$(KERNELNAME))-initramfs $(BIN_DIR)/openwrt-$(BOARD)-vmlinux-initramfs.elf
 endef
 
 define Image/Build/squashfs