kernel: add kmod-squashfs
authorMatteo Croce <matteo.croce@canonical.com>
Thu, 11 Aug 2016 14:11:39 +0000 (16:11 +0200)
committerJohn Crispin <john@phrozen.org>
Mon, 15 Aug 2016 13:32:38 +0000 (15:32 +0200)
add kernel package to build squashfs as module when it's not the root filesystem

Signed-off-by: Matteo Croce <matteo.croce@canonical.com>
package/kernel/linux/modules/fs.mk

index 844a3c96ab3bf4c2c31245603191caa0ea0b4214..c42260a96fa768cf60a802fe9be12b3985c9d06e 100644 (file)
@@ -420,6 +420,22 @@ endef
 $(eval $(call KernelPackage,fs-reiserfs))
 
 
+define KernelPackage/fs-squashfs
+  SUBMENU:=$(FS_MENU)
+  TITLE:=SquashFS 4.0 filesystem support
+  KCONFIG:=CONFIG_SQUASHFS \
+       CONFIG_SQUASHFS_XZ=y
+  FILES:=$(LINUX_DIR)/fs/squashfs/squashfs.ko
+  AUTOLOAD:=$(call AutoLoad,30,squashfs,1)
+endef
+
+define KernelPackage/fs-squashfs/description
+ Kernel module for SquashFS 4.0 support
+endef
+
+$(eval $(call KernelPackage,fs-squashfs))
+
+
 define KernelPackage/fs-udf
   SUBMENU:=$(FS_MENU)
   TITLE:=UDF filesystem support