ramips: add support for Planex DB-WRT01
authorJohn Crispin <john@openwrt.org>
Mon, 14 Sep 2015 20:08:55 +0000 (20:08 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 14 Sep 2015 20:08:55 +0000 (20:08 +0000)
This patch add support for Planex DB-WRT01. DANBOARD route on
 the MT7620A SoC with two Ethernet port and a 802.11n 2.4 GHz radio.
 DANBOARD is Cartoon character.

Signed-off-by: YuheiOKAWA <tochiro.srchack@gmail.com>
SVN-Revision: 46918

target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/DB-WRT01.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile

index 71cf3acb1087d9acbc45d2710f7ce5bd336ec738..a9959e37c12e98f34f296564f68ad2aa731e504b 100755 (executable)
@@ -87,6 +87,9 @@ d105)
        ucidef_set_led_default "power" "POWER" "$board:red:power" "1"
        set_usb_led "$board:green:usb"
        ;;
+db-wrt01)
+       ucidef_set_led_default "power" "power" "$board:orange:power" "1"
+       ;;
 dcs-930l-b1)
        ucidef_set_led_default "power" "POWER" "$board:red:power" "1"
        ucidef_set_led_netdev "wifi" "WiFi" "$board:blue:wps"
index 6a2f042248d33786221996a383a31505fdf1fb29..02cd6824d094e35b86120fd17f3bf0335e38a1c2 100755 (executable)
@@ -61,6 +61,7 @@ ramips_setup_interfaces()
                ;;
        3g-6200n|\
        ai-br100|\
+       db-wrt01|\
        dir-300-b7|\
        dir-320-b1|\
        dir-610-a1|\
index a4911b023cbaa8ce66fd608babdd794103450008..f886b5da8accfb409c9016b035a4bc64217009b3 100644 (file)
@@ -94,6 +94,7 @@ get_status_led() {
        y1s)
                status_led="$board:blue:power"
                ;;
+       db-wrt01|\
        esr-9753)
                status_led="$board:orange:power"
                ;;
index 5cafd4593d60fc8bf1dda557d734c34b187905c0..5b6808e0b314f17c1f9390da21f800c61def9ae4 100755 (executable)
@@ -97,6 +97,9 @@ ramips_board_detect() {
        *"DAP-1350")
                name="dap-1350"
                ;;
+       *"DB-WRT01")
+               name="db-wrt01"
+               ;;
        *"DCS-930")
                name="dcs-930"
                ;;
index 53e7070c99c92cdd18fdc7c2660eba3dcbd2395a..844ed5db95dc54f9529694fec69d787a667cb838 100755 (executable)
@@ -36,6 +36,7 @@ platform_check_image() {
        cf-wr800n|\
        d105|\
        dap-1350|\
+       db-wrt01|\
        dcs-930|\
        dcs-930l-b1|\
        dir-300-b1|\
diff --git a/target/linux/ramips/dts/DB-WRT01.dts b/target/linux/ramips/dts/DB-WRT01.dts
new file mode 100644 (file)
index 0000000..d0fbaf3
--- /dev/null
@@ -0,0 +1,100 @@
+/dts-v1/;
+
+/include/ "mt7620a.dtsi"
+
+/ {
+       compatible = "ralink,mt7620a-soc";
+       model = "Planex DB-WRT01";
+
+       palmbus@10000000 {
+               gpio1: gpio@638 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "en25q64";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "mx25l6405d";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0x7b0000>;
+                               };
+                       };
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "i2c", "spi refclk", "rgmii1";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               pinctrl-names = "default";
+               pinctrl-0 = <&ephy_pins>;
+               mtd-mac-address = <&factory 0x4>;
+               ralink,port-map = "llllw";
+       };
+
+       gsw@10110000 {
+               ralink,port4 = "ephy";
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       pcie@10140000 {
+               status = "okay";
+       };
+       
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               power {
+                       label = "db-wrt01:orange:power";
+                       gpios = <&gpio1 1 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               s1 {
+                       label = "wps";
+                       gpios = <&gpio0 2 1>;
+                       linux,code = <0x211>;
+               };
+       };
+};
index 2f4d4cbc617dc2abe497c691f4a18f78900f9d98..4632ad2cd3447ac0e2eb8cabbe82367e5f482ba1 100644 (file)
@@ -868,6 +868,7 @@ Image/Build/Profile/CF-WR800N=$(call BuildFirmware/Default8M/$(1),$(1),cf-wr800n
 Image/Build/Profile/DIR-810L=$(call BuildFirmware/CustomFlash/$(1),$(1),dir-810l,DIR-810L,$(dlink810l_mtd_size))
 na930_mtd_size=20971520
 Image/Build/Profile/NA930=$(call BuildFirmware/CustomFlash/$(1),$(1),na930,NA930,$(na930_mtd_size))
+Image/Build/Profile/DB-WRT01=$(call BuildFirmware/Default8M/$(1),$(1),db-wrt01,DB-WRT01)
 Image/Build/Profile/MZK-750DHP=$(call BuildFirmware/Default8M/$(1),$(1),mzk-750dhp,MZK-750DHP)
 Image/Build/Profile/OY-0001=$(call BuildFirmware/Default16M/$(1),$(1),oy-0001,OY-0001)
 Image/Build/Profile/Y1=$(call BuildFirmware/Default16M/$(1),$(1),y1,Y1)
@@ -901,6 +902,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/WHR300HP2,$(1))
        $(call Image/Build/Profile/WHR600D,$(1))
        $(call Image/Build/Profile/WHR1166D,$(1))
+       $(call Image/Build/Profile/DB-WRT01,$(1))
        $(call Image/Build/Profile/MZK-750DHP,$(1))
        $(call Image/Build/Profile/NA930,$(1))
        $(call Image/Build/Profile/OY-0001,$(1))