kernel/modules: add kmod-crypto-ctr
authorFelix Fietkau <nbd@openwrt.org>
Mon, 5 Jan 2015 13:01:52 +0000 (13:01 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 5 Jan 2015 13:01:52 +0000 (13:01 +0000)
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
SVN-Revision: 43834

package/kernel/linux/modules/crypto.mk

index 3193fb031a0726a9ceeb4367e95b3f63b9d16a64..1fd10d9534ef144ab6303772403be69450d43272 100644 (file)
@@ -303,6 +303,17 @@ endef
 
 $(eval $(call KernelPackage,crypto-cbc))
 
+define KernelPackage/crypto-ctr
+  TITLE:=Counter Mode CryptoAPI module
+  DEPENDS:=+kmod-crypto-manager +kmod-crypto-seqiv
+  KCONFIG:=CONFIG_CRYPTO_CTR
+  FILES:=$(LINUX_DIR)/crypto/ctr.ko
+  AUTOLOAD:=$(call AutoLoad,09,ctr)
+  $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-ctr))
+
 define KernelPackage/crypto-pcbc
   TITLE:=Propagating Cipher Block Chaining CryptoAPI module
   DEPENDS:=+kmod-crypto-manager