add pwlib and open323 from Zoltan HERPAI, thx, fix bitlebee build after iconv changes...
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Fri, 17 Mar 2006 17:05:50 +0000 (17:05 +0000)
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Fri, 17 Mar 2006 17:05:50 +0000 (17:05 +0000)
SVN-Revision: 3394

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/bitlbee/Makefile
openwrt/package/openh323/Config.in [new file with mode: 0644]
openwrt/package/openh323/Makefile [new file with mode: 0644]
openwrt/package/openh323/ipkg/openh323.control [new file with mode: 0644]
openwrt/package/openh323/patches/001-configure.patch [new file with mode: 0644]
openwrt/package/pwlib/Config.in [new file with mode: 0644]
openwrt/package/pwlib/Makefile [new file with mode: 0644]
openwrt/package/pwlib/ipkg/pwlib.control [new file with mode: 0644]
openwrt/package/pwlib/patches/002-lib_mak.patch [new file with mode: 0644]

index 49575181e48eaca239dd97adf1bffb9a942efbc7..737052e94a0824f217effda0a388295968cea4b7 100644 (file)
@@ -239,11 +239,13 @@ source "package/libnet/Config.in"
 source "package/libnids/Config.in"
 source "package/libogg/Config.in"
 source "package/opencdk/Config.in"  # libopencdk
+source "package/openh323/Config.in" 
 source "package/openldap/Config.in"  # libopenldap
 source "package/openssl/Config.in"  # libopenssl
 source "package/libosip2/Config.in"
 source "package/libpcap/Config.in"
 source "package/pcre/Config.in"  # libpcre
+source "package/pwlib/Config.in" 
 source "package/libpng/Config.in"
 source "package/popt/Config.in"  # libpopt
 source "package/postgresql/Config.in"  # libpq
index a7d878e9a39f944833e890640264c96df78c6294..290723c074ce2ec2d5a7fb7e62c4cb1de5764d01 100644 (file)
@@ -14,7 +14,7 @@ package-$(BR2_COMPILE_AVAHI) += avahi
 package-$(BR2_COMPILE_BC) += bc
 package-$(BR2_COMPILE_BIND) += bind
 package-$(BR2_PACKAGE_BITCHX) += bitchx
-package-$(BR2_PACKAGE_BITCHX) += bitlbee
+package-$(BR2_PACKAGE_BITLBEE) += bitlbee
 package-$(BR2_PACKAGE_BLUEZ_LIBS) += bluez-libs
 package-$(BR2_PACKAGE_BLUEZ_UTILS) += bluez-utils
 package-$(BR2_PACKAGE_BRIDGE) += bridge
@@ -163,6 +163,7 @@ package-$(BR2_PACKAGE_NTPCLIENT) += ntpclient
 package-$(BR2_PACKAGE_NVRAM) += nvram
 package-$(BR2_PACKAGE_OLSRD) += olsrd
 package-$(BR2_COMPILE_OPENCDK) += opencdk
+package-$(BR2_PACKAGE_OPENH323) += openh323
 package-$(BR2_COMPILE_OPENLDAP) += openldap
 package-$(BR2_PACKAGE_OPENNTPD) += openntpd
 package-$(BR2_PACKAGE_OPENSER) += openser
@@ -195,6 +196,7 @@ package-$(BR2_PACKAGE_PRIVOXY) += privoxy
 package-$(BR2_PACKAGE_PROCMAIL) += procmail
 package-$(BR2_PACKAGE_PSYBNC) += psybnc
 package-$(BR2_PACKAGE_PTUNNEL) += ptunnel
+package-$(BR2_PACKAGE_PWLIB) += pwlib
 package-$(BR2_PACKAGE_QUAGGA) += quagga
 package-$(BR2_COMPILE_RADIUSCLIENT_NG) += radiusclient-ng
 package-$(BR2_PACKAGE_RADVD) += radvd
@@ -350,6 +352,7 @@ nfs-server-compile: portmap-compile
 nmap-compile: uclibc++-compile pcre-compile libpcap-compile
 nocatsplash-compile: glib-compile
 opencdk-compile: libgcrypt-compile
+openh323-compile: pwlib-compile
 openldap-compile: cyrus-sasl-compile openssl-compile
 openssh-compile: zlib-compile openssl-compile
 openssl-compile: zlib-compile
@@ -363,6 +366,7 @@ postgresql-compile: zlib-compile
 ppp-compile: linux-atm-compile libpcap-compile
 privoxy-compile: pcre-compile
 ptunnel-compile: libpcap-compile
+pwlib-compile: libpthread-compile
 quagga-compile: readline-compile ncurses-compile
 raddump-compile: openssl-compile libpcap-compile
 radiusclient-ng-compile: openssl-compile
index 482381a13edb7e1c4a6f9c2bd5846d46cf8c37ae..b51370e8c6a11019bfdc85260daac471ce9009ac 100644 (file)
@@ -45,6 +45,10 @@ $(PKG_BUILD_DIR)/.configured:
                --glib1=1 \
                --glib1prefix="$(STAGING_DIR)/usr" \
        );
+       @echo 'CFLAGS+="-I$(STAGING_DIR)/usr/include/iconv"' >> \
+               $(PKG_BUILD_DIR)/Makefile.settings
+       @echo 'LFLAGS+="-L$(STAGING_DIR)/usr/lib/iconv"' >> \
+               $(PKG_BUILD_DIR)/Makefile.settings
        touch $@
 
 $(PKG_BUILD_DIR)/.built:
@@ -58,10 +62,6 @@ $(IPKG_BITLBEE):
                DESTDIR="$(IDIR_BITLBEE)" install 
        install -d -m0755 $(IDIR_BITLBEE)/etc/init.d
        install -m0755 ./files/S55bitlbee $(IDIR_BITLBEE)/etc/init.d/S55bitlbee
+       $(RSTRIP) $(IDIR_BITLBEE)
        $(IPKG_BUILD) $(IDIR_BITLBEE) $(PACKAGE_DIR)
        touch $@
-
-mostlyclean:
-       $(MAKE) -C $(PKG_BUILD_DIR) clean
-       rm -f $(PKG_BUILD_DIR)/.built
-
diff --git a/openwrt/package/openh323/Config.in b/openwrt/package/openh323/Config.in
new file mode 100644 (file)
index 0000000..1aa3202
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_OPENH323
+       prompt "openh323.......................... OpenH323 implementation"
+       tristate
+       select BR2_PACKAGE_PWLIB
+       default n
+       help
diff --git a/openwrt/package/openh323/Makefile b/openwrt/package/openh323/Makefile
new file mode 100644 (file)
index 0000000..f9b8a51
--- /dev/null
@@ -0,0 +1,56 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=openh323
+PKG_VERSION:=cvs-20051230
+PKG_RELEASE:=1
+PKG_MD5SUM:=ba1ffd45016f533bec2bb1539b78e43a
+
+PKG_SOURCE_URL:=http://trash.uid0.hu/openwrt/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,OPENH323,openh323,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       rm -rf $(PKG_INSTALL_DIR);
+       mkdir -p $(PKG_INSTALL_DIR);
+       ln -s $(PKG_BUILD_DIR)/../pwlib-cvs-20051227 $(PKG_BUILD_DIR)/../pwlib; 
+       cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
+       CFLAGS="$(TARGET_CFLAGS)" \
+       CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+       LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+       PWLIBDIR="$(STAGING_DIR)" \
+           ./configure \
+           --prefix=$(STAGING_DIR) \
+           --target=$(GNU_TARGET_NAME) \
+           --host=$(GNU_TARGET_NAME) \
+           --build=$(GNU_HOST_NAME) \
+       cd $(PKG_BUILD_DIR)/plugins; rm -rf config.{cache,status}; \
+       CFLAGS="$(TARGET_CFLAGS)" \
+       CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+       LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+       PWLIBDIR="$(STAGING_DIR)" \
+           ./configure \
+           --prefix=$(STAGING_DIR)
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       CFLAGS="$(TARGET_CFLAGS)" \
+       CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+       LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+       PWLIBDIR="$(PKG_BUILD_DIR)/../pwlib-cvs-20051227/" \
+       $(MAKE) -C $(PKG_BUILD_DIR)/plugins $(TARGET_CONFIGURE_OPTS)
+       
+       CFLAGS="$(TARGET_CFLAGS)" \
+       CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+       LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+       PWLIBDIR="$(PKG_BUILD_DIR)/../pwlib-cvs-20051227/" \
+       $(MAKE) -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS) opt install
+       touch $@
diff --git a/openwrt/package/openh323/ipkg/openh323.control b/openwrt/package/openh323/ipkg/openh323.control
new file mode 100644 (file)
index 0000000..5aab368
--- /dev/null
@@ -0,0 +1,7 @@
+Package: openh323
+Priority: optional
+Section: admin
+Description: The OpenH323 project aims to create a full featured, 
+            interoperable, Open Source implementation of the ITU-T H.323 
+            teleconferencing protocol that can be used by personal 
+            developers and commercial users without charge.
diff --git a/openwrt/package/openh323/patches/001-configure.patch b/openwrt/package/openh323/patches/001-configure.patch
new file mode 100644 (file)
index 0000000..04ed8c5
--- /dev/null
@@ -0,0 +1,122 @@
+--- openh323-cvs-20051230.orig/configure       2005-08-30 03:12:38.000000000 +0200
++++ openh323-cvs-20051230/configure    2005-12-30 11:29:57.000000000 +0100
+@@ -3080,10 +3080,10 @@
+ if eval "test \"\${$as_ac_File+set}\" = set"; then
+   echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+-  test "$cross_compiling" = yes &&
+-  { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+-   { (exit 1); exit 1; }; }
++#  test "$cross_compiling" = yes &&
++#  { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
++#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
++#   { (exit 1); exit 1; }; }
+ if test -r "${PWLIBDIR}/version.h"; then
+   eval "$as_ac_File=yes"
+ else
+@@ -3104,10 +3104,10 @@
+ if eval "test \"\${$as_ac_File+set}\" = set"; then
+   echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+-  test "$cross_compiling" = yes &&
+-  { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+-   { (exit 1); exit 1; }; }
++#  test "$cross_compiling" = yes &&
++#  { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
++#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
++#   { (exit 1); exit 1; }; }
+ if test -r "${OPENH323DIR}/../pwlib/version.h"; then
+   eval "$as_ac_File=yes"
+ else
+@@ -3129,10 +3129,10 @@
+ if eval "test \"\${$as_ac_File+set}\" = set"; then
+   echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+-  test "$cross_compiling" = yes &&
+-  { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+-   { (exit 1); exit 1; }; }
++#  test "$cross_compiling" = yes &&
++#  { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
++#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
++#   { (exit 1); exit 1; }; }
+ if test -r "${HOME}/pwlib/include/ptlib.h"; then
+   eval "$as_ac_File=yes"
+ else
+@@ -3153,10 +3153,10 @@
+ if test "${ac_cv_file__usr_local_include_ptlib_h+set}" = set; then
+   echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+-  test "$cross_compiling" = yes &&
+-  { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+-   { (exit 1); exit 1; }; }
++#  test "$cross_compiling" = yes &&
++#  { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
++#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
++#   { (exit 1); exit 1; }; }
+ if test -r "/usr/local/include/ptlib.h"; then
+   ac_cv_file__usr_local_include_ptlib_h=yes
+ else
+@@ -3215,10 +3215,10 @@
+ if test "${ac_cv_file__usr_include_ptlib_h+set}" = set; then
+   echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+-  test "$cross_compiling" = yes &&
+-  { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+-   { (exit 1); exit 1; }; }
++#  test "$cross_compiling" = yes &&
++#  { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
++#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
++#   { (exit 1); exit 1; }; }
+ if test -r "/usr/include/ptlib.h"; then
+   ac_cv_file__usr_include_ptlib_h=yes
+ else
+@@ -3985,10 +3985,10 @@
+ if test "${ac_cv_file__usr_local_include_ffmpeg_avcodec_h+set}" = set; then
+   echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+-  test "$cross_compiling" = yes &&
+-  { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+-   { (exit 1); exit 1; }; }
++#  test "$cross_compiling" = yes &&
++#  { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
++#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
++#   { (exit 1); exit 1; }; }
+ if test -r "/usr/local/include/ffmpeg/avcodec.h"; then
+   ac_cv_file__usr_local_include_ffmpeg_avcodec_h=yes
+ else
+@@ -4193,10 +4193,10 @@
+ if test "${ac_cv_file__usr_local_lib_libvich263_so+set}" = set; then
+   echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+-  test "$cross_compiling" = yes &&
+-  { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+-   { (exit 1); exit 1; }; }
++#  test "$cross_compiling" = yes &&
++#  { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
++#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
++#   { (exit 1); exit 1; }; }
+ if test -r "/usr/local/lib/libvich263.so"; then
+   ac_cv_file__usr_local_lib_libvich263_so=yes
+ else
+@@ -4219,10 +4219,10 @@
+ if test "${ac_cv_file__usr_local_include_vich263_encoder_h263_h+set}" = set; then
+   echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+-  test "$cross_compiling" = yes &&
+-  { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+-   { (exit 1); exit 1; }; }
++#  test "$cross_compiling" = yes &&
++#  { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
++#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
++#   { (exit 1); exit 1; }; }
+ if test -r "/usr/local/include/vich263/encoder-h263.h"; then
+   ac_cv_file__usr_local_include_vich263_encoder_h263_h=yes
+ else
diff --git a/openwrt/package/pwlib/Config.in b/openwrt/package/pwlib/Config.in
new file mode 100644 (file)
index 0000000..1ad5429
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PWLIB
+       prompt "pwlib............................. Portable Windows library"
+       tristate
+       select BR2_PACKAGE_LIBPTHREAD
+       default n
+       help
+         Portable Windows library
diff --git a/openwrt/package/pwlib/Makefile b/openwrt/package/pwlib/Makefile
new file mode 100644 (file)
index 0000000..cb933e1
--- /dev/null
@@ -0,0 +1,59 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pwlib
+PKG_VERSION:=cvs-20051227
+PKG_RELEASE:=1
+PKG_MD5SUM:=7d5b8e9ab61a05658a5630f91505420d
+
+PKG_SOURCE_URL:=http://trash.uid0.hu/openwrt
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,PWLIB,pwlib,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
+       CFLAGS="$(TARGET_CFLAGS)" \
+       CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+       LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+       $(TARGET_CONFIGURE_OPTS) \
+           ./configure \
+           --prefix=$(STAGING_DIR) \
+           --target=$(GNU_TARGET_NAME) \
+           --host=$(GNU_TARGET_NAME) \
+           --build=$(GNU_HOST_NAME) \
+           --enable-openh323 \
+           --disable-openldap \
+           --disable-openssl \
+           --disable-ftp \
+           --disable-qos \
+           --disable-expat \
+           --disable-jabber \
+           --disable-xmlrpc \
+           --disable-ipv6 \
+           --disable-sdl \
+           --disable-video \
+           --disable-socks \
+           --disable-ftp \
+           --disable-snmp \
+           --disable-telnet \
+           --disable-serial
+           --disable-pop3smtp \
+           --disable-http \
+           --disable-httpsvc
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               all install
+       touch $@
diff --git a/openwrt/package/pwlib/ipkg/pwlib.control b/openwrt/package/pwlib/ipkg/pwlib.control
new file mode 100644 (file)
index 0000000..b573a95
--- /dev/null
@@ -0,0 +1,11 @@
+Package: pwlib
+Priority: optional
+Section: admin
+Description: Portable Windows Library
+            "PWLib is a moderately large class library that has its genesis 
+            many years ago asa method to product applications to run on both M
+            icrosoft Windows and Unix X-Windows systems.
+            [...]
+            Classes for I/O portability, multi-threading portability, aid in 
+            producing unix daemons and NT services portably and all
+            sorts of internet protocols were added over the years."
\ No newline at end of file
diff --git a/openwrt/package/pwlib/patches/002-lib_mak.patch b/openwrt/package/pwlib/patches/002-lib_mak.patch
new file mode 100644 (file)
index 0000000..43018bd
--- /dev/null
@@ -0,0 +1,11 @@
+--- pwlib-cvs-20051227/make/lib.mak.orig       2005-09-25 12:51:23.000000000 +0200
++++ pwlib-cvs-20051227/make/lib.mak    2005-12-30 01:18:21.000000000 +0100
+@@ -201,7 +201,7 @@
+       LDSOOPTS += -Wl,--kill-at
+     else
+     ifneq ($(OSTYPE),Darwin)
+-      LDSOOPTS += -Wl,-soname,$(LIB_SONAME)
++      LDSOOPTS += -soname,$(LIB_SONAME)
+     endif
+     endif
+     LD = $(CPLUS)