fstools: the ubi flash tool is obselete now
authorJohn Crispin <john@openwrt.org>
Wed, 11 Jun 2014 12:59:45 +0000 (12:59 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 11 Jun 2014 12:59:45 +0000 (12:59 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 41128

package/system/fstools/Makefile

index b10f105a741f7bdd830869960a1ca950bd39ab84..08b3be478f84a6d00daf1e97ee9fd539c9dca6da 100644 (file)
@@ -32,16 +32,10 @@ TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
 define Package/fstools
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+ubox +USE_EGLIBC:librt
+  DEPENDS:=+ubox +USE_EGLIBC:librt +NAND_SUPPORT:ubi-utils
   TITLE:=OpenWrt filesystem tools
 endef
 
-define Package/ubi-flash
-  SECTION:=base
-  CATEGORY:=Base system
-  TITLE:=OpenWrt ubi flashing tool
-endef
-
 define Package/block-mount
   SECTION:=base
   CATEGORY:=Base system
@@ -58,12 +52,6 @@ define Package/fstools/install
        ln -s /sbin/jffs2reset $(1)/sbin/jffs2mark
 endef
 
-define Package/ubi-flash/install
-       $(INSTALL_DIR) $(1)/sbin $(1)/lib
-
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ubi $(1)/sbin/
-endef
-
 define Package/block-mount/install
        $(INSTALL_DIR) $(1)/sbin $(1)/lib $(1)/usr/sbin $(1)/etc/hotplug.d/block $(1)/etc/init.d/ $(1)/etc/uci-defaults/
 
@@ -86,5 +74,4 @@ define Build/InstallDev
 endef
 
 $(eval $(call BuildPackage,fstools))
-$(eval $(call BuildPackage,ubi-flash))
 $(eval $(call BuildPackage,block-mount))