ramips: Buffalo WZR-AGL300NH target support
authorJohn Crispin <john@openwrt.org>
Mon, 16 Feb 2015 21:19:18 +0000 (21:19 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 16 Feb 2015 21:19:18 +0000 (21:19 +0000)
I got work with this patch.
Ethernet switch (includes VLAN), WiFi connected via PCIe, LEDs, buttons.

In mtd partion map of DTS file, I renamed Linux firmware regions (kernel + root squashfs) to “firmware”because it allows kernel to split kernel and roots and rootfsdata.

signed-off-by: ngc@ff.iij4u.or.jp
——
——

SVN-Revision: 44470

target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/WZR-AGL300NH.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile

index f298aa47afce22144cfbdf8b134eac02ce6f2dcb..7e9d8c984b1cc8df8fd47689e720eb7a4268e9e9 100755 (executable)
@@ -242,6 +242,12 @@ ramips_setup_interfaces()
                ucidef_add_switch_vlan "switch1" "2" "4 6t"
                ;;
 
+       wzr-agl300nh)
+               ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
+               ucidef_add_switch "switch0" "1" "1"
+               ucidef_add_switch_vlan "switch0" "1" "1 2 3 4 5t"
+               ucidef_add_switch_vlan "switch0" "2" "0 5t"
+               ;;
        *)
                RT3X5X=`cat /proc/cpuinfo | egrep "(RT3.5|RT5350)"`
                if [ -n "${RT3X5X}" ]; then
index d31fbe4f986c07f2728109ae39bd9d51acb1d786..39a0868727fb3ab9453eebc1c3f8b2553fb4a427 100644 (file)
@@ -168,6 +168,9 @@ get_status_led() {
        wli-tx4-ag300n)
                status_led="buffalo:blue:power"
                ;;
+       wzr-agl300nh)
+               status_led="buffalo:green:router"
+               ;;
        wl-351)
                status_led="wl-351:amber:power"
                ;;
index 356a0856c9ab52cd6d4cf2d09bd65221b25ec7bd..fffbe72cb8dc3927b7bf70da091be4f228961ef5 100755 (executable)
@@ -100,6 +100,7 @@ platform_check_image() {
        wl-351 | \
        wl341v3 | \
        wli-tx4-ag300n | \
+       wzr-agl300nh | \
        wmr300 |\
        wnce2001 | \
        wr512-3gn |\
diff --git a/target/linux/ramips/dts/WZR-AGL300NH.dts b/target/linux/ramips/dts/WZR-AGL300NH.dts
new file mode 100644 (file)
index 0000000..8e18e90
--- /dev/null
@@ -0,0 +1,135 @@
+/dts-v1/;
+
+/include/ "rt2880.dtsi"
+
+/ {
+       #address-cells = <1>;
+       #size-cells = <1>;
+       compatible = "WZR-AGL300NH", "ralink,rt2880-soc";
+       model = "Buffalo WZR-AGL300NH";
+
+       palmbus@300000 {
+               gpio0: gpio@600 {
+                       status = "okay";
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "i2c", "uartlite", "mdio";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       cfi@1f000000 {
+               compatible = "cfi-flash";
+               reg = <0x1f000000 0x800000>;
+
+               bank-width = <2>;
+               device-width = <2>;
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       label = "uboot";
+                       reg = <0x0 0x30000>;
+                       read-only;
+               };
+               partition@30000 {
+                       label = "uboot-env";
+                       reg = <0x30000 0x10000>;
+                       read-only;
+               };
+               factory: partition@40000 {
+                       label = "factory";
+                       reg = <0x40000 0x10000>;
+                       read-only;
+               };
+               partition@50000 {
+                       label = "firmware";
+                       reg = <0x50000 0x3b0000>;
+               };
+       };
+
+       ethernet@400000 {
+               status = "okay";
+               mtd-mac-address = <&factory 0x4>;
+
+                port@0 {
+                       ralink,fixed-link = <1000 1 1 1>;
+               };
+
+               mdio-bus {
+                       status = "okay";
+                       phy0: ethernet-phy@0 {
+                               phy-mode = "mii";
+                               reg = <0>;
+                       };
+               };
+       };
+
+       rtl8366s {
+               compatible = "realtek,rtl8366s";
+               gpio-sda = <&gpio0 1 0>;
+               gpio-sck = <&gpio0 2 0>;
+       };
+
+       wmac@480000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <100>;
+               wps {
+                       label = "wps";
+                       gpios = <&gpio0 0 1>;
+                       linux,code = <0x211>;
+               };
+               router {
+                       label = "router_switch";
+                       gpios = <&gpio0 7 0>;
+                       linux,code = <0x100>;
+               };
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 9 1>;
+                       linux,code = <0x198>;
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               router {
+                       label = "buffalo:green:router";
+                       gpios = <&gpio0 8 1>;
+               };
+               diag {
+                       label = "buffalo:red:diag";
+                       gpios = <&gpio0 12 1>;
+               };
+               security_g {
+                       label = "buffalo:orange:security_g";
+                       gpios = <&gpio0 11 1>;
+               };
+               security_n {
+                       label = "buffalo:orange:security_n";
+                       gpios = <&gpio0 13 1>;
+               };
+       };
+
+
+       pcibus0: pci@00440000 {
+               compatible = "ralink,rt288x-pci";
+               reg = <0x00440000 0x20000>;
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               status = "ok";
+       };
+};
index 73637300fdca1cf6f01d4b0c49636fc26ee8da5b..6e6b10bd4675aa38150b807df48c38b636bc905d 100644 (file)
@@ -395,6 +395,8 @@ Image/Build/Profile/V11STFE=$(call BuildFirmware/Default4M/$(1),$(1),v11st-fe,V1
 
 Image/Build/Profile/WLITX4AG300N=$(call BuildFirmware/Default4M/$(1),$(1),wli-tx4-ag300n,WLI-TX4-AG300N)
 
+Image/Build/Profile/WZRAGL300NH=$(call BuildFirmware/Default4M/$(1),$(1),wzr-agl300nh,WZR-AGL300NH)
+
 ifeq ($(SUBTARGET),rt288x)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/AR670W,$(1))
@@ -403,6 +405,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/RTN15,$(1))
        $(call Image/Build/Profile/V11STFE,$(1))
        $(call Image/Build/Profile/WLITX4AG300N,$(1))
+       $(call Image/Build/Profile/WZRAGL300NH,$(1))
 endef
 endif