fix build error in tools on darwin on newer macs (patch by dirtyfreebooter)
authorFelix Fietkau <nbd@openwrt.org>
Sun, 5 Sep 2010 16:16:59 +0000 (16:16 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 5 Sep 2010 16:16:59 +0000 (16:16 +0000)
SVN-Revision: 22934

include/host.mk
tools/cloog/Makefile
tools/gmp/Makefile
tools/mpc/Makefile
tools/ppl/Makefile

index 02365d9eabdf074a35c6cccc20eeb9bf8709ffd0..8092e8db77ac74e1f07c2c1ab1e15b7f1a9a30b4 100644 (file)
@@ -32,11 +32,12 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
                HOST_OS=`uname`; \
                case "$$HOST_OS" in \
                        Linux) HOST_ARCH=`uname -m`;; \
+                       Darwin) HOST_ARCH=`uname -m`;; \
                        *) HOST_ARCH=`uname -p`;; \
                esac; \
                GNU_HOST_NAME=`gcc -dumpmachine`; \
-               [ -n "$$GNU_HOST_NAME" ] || \
-                       GNU_HOST_NAME=`$(SCRIPT_DIR)/config.guess`; \
+               [ -z "$$GNU_HOST_NAME" -o "$$HOST_OS" == "Darwin" ] && \
+                       GNU_HOST_NAME=`$(TOPDIR)/scripts/config.guess`; \
                echo "HOST_OS:=$$HOST_OS" > $@; \
                echo "HOST_ARCH:=$$HOST_ARCH" >> $@; \
                echo "GNU_HOST_NAME:=$$GNU_HOST_NAME" >> $@; \
index 3bbf812fe941c94cb5af8dcfb42c89a2f5b4ab2f..29b4b73040653360bc1e0f892d71c31851290d2d 100644 (file)
@@ -17,11 +17,6 @@ include $(INCLUDE_DIR)/host-build.mk
 
 unexport CFLAGS
 
-ifeq ($(HOST_OS),Darwin)
-  GNU_HOST_NAME:=
-  HOST_CONFIGURE_ARGS:=$(filter-out --target= --build= --host=,$(HOST_CONFIGURE_ARGS))
-endif
-
 HOST_CONFIGURE_VARS += \
        LIBS=-lstdc++
 
index f375ada3478c8da056077cbfbeefd8822e62b037..514187ce6e376593810c4707137c2b8274cc66fb 100644 (file)
@@ -17,11 +17,6 @@ include $(INCLUDE_DIR)/host-build.mk
 
 unexport CFLAGS
 
-ifeq ($(HOST_OS),Darwin)
-  GNU_HOST_NAME:=
-  HOST_CONFIGURE_ARGS:=$(filter-out --target= --build= --host=,$(HOST_CONFIGURE_ARGS))
-endif
-
 HOST_CONFIGURE_ARGS += \
        --enable-static \
        --disable-shared \
index 3898830c0b94eb92e4d41934548dc11305106e02..8f8f07f1ccfac9ed62f7d0f51bcfb21c19477dcd 100644 (file)
@@ -17,11 +17,6 @@ include $(INCLUDE_DIR)/host-build.mk
 
 unexport CFLAGS
 
-ifeq ($(HOST_OS),Darwin)
-  GNU_HOST_NAME:=
-  HOST_CONFIGURE_ARGS:=$(filter-out --target= --build= --host=,$(HOST_CONFIGURE_ARGS))
-endif
-
 HOST_CONFIGURE_ARGS += \
        --enable-static \
        --disable-shared \
index c9c09c512592430d712dce6650d0f813788cf078..7eea73f0b0c7e5bb735641de3ebf5b531ea22f34 100644 (file)
@@ -17,11 +17,6 @@ include $(INCLUDE_DIR)/host-build.mk
 
 unexport CFLAGS
 
-ifeq ($(HOST_OS),Darwin)
-  GNU_HOST_NAME:=
-  HOST_CONFIGURE_ARGS:=$(filter-out --target= --build= --host=,$(HOST_CONFIGURE_ARGS))
-endif
-
 HOST_CONFIGURE_ARGS += \
        --enable-static \
        --disable-shared