Add a PyMod template for python related modules
authorFlorian Fainelli <florian@openwrt.org>
Tue, 28 Aug 2007 12:41:39 +0000 (12:41 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 28 Aug 2007 12:41:39 +0000 (12:41 +0000)
SVN-Revision: 8522

include/package.mk

index 1e18f8cd81495575d7b5c6fae9d99ead25e0a152..4b811f8af6afe3b16b9e9d9604dced40d7e2a53e 100644 (file)
@@ -128,6 +128,15 @@ define Build/Compile
   $(call Build/Compile/Default,)
 endef
 
+define Build/Compile/PyMod
+ cd $(PKG_BUILD_DIR); \
+ $(1) \
+ CFLAGS='-I$(STAGING_DIR)/usr/include' \
+ LDFLAGS='$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib' \
+ $(STAGING_DIR)/usr/bin/hostpython ./setup.py $(2) \
+ --prefix=$(PKG_INSTALL_DIR)/usr
+endef
+
 $(PACKAGE_DIR):
        mkdir -p $@