brcm47xx: dont manually insmod switch drivers
authorJohn Crispin <john@openwrt.org>
Fri, 21 Jun 2013 16:53:15 +0000 (16:53 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 21 Jun 2013 16:53:15 +0000 (16:53 +0000)
Signed-off-by: John Crispin <bloic@openwrt.org>
SVN-Revision: 36993

package/switch/Makefile
target/linux/brcm47xx/base-files/lib/preinit/05_init_interfaces_brcm

index c577584803078bea743a4fa0bc5ca6d520101638..fd1504e1565f89a31e4d0dd4c4f1bd99e9ddacc8 100644 (file)
@@ -21,7 +21,7 @@ define KernelPackage/switch
        $(PKG_BUILD_DIR)/switch-core.ko \
        $(PKG_BUILD_DIR)/switch-adm.ko \
        $(PKG_BUILD_DIR)/switch-robo.ko
-  AUTOLOAD:=$(call AutoLoad,20,switch-core switch-robo switch-adm)
+  AUTOLOAD:=$(call AutoLoad,20,switch-core switch-robo switch-adm,1)
 endef
 
 define KernelPackage/switch/description
index e85dd49f4296181208401bf60a32629afcedae0a..04992dee16311e76685943b29713c3b7743ffbb7 100644 (file)
@@ -23,10 +23,6 @@ set_preinit_iface() {
 }
 
 init_iface() {
-       insmod switch-core
-       insmod switch-robo
-       insmod switch-adm
-
        [ -d /proc/switch/eth0 ] && [ "$ifname" = "eth0" ] && {
                case "$(cat /proc/switch/eth0/cpuport)" in
                        "5") cpu_port="5u*";;