kmod-ipt-iprange: fix build error on .25
authorGabor Juhos <juhosg@openwrt.org>
Wed, 30 Apr 2008 15:42:10 +0000 (15:42 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 30 Apr 2008 15:42:10 +0000 (15:42 +0000)
SVN-Revision: 10992

include/netfilter.mk
package/kernel/modules/netfilter.mk
target/linux/generic-2.6/config-2.6.25

index 7e7005d2a2147c944521dfbfe2ed35c248e6052d..56c558825207a0491f7acdb41cc6d4dd23671dda 100644 (file)
@@ -120,6 +120,7 @@ $(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_TARGET_TOS, $(P_V4)ipt_TOS))
 # iprange
 
 $(eval $(call nf_add,IPT_IPRANGE,CONFIG_IP_NF_MATCH_IPRANGE, $(P_V4)ipt_iprange))
+$(eval $(call nf_add,IPT_IPRANGE,CONFIG_NETFILTER_XT_MATCH_IPRANGE, $(P_XT)xt_iprange))
 
 
 # ipsec
index bafb5ea92e6b17b46d092b5c39dfb7ed7bf9f634..e753fb24fe74464a1f3a2fd03ee4f558ca123b9b 100644 (file)
@@ -204,7 +204,7 @@ $(eval $(call KernelPackage,ipt-ulog))
 define KernelPackage/ipt-iprange
   SUBMENU:=$(NF_MENU)
   TITLE:=Module for matching ip ranges
-  FILES:=$(LINUX_DIR)/net/ipv4/netfilter/ipt_iprange.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(foreach mod,$(IPT_IPRANGE-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,40,$(notdir $(IPT_IPRANGE-m)))
 endef
 
index d797a8c387b99f49fe127fa371964a757a2ec095..e9ac69a756bbb0309cae8ce298828d278aa8e0ac 100644 (file)
@@ -593,7 +593,6 @@ CONFIG_IP_NF_MATCH_AH=m
 CONFIG_IP_NF_MATCH_ECN=m
 CONFIG_IP_NF_MATCH_HASHLIMIT=m
 CONFIG_IP_NF_MATCH_IPP2P=m
-CONFIG_IP_NF_MATCH_IPRANGE=m
 CONFIG_NETFILTER_XT_MATCH_LAYER7=m
 # CONFIG_NETFILTER_XT_MATCH_LAYER7_DEBUG is not set
 CONFIG_NETFILTER_XT_MATCH_TIME=m