simplify and fix adm5120 image building, fix broken FEATURES handling
authorFelix Fietkau <nbd@openwrt.org>
Mon, 23 Jul 2007 02:13:10 +0000 (02:13 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 23 Jul 2007 02:13:10 +0000 (02:13 +0000)
SVN-Revision: 8113

target/linux/adm5120-2.6/Makefile
target/linux/adm5120-2.6/image/Makefile
target/linux/adm5120-2.6/profiles/RB1xx.mk

index fb46f28312fa2e8289f3dee694e46201bdd71c63..8a4884c9ca8783da3dbaea6caa7b679a31cb8998 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=adm5120
 BOARDNAME:=ADM5120 (Little Endian)
-FEATURES:=squashfs jffs2 pci usb broken
+FEATURES:=squashfs jffs2 tgz broken
 
 LINUX_VERSION:=2.6.22.1
 
index ee70b6b1aaab611bd9f7e021546e2bf3aa9932ac..802fd956af117dd5e4aadd92a16f89d4c0b802f9 100644 (file)
@@ -86,10 +86,7 @@ define Image/Build/RouterBoard
        $(STAGING_DIR)/bin/patch-cmdline $(KDIR)/vmlinux.elf '$(strip $(call Image/cmdline/yaffs2)) '
 endef
 
-define Image/Build
-# this line is here intentionally
-ifneq ($(1),jffs2-256k)
-ifneq ($(1),jffs2-128k)
+define Image/Build/jffs2-64k
        $(call Image/Build/Compex,$(1),wp54g-wrt,$(patsubst jffs2-%,jffs2,$(1)),WP54G-WRT)
 ifeq ($(CONFIG_DEVEL),y)
        $(call Image/Build/Edimax,$(1),br-6104k,$(patsubst jffs2-%,jffs2,$(1)),BR-6104K)
@@ -117,8 +114,14 @@ ifeq ($(CONFIG_DEVEL),y)
        $(call Image/Build/MyLoader,$(1),wpp54g,$(patsubst jffs2-%,jffs2,$(1)),WPP54G)
        $(call Image/Build/MyLoader,$(1),wpp54ag,$(patsubst jffs2-%,jffs2,$(1)),WPP54AG)
 endif
-endif
-endif
+endef
+
+define Image/Build/squashfs
+$(call Image/Build/jffs2-64k,$(1))
+endef
+
+define Image/Build
+$(call Image/Build/$(1),$(1))
 endef
 
 ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
index 58622429e6f14aa9343efe5c33166271f10f6f4e..9dd3de09735858fdfc322ab866a6a5d7688f8c7f 100644 (file)
@@ -8,7 +8,6 @@
 define Profile/RouterBoard
   NAME:=RouterBoard RB1xx
   PACKAGES:=kmod-madwifi
-  FEATURES:=tgz pci
 endef
 
 define Profile/RouterBoard/Description