kernel: bump 5.4 to 5.4.154
authorJohn Audia <graysky@archlinux.us>
Sun, 17 Oct 2021 13:14:42 +0000 (09:14 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 20 Oct 2021 22:17:36 +0000 (00:17 +0200)
All patches automatically rebased.

Signed-off-by: John Audia <graysky@archlinux.us>
23 files changed:
include/kernel-version.mk
target/linux/ath25/patches-5.4/107-ar5312_gpio.patch
target/linux/ath79/patches-5.4/0032-MIPS-ath79-sanitize-symbols.patch
target/linux/bcm4908/patches-5.4/072-v5.12-0002-net-broadcom-bcm4908enet-add-BCM4908-controller-driv.patch
target/linux/bcm4908/patches-5.4/073-v5.12-0001-dt-bindings-net-rename-BCM4908-Ethernet-binding.patch
target/linux/bcm4908/patches-5.4/073-v5.12-0003-net-broadcom-rename-BCM4908-driver-update-DT-binding.patch
target/linux/bcm4908/patches-5.4/082-v5.12-0002-soc-bcm-add-PM-driver-for-Broadcom-s-PMB.patch
target/linux/bcm63xx/patches-5.4/322-MIPS-BCM63XX-switch-to-IRQ_DOMAIN.patch
target/linux/generic/hack-5.4/661-use_fq_codel_by_default.patch
target/linux/lantiq/patches-5.4/0152-lantiq-VPE.patch
target/linux/layerscape/patches-5.4/701-net-0130-bus-fsl-mc-move-fsl_mc_command-struct-in-a-uapi-head.patch
target/linux/layerscape/patches-5.4/701-net-0132-bus-fsl-mc-add-root-dprc-rescan-attribute.patch
target/linux/layerscape/patches-5.4/701-net-0261-net-mscc-ocelot-publish-ocelot_sys.h-to-include-soc-.patch
target/linux/layerscape/patches-5.4/701-net-0262-net-dsa-ocelot-add-tagger-for-Ocelot-Felix-switches.patch
target/linux/layerscape/patches-5.4/701-net-0263-net-dsa-ocelot-add-driver-for-Felix-switch-family.patch
target/linux/layerscape/patches-5.4/701-net-0323-staging-fsl_ppfe-eth-add-pfe-support-to-Kconfig-and-.patch
target/linux/layerscape/patches-5.4/809-jailhouse-0020-jailhouse-Add-simple-debug-console-via-the-hyperviso.patch
target/linux/layerscape/patches-5.4/810-keys-0001-security-keys-secure_key-Adds-the-secure-key-support.patch
target/linux/layerscape/patches-5.4/810-keys-0002-encrypted_keys-Adds-support-for-secure-key-type-as-m.patch
target/linux/layerscape/patches-5.4/812-pcie-0009-PCI-mobiveil-Refactor-Mobiveil-PCIe-Host-Bridge-IP-d.patch
target/linux/layerscape/patches-5.4/812-pcie-0016-PCI-mobiveil-Add-the-EP-driver-support.patch
target/linux/layerscape/patches-5.4/814-qe-0006-config-qe-add-irq-qeic-support.patch
target/linux/realtek/patches-5.4/300-mips-add-rtl838x-platform.patch

index 46aa1855254f4b32cc4e0573ce4c7ec04a427d2a..4008511940ba1d230d95f27cfda0688c5a60f835 100644 (file)
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .153
+LINUX_VERSION-5.4 = .154
 LINUX_VERSION-5.10 = .72
 
-LINUX_KERNEL_HASH-5.4.153 = 6d9f07c9d611e5a7317eb6d5114880bad5c2dc1ac48d89f861b887d2f4295f49
+LINUX_KERNEL_HASH-5.4.154 = 058994f4666b6b0474a4d5228583e394594e406783b7e93d487c2a66c35f3c06
 LINUX_KERNEL_HASH-5.10.72 = b4d635afe7646ac6a6617c738e747ba0a6006675cd9735d18f672f8b1fba4c7c
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 7b8c9650cc7ba87254f4d986fa8c7664c70d3716..321ebc7fb83371569cb6ce764926a84317af5087 100644 (file)
 +subsys_initcall(ar5312_gpio_init);
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -190,6 +190,7 @@ config ATH25
+@@ -192,6 +192,7 @@ config ATH25
        select CEVT_R4K
        select CSRC_R4K
        select DMA_NONCOHERENT
index 9fa199a2046e35492ec9c416eb23ea0e4d165c4c..3d79121e9408db227093e5a49cd456037422f3ff 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -218,6 +218,8 @@ config ATH79
+@@ -220,6 +220,8 @@ config ATH79
        select SYS_SUPPORTS_BIG_ENDIAN
        select SYS_SUPPORTS_MIPS16
        select SYS_SUPPORTS_ZBOOT_UART_PROM
index adef3d87acf44d7d7f74d886425c227ee223a1e5..3f6444e6b35a0b8655e97addbc2847ddae6d117a 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -3207,6 +3207,15 @@ F:      Documentation/devicetree/bindings/mip
+@@ -3208,6 +3208,15 @@ F:      Documentation/devicetree/bindings/mip
  F:    arch/mips/bcm47xx/*
  F:    arch/mips/include/asm/mach-bcm47xx/*
  
index df3fca624aea1a41fefbf7ac59a35d2ae32ccc6c..563cb3ba91393708c621acc8dad1e53486cd3535 100644 (file)
@@ -117,7 +117,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 +    };
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -3212,7 +3212,7 @@ M:       Rafał Miłecki <rafal@milecki.pl>
+@@ -3213,7 +3213,7 @@ M:       Rafał Miłecki <rafal@milecki.pl>
  M:    bcm-kernel-feedback-list@broadcom.com
  L:    netdev@vger.kernel.org
  S:    Maintained
index 603d4c9c0c4ba9ebe0b641014418bf637654e858..66681963c10cf9dee1c9b23ebb4a28167307255d 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -3213,7 +3213,7 @@ M:       bcm-kernel-feedback-list@broadcom.com
+@@ -3214,7 +3214,7 @@ M:       bcm-kernel-feedback-list@broadcom.com
  L:    netdev@vger.kernel.org
  S:    Maintained
  F:    Documentation/devicetree/bindings/net/brcm,bcm4908-enet.yaml
index 5b8781a339b2b7a57c57f987d9612cd89c743ec9..40126a968bf7281823692520713cff97500af617 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -3414,6 +3414,16 @@ L:      linux-mips@vger.kernel.org
+@@ -3415,6 +3415,16 @@ L:      linux-mips@vger.kernel.org
  S:    Maintained
  F:    drivers/firmware/broadcom/*
  
index eff4af025e34d5085dbe0c6653da6d2d4326c3c2..7fe81ba5b0a1d60c980cc6e8ea2a4f0cfe7db286 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -292,6 +292,9 @@ config BCM63XX
+@@ -294,6 +294,9 @@ config BCM63XX
        select SYNC_R4K
        select DMA_NONCOHERENT
        select IRQ_MIPS_CPU
index cd86a7ab84b9edb9325c2dd81b1297509cfd985a..bbe43d24c240d93f9ae3ffe44a07f88f91c14efd 100644 (file)
@@ -44,7 +44,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
          device, it has to decide which ones to send first, which ones to
 --- a/net/sched/sch_api.c
 +++ b/net/sched/sch_api.c
-@@ -2272,7 +2272,7 @@ static int __init pktsched_init(void)
+@@ -2278,7 +2278,7 @@ static int __init pktsched_init(void)
                return err;
        }
  
index 2aff479024201ddcea2daddb8d3eb92f33598f00..f9c116a33062c3bdb76d6c49d86561c7666ef8f6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -2379,6 +2379,12 @@ config MIPS_VPE_LOADER
+@@ -2381,6 +2381,12 @@ config MIPS_VPE_LOADER
          Includes a loader for loading an elf relocatable object
          onto another VPE and running it.
  
index 335ec7108c638ae6b0f9d11789beadb6f613906d..5aa85bf51cafbf1e852fefc18c44023f2db9f12f 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Ioana Ciornei <ioana.ciornei@nxp.com>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -13437,6 +13437,8 @@ S:     Maintained
+@@ -13438,6 +13438,8 @@ S:     Maintained
  F:    drivers/bus/fsl-mc/
  F:    Documentation/devicetree/bindings/misc/fsl,qoriq-mc.txt
  F:    Documentation/networking/device_drivers/freescale/dpaa2/overview.rst
index 9062346821bee5d8ac6a980099054bcf53f90ffd..8fd964993eab9cb02870fefa7f595f999af00013 100644 (file)
@@ -31,7 +31,7 @@ Signed-off-by: Ioana Ciornei <ioana.ciornei@nxp.com>
 +Users:                Userspace drivers and management tools
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -13439,6 +13439,7 @@ F:     Documentation/devicetree/bindings/mis
+@@ -13440,6 +13440,7 @@ F:     Documentation/devicetree/bindings/mis
  F:    Documentation/networking/device_drivers/freescale/dpaa2/overview.rst
  F:    Documentation/networking/dpaa2/overview.rst
  F:    include/uapi/linux/fsl_mc.h
index 98556523e352ca885f6be92605c094ce76b5225a..f65ae631dcba3cc4cc3806c2359256c67e55c641 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -10825,6 +10825,7 @@ M:     Microchip Linux Driver Support <UNGLi
+@@ -10826,6 +10826,7 @@ M:     Microchip Linux Driver Support <UNGLi
  L:    netdev@vger.kernel.org
  S:    Supported
  F:    drivers/net/ethernet/mscc/
index b849387c44686a258cbc8145892547d19c54784b..5304bbca0ad7daecefd14835143fecd8fa91a586 100644 (file)
@@ -39,7 +39,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -17355,6 +17355,13 @@ S:    Maintained
+@@ -17356,6 +17356,13 @@ S:    Maintained
  F:    drivers/input/serio/userio.c
  F:    include/uapi/linux/userio.h
  
index 3c729498a92903db46e293822c619063a4a9d4d2..5dc50c5ee61478b88ae7f000e04d6249eb51f8e7 100644 (file)
@@ -57,7 +57,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -17360,6 +17360,7 @@ M:     Vladimir Oltean <vladimir.oltean@nxp.
+@@ -17361,6 +17361,7 @@ M:     Vladimir Oltean <vladimir.oltean@nxp.
  M:    Claudiu Manoil <claudiu.manoil@nxp.com>
  L:    netdev@vger.kernel.org
  S:    Maintained
index 7d071397f0f7cc6a2391bf38533f4ace3fff38a0..d370f728dd267931e8e0bc0439885597626d80eb 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Dong Aisheng <aisheng.dong@nxp.com>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -6575,6 +6575,14 @@ F:      drivers/ptp/ptp_qoriq_debugfs.c
+@@ -6576,6 +6576,14 @@ F:      drivers/ptp/ptp_qoriq_debugfs.c
  F:    include/linux/fsl/ptp_qoriq.h
  F:    Documentation/devicetree/bindings/ptp/ptp-qoriq.txt
  
index 72f3048d8fe5f901603d3c7f11041b60e52a8cba..d3fb53ec5885c8de3bdacfa1a51d2b185ae9475d 100644 (file)
@@ -21,7 +21,7 @@ From http://git.kiszka.org/?p=linux.git;a=shortlog;h=refs/heads/queues/jailhouse
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -8773,6 +8773,7 @@ L:       jailhouse-dev@googlegroups.com
+@@ -8774,6 +8774,7 @@ L:       jailhouse-dev@googlegroups.com
  S:    Maintained
  F:    arch/x86/kernel/jailhouse.c
  F:    arch/x86/include/asm/jailhouse_para.h
index 65b996d879289dc234b7938ecc53520b1c2cff8d..2347212a916bd969e502fce0585147379ccc3dd9 100644 (file)
@@ -100,7 +100,7 @@ Reviewed-by: Sahil Malhotra <sahil.malhotra@nxp.com>
 +      $ keyctl load secure kmk-master "load 'cat secure_key.blob'" @u
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -9074,6 +9074,17 @@ F:      include/keys/trusted-type.h
+@@ -9075,6 +9075,17 @@ F:      include/keys/trusted-type.h
  F:    security/keys/trusted.c
  F:    include/keys/trusted.h
  
index ed2eaa8a6169ac879ed0a6d2188a21d3ee6c3de3..3a354e1fa88d77223ab7368fc37c49c53d2cd5d0 100644 (file)
@@ -23,7 +23,7 @@ Reviewed-by: Sahil Malhotra <sahil.malhotra@nxp.com>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -9084,6 +9084,7 @@ F:       include/keys/secure-type.h
+@@ -9085,6 +9085,7 @@ F:       include/keys/secure-type.h
  F:    security/keys/secure_key.c
  F:    security/keys/securekey_desc.c
  F:    security/keys/securekey_desc.h
index acbf2fe35aec86f1a2591d10f0781b9a471736c0..08f7a7a0f0808abacf6f28796848f4c2475d5623 100644 (file)
@@ -34,7 +34,7 @@ Reviewed-by: Subrahmanya Lingappa <l.subrahmanya@mobiveil.co.in>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -12503,7 +12503,7 @@ M:     Hou Zhiqiang <Zhiqiang.Hou@nxp.com>
+@@ -12504,7 +12504,7 @@ M:     Hou Zhiqiang <Zhiqiang.Hou@nxp.com>
  L:    linux-pci@vger.kernel.org
  S:    Supported
  F:    Documentation/devicetree/bindings/pci/mobiveil-pcie.txt
index 5182eed992ffe3627376efad73488b629a20e9ea..667094355f774912370c56e3bf4c944a0d6f3d07 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Hou Zhiqiang <Zhiqiang.Hou@nxp.com>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -12500,6 +12500,7 @@ F:     drivers/ntb/hw/mscc/
+@@ -12501,6 +12501,7 @@ F:     drivers/ntb/hw/mscc/
  PCI DRIVER FOR MOBIVEIL PCIE IP
  M:    Karthikeyan Mitran <m.karthikeyan@mobiveil.co.in>
  M:    Hou Zhiqiang <Zhiqiang.Hou@nxp.com>
index babf74329b19286833beb3935a430ba7ebbfb62a..5d8c35d04f476b5b00427ca97430f9f2e5885b63 100644 (file)
@@ -12,7 +12,7 @@ Signed-off-by: Zhao Qiang <qiang.zhao@nxp.com>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -6597,6 +6597,12 @@ F:      drivers/soc/fsl/qe/
+@@ -6598,6 +6598,12 @@ F:      drivers/soc/fsl/qe/
  F:    include/soc/fsl/*qe*.h
  F:    include/soc/fsl/*ucc*.h
  
index ecc77b2a733637348c5ea38c1bbe46fda84e3ab3..c680d5f4a562ed34b0c6db1bae8c12b7b6909f27 100644 (file)
@@ -10,7 +10,7 @@
  platforms += sgi-ip27
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -631,6 +631,26 @@ config RALINK
+@@ -633,6 +633,26 @@ config RALINK
        select ARCH_HAS_RESET_CONTROLLER
        select RESET_CONTROLLER