mvebu: fix NAND and NOR options
authorImre Kaloz <kaloz@openwrt.org>
Thu, 5 Feb 2015 11:26:17 +0000 (11:26 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Thu, 5 Feb 2015 11:26:17 +0000 (11:26 +0000)
All the boards but Mamba had wrong UBI options so far, making it impossible to
flash the built image on their respective storage medium.

Fix all of the supported boards in order to make the generated images useful.

Tested on a Mirabox, an Armada XP GP and an Openblocks AX3, and used the NAND
chip datasheet for the others.

Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 44264

target/linux/mvebu/image/Makefile

index a8fc4de134f89b070df6b541a047c812374cf349..c8ec72e87ce388211830b07e3e6728235ecdc5e6 100644 (file)
@@ -125,14 +125,18 @@ define MultiProfile
   endef
 endef
 
+# Boards with NAND, without subpages
+$(eval $(call NANDProfile,370-DB,armada-370-db,512KiB,4096))
+$(eval $(call NANDProfile,370-RD,armada-370-rd,512KiB,4096))
+$(eval $(call NANDProfile,Mirabox,armada-370-mirabox,512KiB,4096))
+$(eval $(call NANDProfile,XP-DB,armada-xp-db,512KiB,4096))
+$(eval $(call NANDProfile,XP-GP,armada-xp-gp,512KiB,4096))
+
 # Boards with NAND, with subpages
-$(eval $(call NANDProfile,370-DB,armada-370-db,128KiB,2048,512))
-$(eval $(call NANDProfile,370-RD,armada-370-rd,128KiB,2048,512))
 $(eval $(call NANDProfile,Mamba,armada-xp-mamba,128KiB,2048,512))
-$(eval $(call NANDProfile,Mirabox,armada-370-mirabox,128KiB,2048,512))
-$(eval $(call NANDProfile,OpenBlocks-AX-3-4,armada-xp-openblocks-ax3-4,128KiB,2048,512))
-$(eval $(call NANDProfile,XP-DB,armada-xp-db,128KiB,2048,512))
-$(eval $(call NANDProfile,XP-GP,armada-xp-gp,128KiB,2048,512))
+
+# Boards with large NOR, where we want to use UBI
+$(eval $(call UBINORProfile,OpenBlocks-AX-3-4,armada-xp-openblocks-ax3-4,128KiB))
 
 define Image/Build/Profile/Mamba/squashfs
        $(call Image/Build/UbinizeImage,armada-xp-mamba,,squashfs, -p 128KiB -m 2048 -s 512)