Make lzma-loader sdram mapping configurable (#1169)
authorEugene Konev <ejka@imfi.kspu.ru>
Sun, 18 Mar 2007 09:32:22 +0000 (09:32 +0000)
committerEugene Konev <ejka@imfi.kspu.ru>
Sun, 18 Mar 2007 09:32:22 +0000 (09:32 +0000)
SVN-Revision: 6598

target/linux/generic-2.6/image/lzma-loader/src/Makefile
target/linux/generic-2.6/image/lzma-loader/src/decompress.c
target/linux/generic-2.6/image/lzma-loader/src/start.S

index dbe9019f2bd1490391b740ac1d1b974ab68d4745..13ed96213e6ba557166766ee91c5eee9b94a7b05 100644 (file)
@@ -4,15 +4,16 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+RAMSTART = 0x80000000
+RAMSIZE = 0x00100000           # 1MB
 LOADADDR = 0x80400000          # RAM start + 4M
 KERNEL_ENTRY = 0x80001000
-RAMSIZE = 0x00100000           # 1MB
 IMAGE_COPY:=0
 
 CROSS_COMPILE = mips-linux-
 
 OBJCOPY:= $(CROSS_COMPILE)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S
-CFLAGS := -fno-builtin -Os -G 0 -ffunction-sections -mno-abicalls -fno-pic -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap -Wall -DRAMSIZE=${RAMSIZE} -DKERNEL_ENTRY=${KERNEL_ENTRY} -D_LZMA_IN_CB
+CFLAGS := -fno-builtin -Os -G 0 -ffunction-sections -mno-abicalls -fno-pic -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap -Wall -DRAMSTART=${RAMSTART} -DRAMSIZE=${RAMSIZE} -DKERNEL_ENTRY=${KERNEL_ENTRY} -D_LZMA_IN_CB
 ifeq ($(IMAGE_COPY),1)
 CFLAGS += -DLOADADDR=${LOADADDR} -DIMAGE_COPY=1
 endif
index 4ed432d1a502a62883b9f141b26fd199f6b1f221..45ac509cdc49a46c196aab591889195ffa28cf96 100644 (file)
@@ -96,7 +96,10 @@ static __inline__ unsigned char get_byte(void)
        return read_byte(0, &buffer, &fake), *buffer;
 }
 
-static char *buffer = (char *)0x80C00000;
+/* This puts lzma workspace 128k below RAM end. 
+ * That should be enough for both lzma and stack
+ */
+static char *buffer = (char *)(RAMSTART + RAMSIZE - 0x00020000);
 extern char lzma_start[];
 extern char lzma_end[];
 
index 9a85c4c3572f8fa66aa8750f651b20224953e9df..864293379f762e8258f2e96c7396d2701349aace 100644 (file)
@@ -41,7 +41,7 @@ LEAF(_start)
        move t7, a3
        
        /* set up stack */
-       li      sp, 0xa0000000 + RAMSIZE - 16
+       li      sp, RAMSTART + RAMSIZE - 16
 
 #ifdef IMAGE_COPY
        /* Copy decompressor code to the right place */