kernel: bump 5.10 to 5.10.85
authorJohn Audia <graysky@archlinux.us>
Tue, 14 Dec 2021 11:15:08 +0000 (06:15 -0500)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 17 Dec 2021 14:10:22 +0000 (15:10 +0100)
Removed target for patch which does not exist:
    bcm27xx/patches-5.10/950-0249-kbuild-Disable-gcc-plugins.patch

All patches automatically rebased.

Build system: x86_64
Build-tested: bcm2711/RPi4B, ipq806x/R7800*
Run-tested: bcm2711/RPi4B, ipq806x/R7800*

* Had to revert 7f1edbd41295dff9f2127b169fbc086c0fb2c14e in order to build
  (binutils 2.37, https://bugs.openwrt.org/index.php?do=details&task_id=4149)

Signed-off-by: John Audia <graysky@archlinux.us>
12 files changed:
include/kernel-version.mk
target/linux/bcm27xx/patches-5.10/950-0139-xhci-implement-xhci_fixup_endpoint-for-interval-adju.patch
target/linux/bcm27xx/patches-5.10/950-0151-hid-usb-Add-device-quirks-for-Freeway-Airmouse-T3-an.patch
target/linux/bcm27xx/patches-5.10/950-0249-kbuild-Disable-gcc-plugins.patch [deleted file]
target/linux/bcm27xx/patches-5.10/950-0323-media-i2c-Add-driver-for-Sony-IMX477-sensor.patch
target/linux/bcm27xx/patches-5.10/950-0657-Documentation-devicetree-Add-documentation-for-imx37.patch
target/linux/bcm27xx/patches-5.10/950-0733-usb-xhci-workaround-for-bogus-SET_DEQ_PENDING-endpoi.patch
target/linux/generic/backport-5.10/610-v5.13-57-netfilter-flowtable-Set-offload-timeouts-according-t.patch
target/linux/generic/backport-5.10/732-net-next-1-of-net-pass-the-dst-buffer-to-of_get_mac_address.patch
target/linux/generic/pending-5.10/834-ledtrig-libata.patch
target/linux/oxnas/patches-5.10/999-libata-hacks.patch
target/linux/realtek/patches-5.10/008-5.17-watchdog-add-realtek-otto-watchdog-timer.patch

index 9d5d278e86919adbfa6ca75ed12dc01af8056296..4394dd09003928d4bdce3c7276dcd43c09c974ce 100644 (file)
@@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-5.4 = .167
-LINUX_VERSION-5.10 = .84
+LINUX_VERSION-5.10 = .85
 
 LINUX_KERNEL_HASH-5.4.167 = b4e43116217ee02009aba7eab3081e64560b81ce42bc6096fcd81257f470a5a7
-LINUX_KERNEL_HASH-5.10.84 = 6e96271d72dd106c4bd83931ca16fda622413b34c5649e2916116c38c12e233d
+LINUX_KERNEL_HASH-5.10.85 = ba89162605ac447db8953c29f649b64d16aff7de8145e2db30d759e5476b19ac
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index dfd6e89b3d7b7adc7a780c2bd3331b53e96a42b6..6cc7482115b7541bd978c30cbc29c34c9794a4ee 100644 (file)
@@ -119,7 +119,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
   * non-error returns are a promise to giveback() the urb later
   * we drop ownership so next owner (or urb unlink) can get it
   */
-@@ -5366,6 +5463,7 @@ static const struct hc_driver xhci_hc_dr
+@@ -5370,6 +5467,7 @@ static const struct hc_driver xhci_hc_dr
        .endpoint_reset =       xhci_endpoint_reset,
        .check_bandwidth =      xhci_check_bandwidth,
        .reset_bandwidth =      xhci_reset_bandwidth,
index 217b2117d49d24ecc7b387cf1d43ca7f406ae34a..fa76e0a8229459485cace871eb3897a1bb610b9b 100644 (file)
@@ -33,7 +33,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
  #define USB_VENDOR_ID_BELKIN          0x050d
  #define USB_DEVICE_ID_FLIP_KVM                0x3201
  
-@@ -1268,6 +1271,9 @@
+@@ -1270,6 +1273,9 @@
  #define USB_VENDOR_ID_XAT     0x2505
  #define USB_DEVICE_ID_XAT_CSR 0x0220
  
@@ -53,7 +53,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
        { HID_USB_DEVICE(USB_VENDOR_ID_CHICONY, USB_DEVICE_ID_CHICONY_MULTI_TOUCH), HID_QUIRK_MULTI_INPUT },
        { HID_USB_DEVICE(USB_VENDOR_ID_CHICONY, USB_DEVICE_ID_CHICONY_PIXART_USB_OPTICAL_MOUSE), HID_QUIRK_ALWAYS_POLL },
        { HID_USB_DEVICE(USB_VENDOR_ID_CHICONY, USB_DEVICE_ID_CHICONY_PIXART_USB_OPTICAL_MOUSE2), HID_QUIRK_ALWAYS_POLL },
-@@ -193,6 +194,7 @@ static const struct hid_device_id hid_qu
+@@ -194,6 +195,7 @@ static const struct hid_device_id hid_qu
        { HID_USB_DEVICE(USB_VENDOR_ID_WISEGROUP, USB_DEVICE_ID_QUAD_USB_JOYPAD), HID_QUIRK_NOGET | HID_QUIRK_MULTI_INPUT },
        { HID_USB_DEVICE(USB_VENDOR_ID_XIN_MO, USB_DEVICE_ID_XIN_MO_DUAL_ARCADE), HID_QUIRK_MULTI_INPUT },
        { HID_USB_DEVICE(USB_VENDOR_ID_LOGITECH, USB_DEVICE_ID_LOGITECH_GROUP_AUDIO), HID_QUIRK_NOGET },
diff --git a/target/linux/bcm27xx/patches-5.10/950-0249-kbuild-Disable-gcc-plugins.patch b/target/linux/bcm27xx/patches-5.10/950-0249-kbuild-Disable-gcc-plugins.patch
deleted file mode 100644 (file)
index f3a0b33..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-From 4c6ffdf90a3a982fa11676faf658eebfd000867b Mon Sep 17 00:00:00 2001
-From: Phil Elwell <phil@raspberrypi.com>
-Date: Wed, 8 Apr 2020 15:23:56 +0100
-Subject: [PATCH] kbuild: Disable gcc plugins
-
-The GCC plugin feature leads to different kernel configurations on what
-ought to be equivalent build systems because they depend on the build
-hosts native compilers rather than the cross compilers needed for the
-target. This causes problems with module symbol version mismatches.
-
-Disable GCC plugins for all build hosts.
-
-Advanced build script hackery borrowed from a patch by milhouse.
-
-Signed-off-by: Phil Elwell <phil@raspberrypi.com>
----
- scripts/gcc-plugin.sh | 1 +
- 1 file changed, 1 insertion(+)
-
---- a/scripts/gcc-plugin.sh
-+++ b/scripts/gcc-plugin.sh
-@@ -1,5 +1,6 @@
- #!/bin/sh
- # SPDX-License-Identifier: GPL-2.0
-+exit 1 # Disable plugins
- set -e
index d24d8f51e5d2d3ae4b4faf6d0e3d08396fd56f7d..bbfecb7ad62f943d5bc84dec7ec99c8d1140ad62 100644 (file)
@@ -25,7 +25,7 @@ Signed-off-by: Naushir Patuck <naush@raspberrypi.com>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -16347,6 +16347,14 @@ S:    Maintained
+@@ -16346,6 +16346,14 @@ S:    Maintained
  T:    git git://linuxtv.org/media_tree.git
  F:    drivers/media/i2c/imx355.c
  
index 4116fa11c46e14ff2ac81596ead9fa4056c25133..cd2c028d5e15d091b920b2b0460a7e0c61c37bf0 100644 (file)
@@ -132,7 +132,7 @@ Signed-off-by: David Plowman <david.plowman@raspberrypi.com>
 +...
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -16361,6 +16361,7 @@ M:     Raspberry Pi Kernel Maintenance <kern
+@@ -16360,6 +16360,7 @@ M:     Raspberry Pi Kernel Maintenance <kern
  L:    linux-media@vger.kernel.org
  S:    Maintained
  T:    git git://linuxtv.org/media_tree.git
index 830616612778d6fcb3982350b4d361c5e471bce4..c0a4caad4bfad318d4766932a78feaa784579000 100644 (file)
@@ -26,7 +26,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
 
 --- a/drivers/usb/host/xhci-ring.c
 +++ b/drivers/usb/host/xhci-ring.c
-@@ -4269,9 +4269,9 @@ void xhci_queue_new_dequeue_state(struct
+@@ -4268,9 +4268,9 @@ void xhci_queue_new_dequeue_state(struct
        }
        ep = &xhci->devs[slot_id]->eps[ep_index];
        if ((ep->ep_state & SET_DEQ_PENDING)) {
index 5410e2751a91d0e9c620ef1160ed23203639acdf..1e82308eaa64510a0c001003d79ba06c4a24ec87 100644 (file)
@@ -64,8 +64,8 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
                return;
 +      }
  
-       if (nf_flow_timeout_delta(ct->timeout) > (__s32)timeout)
-               ct->timeout = nfct_time_stamp + timeout;
+       if (nf_flow_timeout_delta(READ_ONCE(ct->timeout)) > (__s32)timeout)
+               WRITE_ONCE(ct->timeout, nfct_time_stamp + timeout);
 @@ -265,11 +268,35 @@ static const struct rhashtable_params nf
        .automatic_shrinking    = true,
  };
index 196ff1dcba574031040cc04f46acbcc1a99339ea..794d87dc6e4d0acadbda2b6fcb42b8fcf5b1ccac 100644 (file)
@@ -272,7 +272,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        void __iomem *descmap;
        const struct of_device_id *of_id = NULL;
  
-@@ -1525,10 +1524,8 @@ static int altera_tse_probe(struct platf
+@@ -1528,10 +1527,8 @@ static int altera_tse_probe(struct platf
        priv->rx_dma_buf_sz = ALTERA_RXDMABUFFER_SIZE;
  
        /* get default MAC address from device tree */
index fddec74d9692f918b2e23313bcc01566067c4cec..e43a97bfe8ac3dd73d7ba355945c937cb31d9af7 100644 (file)
@@ -65,7 +65,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
-@@ -4545,6 +4558,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -4547,6 +4560,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
                if (tag < 0)
                        return NULL;
        }
@@ -75,7 +75,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
        qc = __ata_qc_from_tag(ap, tag);
        qc->tag = qc->hw_tag = tag;
-@@ -5323,6 +5339,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -5325,6 +5341,9 @@ struct ata_port *ata_port_alloc(struct a
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
@@ -85,7 +85,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        ata_sff_port_init(ap);
  
        return ap;
-@@ -5358,6 +5377,12 @@ static void ata_host_release(struct kref
+@@ -5360,6 +5379,12 @@ static void ata_host_release(struct kref
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
@@ -98,7 +98,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                kfree(ap);
                host->ports[i] = NULL;
        }
-@@ -5764,7 +5789,23 @@ int ata_host_register(struct ata_host *h
+@@ -5766,7 +5791,23 @@ int ata_host_register(struct ata_host *h
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }
index e34891cbb6790488c081ff4ab079b574de7a0463..61c0c045a68ea9d389d145e97fb6fa2b5488e87b 100644 (file)
@@ -15,7 +15,7 @@
        /* initialize internal qc */
        qc = __ata_qc_from_tag(ap, ATA_TAG_INTERNAL);
  
-@@ -4552,6 +4560,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -4554,6 +4562,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
        if (unlikely(ap->pflags & ATA_PFLAG_FROZEN))
                return NULL;
  
@@ -25,7 +25,7 @@
        /* libsas case */
        if (ap->flags & ATA_FLAG_SAS_HOST) {
                tag = ata_sas_allocate_tag(ap);
-@@ -4597,6 +4608,8 @@ void ata_qc_free(struct ata_queued_cmd *
+@@ -4599,6 +4610,8 @@ void ata_qc_free(struct ata_queued_cmd *
                qc->tag = ATA_TAG_POISON;
                if (ap->flags & ATA_FLAG_SAS_HOST)
                        ata_sas_free_tag(tag, ap);
index 9b06a3e3186290e24c462dedd885585440be9084..cc5ee924669e16764dd6dde4db8e90f33bece5d7 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Guenter Roeck <linux@roeck-us.net>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -14815,6 +14815,13 @@ S:    Maintained
+@@ -14814,6 +14814,13 @@ S:    Maintained
  F:    include/sound/rt*.h
  F:    sound/soc/codecs/rt*