kernel: add thermal monitor for nct6775/6776
authorPhilip Prindeville <philipp@redfish-solutions.com>
Mon, 9 Jan 2017 04:08:47 +0000 (21:08 -0700)
committerJohn Crispin <john@phrozen.org>
Fri, 7 Apr 2017 15:41:21 +0000 (17:41 +0200)
Support for the nct6775/6776 hwmon chips, and other compatibles
in the family as well as the Intel on-chip thermal sensors.

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
package/kernel/linux/modules/hwmon.mk

index b39a2e2fe8e35c0b0a74861d9e99368313e05574..79c81846c635479097589c8bffd360e6cea96442 100644 (file)
@@ -93,6 +93,21 @@ endef
 $(eval $(call KernelPackage,hwmon-ina209))
 
 
+define KernelPackage/hwmon-nct6775
+  TITLE:=NCT6106D/6775F/6776F/6779D/6791D/6792D/6793D and compatibles monitoring support
+  KCONFIG:=CONFIG_SENSORS_NCT6775
+  FILES:=$(LINUX_DIR)/drivers/hwmon/nct6775.ko
+  AUTOLOAD:=$(call AutoProbe,nct6775)
+  $(call AddDepends/hwmon,@PCI_SUPPORT @TARGET_x86 +kmod-hwmon-vid)
+endef
+
+define KernelPackage/hwmon-nct6775/description
+ Kernel module for NCT6106D/6775F/6776F/6779D/6791D/6792D/6793D thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-nct6775))
+
+
 define KernelPackage/hwmon-ina2xx
   TITLE:=INA2XX monitoring support
   KCONFIG:=CONFIG_SENSORS_INA2XX