Add admswconfig until we add support for adm5120 switch in kmod-switch, thanks Thomas...
authorFlorian Fainelli <florian@openwrt.org>
Thu, 19 Apr 2007 13:19:37 +0000 (13:19 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 19 Apr 2007 13:19:37 +0000 (13:19 +0000)
SVN-Revision: 7007

package/admswconfig/Makefile [new file with mode: 0644]

diff --git a/package/admswconfig/Makefile b/package/admswconfig/Makefile
new file mode 100644 (file)
index 0000000..ab40770
--- /dev/null
@@ -0,0 +1,48 @@
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=admswconfig
+PKG_VERSION:=0.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://sharon.esrac.ele.tue.nl/users/pe1rxq/linux-adm/admswconfig/
+PKG_MD5SUM:=3d00efbff699af8a4d3179becd881b1e
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/admswconfig
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=ADM5120 Switch configuration tool
+  DEPENDS:=@LINUX_2_6_ADM5120 || @LINUX_2_6_ADM5120EB
+  DESCRIPTION:=\
+       A program to configure the internal ethernet switch of an ADM5120 processor. \\\
+       You need the corresponding driver for the switch in the kernel. \\\
+       with this program you can configure which ports of the switch belong \\\
+       to the different ethernet devices.
+  URL:=http://sharon.esrac.ele.tue.nl/users/pe1rxq/linux-adm/admswconfig/
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+       $(TARGET_CC) $(TARGET_CFLAGS) -Os $(PKG_BUILD_DIR)/admswconfig.c -o $(PKG_BUILD_DIR)/$(PKG_NAME)
+endef
+
+define Package/admswconfig/install
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/admswconfig $(1)/sbin/
+endef
+
+$(eval $(call BuildPackage,admswconfig))