procd: Allow boot messages to be sent to console
authorJohn Crispin <john@openwrt.org>
Thu, 30 Oct 2014 10:10:45 +0000 (10:10 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 30 Oct 2014 10:10:45 +0000 (10:10 +0000)
update to latest git HEAD, adds "log to console"

Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 43118

package/system/procd/Makefile

index 734b44467bcc24a1bef4d4f14305fe07909b7715..0065bee85013eed648308fb947b2b6059887b45c 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procd
-PKG_VERSION:=2014-10-14
+PKG_VERSION:=2014-10-30
 
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=b9a389c841db8433bb3b02158b1512cf577dbff7
+PKG_SOURCE_VERSION:=07c7864d49723b1264ee8bcd6861ea92f679ee98
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1
 
@@ -43,6 +43,23 @@ define Package/procd-nand
   TITLE:=OpenWrt sysupgrade nand helper
 endef
 
+define Package/procd/config
+menu "Configuration"
+       depends on PACKAGE_procd
+
+config PROCD_SHOW_BOOT
+       bool
+       default n
+       prompt "Print the shutdown to the console as well as logging it to syslog"
+endmenu
+endef
+
+PKG_CONFIG_DEPENDS:= PROCD_SHOW_BOOT
+
+ifeq ($(CONFIG_PACKAGE_PROCD_SHOW_BOOT),y)
+  CMAKE_OPTIONS += -DSHOW_BOOT_ON_CONSOLE
+endif
+
 define Package/procd/install
        $(INSTALL_DIR) $(1)/sbin $(1)/etc $(1)/lib/functions