downloads.mk: introduce name-agnostic PROJECT_GIT variable
authorJo-Philipp Wich <jo@mein.io>
Fri, 5 Jan 2018 09:43:55 +0000 (10:43 +0100)
committerJo-Philipp Wich <jo@mein.io>
Wed, 10 Jan 2018 20:27:31 +0000 (21:27 +0100)
Introduce a name-agnostic PROJECT_GIT variable poiting to
https://git.openwrt.org/ and declare LEDE_GIT and OPENWRT_GIT
as aliases to it.

After some transition time we can drop this alias variables.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
include/download.mk

index 0a25641738413379736c65b8e73938b2b51003d6..2ba8a7bdf48e6f0a2ef8a5076b941ded58821555 100644 (file)
@@ -6,8 +6,10 @@
 # See /LICENSE for more information.
 #
 
-OPENWRT_GIT = http://git.openwrt.org
-LEDE_GIT = https://git.lede-project.org
+PROJECT_GIT = https://git.openwrt.org
+
+OPENWRT_GIT = $(PROJECT_GIT)
+LEDE_GIT = $(PROJECT_GIT)
 
 ifdef PKG_SOURCE_VERSION
 PKG_VERSION ?= $(if $(PKG_SOURCE_DATE),$(PKG_SOURCE_DATE)-)$(call version_abbrev,$(PKG_SOURCE_VERSION))