hostapd: disable support for Wired Equivalent Privacy by default
authorPetr Štetiar <ynezz@true.cz>
Mon, 4 May 2020 08:14:32 +0000 (10:14 +0200)
committerPetr Štetiar <ynezz@true.cz>
Thu, 21 May 2020 06:18:01 +0000 (08:18 +0200)
Upstream in commit 200c7693c9a1 ("Make WEP functionality an optional
build parameter") has made WEP functionality an optional build parameter
disabled as default, because WEP should not be used for anything
anymore. As a step towards removing it completely, they moved all WEP
related functionality behind CONFIG_WEP blocks and disabled it by
default.

This functionality is subject to be completely removed in a future
release.

So follow this good security advice, deprecation notice and disable WEP
by default, but still allow custom builds with WEP support via
CONFIG_WPA_ENABLE_WEP config option till upstream removes support for
WEP completely.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/network/services/hostapd/Config.in
package/network/services/hostapd/Makefile

index 9dfa44e3132d67174eacdd4fd279bde0c6a8dca9..2cdd1ed9701b1adda2c18101fa40cafbd3ec62a1 100644 (file)
@@ -73,3 +73,12 @@ config DRIVER_11AC_SUPPORT
 config DRIVER_11W_SUPPORT
        bool
        default n
+
+config WPA_ENABLE_WEP
+       bool "Enable support for unsecure and obsolete WEP"
+       help
+         Wired equivalent privacy (WEP) is an obsolete cryptographic data
+         confidentiality algorithm that is not considered secure. It should not be used
+         for anything anymore. The functionality needed to use WEP is available in the
+         current hostapd release under this optional build parameter and completely
+         removed in a future release.
index b4b70a3d6f251f2994c41aed0b7aeae94b4e1d5e..a2c5a34f2f7af113d5d9e1509c6d9f0a490f64c9 100644 (file)
@@ -32,6 +32,7 @@ PKG_CONFIG_DEPENDS:= \
        CONFIG_DRIVER_WEXT_SUPPORT \
        CONFIG_DRIVER_11N_SUPPORT \
        CONFIG_DRIVER_11AC_SUPPORT \
+       CONFIG_WPA_ENABLE_WEP
 
 EAPOL_TEST_PROVIDERS:=eapol-test eapol-test-openssl eapol-test-wolfssl
 
@@ -445,6 +446,10 @@ ifdef CONFIG_PACKAGE_kmod-cfg80211
   TARGET_LDFLAGS += -lm -lnl-tiny
 endif
 
+ifdef CONFIG_WPA_ENABLE_WEP
+    DRIVER_MAKEOPTS += CONFIG_WEP=y
+endif
+
 define Build/RunMake
        CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
        $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR)/$(1) \