netsupport: package L2TPv3 over IPv6 as well
authorSteven Barth <cyrus@openwrt.org>
Sat, 2 May 2015 07:44:47 +0000 (07:44 +0000)
committerSteven Barth <cyrus@openwrt.org>
Sat, 2 May 2015 07:44:47 +0000 (07:44 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
SVN-Revision: 45593

package/kernel/linux/modules/netsupport.mk

index 547e429f093204588ec05358d04992efe508b92a..7ec3d29792d7118d800735f5f04718ea3883e0fb 100644 (file)
@@ -895,11 +895,11 @@ $(eval $(call KernelPackage,l2tp-eth))
 
 define KernelPackage/l2tp-ip
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
-  TITLE:=L2TP IP encapsulation for L2TPv3
-  DEPENDS:=+kmod-l2tp
+  TITLE:=L2TP IP + IPv6 encapsulation for L2TPv3
+  DEPENDS:=+kmod-l2tp +kmod-ipv6
   KCONFIG:=CONFIG_L2TP_IP
-  FILES:=$(LINUX_DIR)/net/l2tp/l2tp_ip.ko
-  AUTOLOAD:=$(call AutoLoad,33,l2tp_ip)
+  FILES:=$(LINUX_DIR)/net/l2tp/l2tp_ip.ko $(LINUX_DIR)/net/l2tp/l2tp_ip6.ko
+  AUTOLOAD:=$(call AutoLoad,33,l2tp_ip l2tp_ip6)
 endef
 
 define KernelPackage/l2tp-ip/description