brcm2708: fix renamed definition (FS#2265)
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 3 May 2019 14:13:19 +0000 (16:13 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 3 May 2019 14:37:48 +0000 (16:37 +0200)
This target adds an alternative mmc driver using a patch.
Within this patch, a definition got renamed upstream.

Change it to fix following compile error:

  CC      drivers/mmc/host/bcm2835-mmc.o
In file included from ./include/linux/kernel.h:14:0,
                 from ./include/linux/delay.h:22,
                 from drivers/mmc/host/bcm2835-mmc.c:25:
drivers/mmc/host/bcm2835-mmc.c: In function 'bcm2835_mmc_dumpregs':
drivers/mmc/host/bcm2835-mmc.c:254:27: error: 'SDHCI_ACMD12_ERR' undeclared (first use in this function); did you mean 'SDHCI_CMD_CRC'?
   bcm2835_mmc_readw(host, SDHCI_ACMD12_ERR),
                           ^
./include/linux/printk.h:137:18: note: in definition of macro 'no_printk'
    printk(fmt, ##__VA_ARGS__); \
                  ^~~~~~~~~~~
drivers/mmc/host/bcm2835-mmc.c:253:2: note: in expansion of macro 'pr_debug'
  pr_debug(DRIVER_NAME ": AC12 err: 0x%08x | Slot int: 0x%08x\n",
  ^~~~~~~~
drivers/mmc/host/bcm2835-mmc.c:254:27: note: each undeclared identifier is reported only once for each function it appears in
   bcm2835_mmc_readw(host, SDHCI_ACMD12_ERR),
                           ^
./include/linux/printk.h:137:18: note: in definition of macro 'no_printk'
    printk(fmt, ##__VA_ARGS__); \
                  ^~~~~~~~~~~
drivers/mmc/host/bcm2835-mmc.c:253:2: note: in expansion of macro 'pr_debug'
  pr_debug(DRIVER_NAME ": AC12 err: 0x%08x | Slot int: 0x%08x\n",
  ^~~~~~~~
scripts/Makefile.build:326: recipe for target 'drivers/mmc/host/bcm2835-mmc.o' failed
make[8]: *** [drivers/mmc/host/bcm2835-mmc.o] Error 1

Upstream commit:
https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v4.14.114&id=45fd8679ea86bffb352132a1df4917c3d11375aa

Fixes: b765f4be407c ("kernel: bump 4.14 to 4.14.114")
Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
target/linux/brcm2708/patches-4.14/950-0040-MMC-added-alternative-MMC-driver.patch

index f10a1d3c791491a70f9129c0d4a5ae1612519c71..fd73461f415608f4f306ee618ba43e209fcea35f 100644 (file)
@@ -521,7 +521,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 +              bcm2835_mmc_readl(host, SDHCI_INT_ENABLE),
 +              bcm2835_mmc_readl(host, SDHCI_SIGNAL_ENABLE));
 +      pr_debug(DRIVER_NAME ": AC12 err: 0x%08x | Slot int: 0x%08x\n",
-+              bcm2835_mmc_readw(host, SDHCI_ACMD12_ERR),
++              bcm2835_mmc_readw(host, SDHCI_AUTO_CMD_STATUS),
 +              bcm2835_mmc_readw(host, SDHCI_SLOT_INT_STATUS));
 +      pr_debug(DRIVER_NAME ": Caps:     0x%08x | Caps_1:   0x%08x\n",
 +              bcm2835_mmc_readl(host, SDHCI_CAPABILITIES),